Subject: [CODE4LIB] Fedora-commons repositories

From: Tim Cornwell <[email-masked]>
Date: Wed, 6 May 2009 08:50:15 -0400

(thought it better to have a subject line)

By way of a response to Etienne's request to hear from other fedora-commons 
development, and our own announcement:

The NSDL technical network services group (TNS) has released it's own set of tools for
repository management based on a fedora-commons back end.

At http://ncore.nsdl.org/ you can find information about EduPak
(http://ncore.nsdl.org/index.php?menu=services&submenu=services!EduPak)

The EduPak bundle (http://sourceforge.net/projects/nsdl-core/) includes a catalog
management and search/discovery tool integrated with a fedora-commons-backed repository
along with a generalized fedora-commons API for handling resource references and metadata
objects.  

The fedora-commons project has two complete OAI services already, but the MOAI service
looks like OAI aggregator heaven.

Tim

---

From: David Kennedy <[email-masked]>
Date: Wed, 6 May 2009 09:30:52 -0400

Tim,

Is there documentation available for the generalized fedora-commons API?

Thanks
Dave

-----
David Kennedy
Systems Programmer
Perkins Library, Duke University
(919) 613-6831
[email-masked]

Tim Cornwell <[email-masked]> 
Sent by: Code for Libraries <[email-masked]>
05/06/2009 08:53 AM
Please respond to
[email-masked]

To
[email-masked]
cc

Subject
[CODE4LIB] Fedora-commons repositories

By way of a response to Etienne's request to hear from other 
fedora-commons 
development, and our own announcement:

The NSDL technical network services group (TNS) has released it's own set 
of tools for
repository management based on a fedora-commons back end.

The EduPak bundle (http://sourceforge.net/projects/nsdl-core/) includes a 
catalog
management and search/discovery tool integrated with a 
fedora-commons-backed repository
along with a generalized fedora-commons API for handling resource 
references and metadata
objects. 

The fedora-commons project has two complete OAI services already, but the 
MOAI service
looks like OAI aggregator heaven.

Tim

---

From: Tim Cornwell <[email-masked]>
Date: Wed, 6 May 2009 09:38:34 -0400

Yes.  A bit hard to find, but via the "Repository" link at the Ncore.nsdl.org site's
"Services" selection (http://ncore.nsdl.org/index.php?menu=services)

Documentation for the generalized fedora-commons API:

http://wiki.nsdl.org/index.php/Community:NDR 

What we call the "NDR" is the fedora-commons repository with our data model overlay

-Tim

> -----Original Message-----
> From: Code for Libraries [mailto:[email-masked]] On 
> Behalf Of David Kennedy
> Sent: Wednesday, May 06, 2009 9:31 AM
> To: [email-masked]
> Subject: Re: [CODE4LIB] Fedora-commons repositories
> 
> Tim,
> 
> The EduPak bundle 
> (http://sourceforge.net/projects/nsdl-core/) includes a 
> catalog