Subject: [CODE4LIB] Code4Lib 2009 Video

From: jean rainwater <[email-masked]>
Date: Fri, 15 May 2009 07:16:25 -0400

Video for Code4Lib 2009 presentations and lightning talks is now available.

Presentations:  http://code4lib.org/conference/2009/schedule
Lightning Talks: http://code4lib.org/conference/2009/lightning

Thanks to Talis for sponsoring a camera operator and post-processing!
Thanks to Karen Schneider for bringing and operating the second camera!

Video will be uploaded to Internet Archive soon.

Jean Rainwater
Co-Leader, Integrated Technology Services
Brown University Library
Providence, Rhode Island 02912
401.863.9031
[email-masked]

---

From: Mike Taylor <[email-masked]>
Date: Fri, 15 May 2009 12:38:53 +0100

> Lightning Talks: http://code4lib.org/conference/2009/lightning

Thanks for these.  When I look at them with totem, I get only an audio
stream.  Is there video in there -- is it just that my software is
broken?

 > Thanks to Talis for sponsoring a camera operator and
 > post-processing!  Thanks to Karen Schneider for bringing and
 > operating the second camera!
 > 

Hopefully that version will be in a format that I can watch!

Thanks,

 _/|_	 ___________________________________________________________________
/o ) \/  Mike Taylor    <[email-masked]>    http://www.miketaylor.org.uk
)_v__/\  "Two fat blokes in pub / First fat bloke says, "Your round,
	 mate" / Friend says, "So are you" -- my favourite short joke,
	 in Haiku form.

---

From: Karen Schneider <[email-masked]>
Date: Fri, 15 May 2009 07:44:04 -0400

> stream.  Is there video in there -- is it just that my software is

Reporting the same problem (but thanks for all your work on this!)

-- 
| Karen G. Schneider
| Community Librarian
| Equinox Software Inc. "The Evergreen Experts"
| Toll-free: 1.877.Open.ILS (1.877.673.6457) x712
| [email-masked]
| Web: http://www.esilibrary.com
| Be a part of the Evergreen International Conference, May 20-22, 2009!
| http://www.lyrasis.org/evergreen

---

From: Thomas Dowling <[email-masked]>
Date: Fri, 15 May 2009 08:03:32 -0400

> stream.  Is there video in there -- is it just that my software is

It played okay for me in both Totem and VLC, so it may be a version problem.
It seems that stream 0 is the audio and stream 1 the video, which (AFAICR) is
the reverse of most video files.

-- 
Thomas Dowling

---

From: "Ziso, Ya'aqov" <[email-masked]>
Date: Sat, 16 May 2009 13:03:36 -0400

As our users and we are having fun with vuFIND, I'm taking stock after 1-2 years of working with vuFIND, to send out a few general questions,

   1. is vuFIND primarily an experiment? if not why haven’t more sites switched to production like VU or NLA?
   2. is SOLR indexing satisfactory?
   3. how many staff are needed for vuFIND’s viable maintenance? for developing/adding features?
   4. do we want vuFIND to measure up to the ILS (Voyager, Aleph, III, etc.) OPAC,  or we like it as an alternative, for its discovery tools?
   5. what is plan B at your institution for when the vuFIND guru leaves?
   6. do we need someone to co-work with Andrew on the installation package? on keeping track of developments, road maps?
   7. which collections, other than the catalog and OAI/repositories have we added? which API to other collections have we installed? are now tested?

I’m sure many of us cope with these questions and could benefit from the variety of our replies. Kindest thanks,
Ya’aqov Ziso, Electronic Resource Management Librarian, Rowan University 856 256 4804

---

From: Jill Ellern <[email-masked]>
Date: Mon, 18 May 2009 15:52:17 -0400

Hey Code4Lib folks,

Not sure if there are any Clio ILL software users in the Code4Lib group...but we are interested in getting Clio to pull emails from the ClioAdvanced email more often.  We are thinking there must be a windows macro/scripting program on top of Clio (which is an MS Access application for those not familiar with it) would be the best idea.  Right now, it needs human intervention to run the menu option to pop these requests into Clio...and they only do it once or twice a day.  We want this menu option in Clio to run every 15-20 minutes all day. However, we are not familiar with what programs are out there that would be good to look at.  Can you folks make a suggestion?  Has anyone done this already with Clio?

Thanks,

Jill Ellern
Systems Librarian 
Western Carolina University

---

From: "Houghton,Andrew" <[email-masked]>
Date: Mon, 18 May 2009 16:12:44 -0400

> From: Code for Libraries [mailto:[email-masked]] On Behalf Of
> Jill Ellern
> Sent: Monday, May 18, 2009 3:52 PM
> To: [email-masked]
> Subject: [CODE4LIB] A simple windows macro program?
> 
> Hey Code4Lib folks,
> 
> Not sure if there are any Clio ILL software users in the Code4Lib
> group...but we are interested in getting Clio to pull emails from the
> ClioAdvanced email more often.  We are thinking there must be a windows
> macro/scripting program on top of Clio (which is an MS Access
> application for those not familiar with it) would be the best idea.
> Right now, it needs human intervention to run the menu option to pop
> these requests into Clio...and they only do it once or twice a day.  We
> want this menu option in Clio to run every 15-20 minutes all day.
> However, we are not familiar with what programs are out there that
> would be good to look at.  Can you folks make a suggestion?  Has anyone
> done this already with Clio?

I'm not familiar with Clio, but have used MS Access extensively over
the years.  It is quite possible, since Clio is using MS Access that
they have VBA macros to accomplish various tasks.  If the macros are
not encrypted, you might be able to modify them to suit your needs.

Alternately, you could write a VB.NET or C# application that uses 
ADO.NET to open the Clio MS Access database every 15-20 minutes pull 
the information from ADO.NET and push it to your e-mail solution.  
Microsoft Express tools, e.g., VB.NET Express, C# Express, etc. can 
be freely downloaded and used.

Hope this helps, Andy.

---

From: Kyle Banerjee <[email-masked]>
Date: Mon, 18 May 2009 13:31:20 -0700

I'm not familiar with the particulars of clio, but it sounds like you
could use autoit to do what you want. Be aware that automating user
interfaces is not so reliable, you'll need to get it to work with
windows scheduled tasks, and you have the additional problem of not
being able to use the machine for other things.

Since the back end is Access, it would probably be easier and more
reliable to figure out what queries are getting executed when the menu
item is run and just invoke that as a scheduled task.

For another possibility, can all the necessary menu options be invoked
with keystrokes? If yes, you may be able to just use the very low tech
but useful Windows Scripting Host (built right into windows) to do
what you want.

For example, take the following lines below, save it as a text file
with a .vbs extension (e.g. test.vbs). Then just doubleclick. You'll
see the the calculator application open and add a couple numbers
together.

set WshShell = WScript.CreateObject("WScript.Shell")
WshShell.Run "calc"
WScript.Sleep 100
WshShell.AppActivate "Calculator"
WScript.Sleep 100
WshShell.SendKeys "5*"
WScript.Sleep 500
WshShell.SendKeys "2"
WScript.Sleep 500
WshShell.SendKeys "{ENTER}"

You can find how to send special characters like ALT keys (necessary
to open menus), tabs, and the like at

http://msdn.microsoft.com/en-us/library/8c6yea83(VS.85).aspx

BTW, the AppActivate name is just what appears in the title bar of the
application.

kyle

-- 
----------------------------------------------------------
Kyle Banerjee
Digital Services Program Manager
Orbis Cascade Alliance
[email-masked] / 503.999.9787

---

From: "Lovins, Daniel" <[email-masked]>
Date: Tue, 19 May 2009 16:51:01 -0400

>No intention to spoil our users and our fun with vuFIND. Just taking stock after 1-2 years of working with >vuFIND, here are few general questions,

Hi Yaaqov.

Here's my take (and I'm cc'ing several of my colleagues in case they want to add or dispute anything):

1. is vuFIND primarily an experiment? if not why haven't more sites switched to production like VU or NLA?

We consider it "beta" but still more than an experiment. We're planning enhancements this summer: regenerating our solr index with SolrMarc 2.0 (get spell checker, linked 880s, etc.), implement nightly syncs, implement patron empowerment features (CAS + MyResearch module) and add server redundancy; longer term we're planning to enhance the non-Roman script functionality, search engine optimization, and add non-MARC metadata (journal articles? Visual images? Government documents? We're still debating) .  

I would say 'yes', though there's certainly a lot of customization we'd like to do.

3. how many staff are needed for vuFIND's viable maintenance? for developing/adding features?

We've had a project manager and programmer analyst each at 50% over the past year, and smaller amounts of time allocated from usability, web design, systems, and other kinds of librarians. I would say we could have used much more (and we'll be ramping up this summer and beyond).

As others have pointed out, VuFind is already superior to traditional OPACs in certain ways: relevancy ranking is extremely powerful. Faceted navigation is great, too, but there's a lot of tweaking that needs to be done in our case. The traditional OPAC is currently better at integrating authority files and displaying complex indexes (e.g., authors sub-arranged by titles)

We're planning to continue running Voyager and VuFind in parallel. Developments are moving so fast, that it's hard to predict the landscape 5 years from now, but in the mean time, VuFind gives us an excellent open platform both for "production" and R&D.

Great idea. I think some of my Yale colleagues who are real programmers are planning to contribute code. I hope to contribute in other ways (e.g., on integration of authority files, analysis/enhancement of non-Western language functionality)

So far we've only indexed our catalog MARC data. We've done some testing of other record sets (e.g., visual image records).

I'm sure many of us cope with these questions and could benefit from the variety of our replies. Kindest thanks,

Ya'aqov Ziso, Electronic Resource Management Librarian, Rowan University 856 256 4804