Subject: [CODE4LIB] tools for massaging metadata

From: "Avila, Regina L." <[email-masked]>
Date: Thu, 9 Jul 2009 10:15:07 -0400

Can anybody share some good tools for massaging metadata? For anything from file renaming to cleaning ASCII characters to various formulas?  I know Excel does a lot of things but I'm looking for other useful software to consider. I'm familiar with Parserat, Notepad++, A Better File Rename and a few others.  Any other gems I should know?

Thanks.

_______________________________________
Regina Avila
Librarian
National Institute of Standards and Technology
301-975-3575
[email-masked]<mailto:[email-masked]>

---

From: Jon Gorman <[email-masked]>
Date: Thu, 9 Jul 2009 09:29:43 -0500

What do you mean by metadata "massaging"?  Just text editing?  What
format is this metadata in?

Sorry, you're so broad here I'm not sure where to start.

Oxygen, xml spy, emacs, vi for editing.  Countless of command line
tools (find, awk, xargs, rename, etc).

Iconv for encoding conversions and issues there.

That's off the top of my head.

Jon

---

From: Joe Atzberger <[email-masked]>
Date: Thu, 9 Jul 2009 10:41:35 -0400

On Thu, Jul 9, 2009 at 10:15 AM, Avila, Regina L. <[email-masked]>wrote:

> Can anybody share some good tools for massaging metadata? For anything from
> file renaming to cleaning ASCII characters to various formulas?  I know
> Excel does a lot of things but I'm looking for other useful software to
> consider. I'm familiar with Parserat, Notepad++, A Better File Rename and a
> few others.  Any other gems I should know?

Since I work mostly with MARC records:

   - MarcEdit
   - MARC::Record, MARC::Lint
   - and the more general: sed, egrep, etc.

A validator for your given data format is usually important to keeping your
data compliant.

--Joe

---

From: Joe Hourcle <[email-masked]>
Date: Thu, 9 Jul 2009 10:58:13 -0400

On Thu, 9 Jul 2009, Avila, Regina L. wrote:

> Can anybody share some good tools for massaging metadata? For anything 
> from file renaming to cleaning ASCII characters to various formulas?  I 
> know Excel does a lot of things but I'm looking for other useful 
> software to consider. I'm familiar with Parserat, Notepad++, A Better 
> File Rename and a few others.  Any other gems I should know?

What formats are you dealing with, and what platform are you on?

For text files on the Mac, I've been a long-term BBEdit user, but any text 
editor that's scriptable and supports regex replace is useful.  (you could 
always use perl or sed & awk if you wanted to automate it).

If you're working with binary data, you might need something to convert it 
to something that you can work with in other tools.

-Joe