Subject: [CODE4LIB] agile methodologies

From: susan teague-rector <[email-masked]>
Date: Wed, 18 Nov 2009 09:44:00 -0500

Anyone using agile methodologies for Web applications / projects - 
particularly user stories to define requirements for Web projects?

Thanks,
Susan

Susan Teague-Rector
Web Applications Manager
VCU Libraries

---

From: Leslie Johnston <[email-masked]>
Date: Wed, 18 Nov 2009 09:53:25 -0500

Depending on the project, we use use cases or user studies.  We've just completed collecting users studies for a new project and used them to create a system gap analysis, in preparation for creating a design document.

Leslie

----------
Leslie Johnston
Digital Media Project Coordinator
Office of Strategic Initiatives
Library of Congress
202-707-2801
[email-masked]

>>> susan teague-rector <[email-masked]> 11/18/2009 9:44 AM >>>

Thanks,
Susan

Susan Teague-Rector
Web Applications Manager
VCU Libraries

---

From: "Sarr, Nathan" <[email-masked]>
Date: Wed, 18 Nov 2009 10:08:52 -0500

Hi Susan,

   We used Use Cases which are generally a little more structured to help define the requirements for our IR+ system here at the University of Rochester - you can see our production system here: https://urresearch.rochester.edu .  They were also re-used to help with user testing of the system.

-Nate

Nathan Sarr
Senior Software Engineer
River Campus Libraries
University of Rochester
Rochester, NY  14627
(585) 275-0692

-----Original Message-----
From: Code for Libraries [mailto:[email-masked]] On Behalf Of susan teague-rector
Sent: Wednesday, November 18, 2009 9:44 AM
To: [email-masked]
Subject: [CODE4LIB] agile methodologies

Thanks,
Susan

Susan Teague-Rector
Web Applications Manager
VCU Libraries

---

From: Glen Newton <[email-masked]>
Date: Wed, 18 Nov 2009 11:05:42 -0500

> particularly user stories to define requirements for Web projects?

It might be worth your while reading Ravi Mohan's interesting "Let the
Agile Fad Flow By"  http://pindancing.blogspot.com/2009/09/let-agile-fad-flow-by.html

-- 

Glen Newton | [email-masked]
Researcher, Information Science, CISTI Research
& NRC W3C Advisory Committee Representative
http://tinyurl.com/yvchmu
tel/t l: 613-990-9163 | facsimile/t l copieur 613-952-8246
Canada Institute for Scientific and Technical Information (CISTI)
National Research Council Canada (NRC)| M-55, 1200 Montreal Road
http://www.nrc-cnrc.gc.ca/
Institut canadien de l'information scientifique et technique (ICIST) 
Conseil national de recherches Canada | M-55, 1200 chemin Montr al
Ottawa, Ontario K1A 0R6  
Government of Canada | Gouvernement du Canada   
--