Subject: [CODE4LIB] ticTOCs makes its data available to developers

From: "Bucknell, Terry" <[email-masked]>
Date: Wed, 11 Feb 2009 22:11:47 +0000

As you may know, ticTOCs is a project funded by JISC in the UK to create a single, freely available source of RSS feeds for tables of contents - see http://www.tictocs.ac.uk/ . Our database now contains over 12,000 journals from over 430 publishers. Up until now the only way to get feeds out of ticTOCs has been to use our web interface to search for feeds and then export them as an OPML file, or one at a time to a feed reader of your choice.

We are working on creating APIs to let groups like the code4lib community extract our data in more flexible ways, but it has been pointed out to us - see http://robotlibrarian.billdueber.com/tictocs-give-us-a-file-pretty-pretty-pretty-please/ - that all you really need (at least at first) is a simple tab-delimited file that contains titles, ISSNs, and feed URIs for all of the journals in tocTOCs. We now provide precisely this at http://www.tictocs.ac.uk/text.php.

We hope that you will use this data to populate your catalog, A-Z journals list or whatever with RSS feed icons/links, or embedded TOCs.  We look forward to the day when SFX, SerialsSolutions and the like are all using our data!

Although the project phase of ticTOCs is very nearly at end end, we are confident that we are very close to ensuring that the future of ticTOCs is assured for at least the next three years, and will continue to be free.

Share and enjoy.

Terry Bucknell
Electronic Resources Manager
Sydney Jones Library
University of Liverpool
Chatham St, PO Box 123
Liverpool, L69 3DA, UK
Tel: +44 (0)151 794 2692
Fax: +44 (0)151 794 2681

---

From: "Boheemen, Peter van" <[email-masked]>
Date: Thu, 12 Feb 2009 08:49:01 +0100

This is great !!! But don't forget the API !

Peter 

-----Original Message-----
From: Code for Libraries [mailto:[email-masked]] On Behalf Of
Bucknell, Terry
Sent: woensdag 11 februari 2009 23:12
To: [email-masked]
Subject: [CODE4LIB] ticTOCs makes its data available to developers

As you may know, ticTOCs is a project funded by JISC in the UK to create
a single, freely available source of RSS feeds for tables of contents -
see http://www.tictocs.ac.uk/ . Our database now contains over 12,000
journals from over 430 publishers. Up until now the only way to get
feeds out of ticTOCs has been to use our web interface to search for
feeds and then export them as an OPML file, or one at a time to a feed
reader of your choice.

We are working on creating APIs to let groups like the code4lib
community extract our data in more flexible ways, but it has been
pointed out to us - see
http://robotlibrarian.billdueber.com/tictocs-give-us-a-file-pretty-prett
y-pretty-please/ - that all you really need (at least at first) is a
simple tab-delimited file that contains titles, ISSNs, and feed URIs for
all of the journals in tocTOCs. We now provide precisely this at
http://www.tictocs.ac.uk/text.php.

We hope that you will use this data to populate your catalog, A-Z
journals list or whatever with RSS feed icons/links, or embedded TOCs.
We look forward to the day when SFX, SerialsSolutions and the like are
all using our data!

Although the project phase of ticTOCs is very nearly at end end, we are
confident that we are very close to ensuring that the future of ticTOCs
is assured for at least the next three years, and will continue to be
free.

Share and enjoy.

Terry Bucknell

---

From: "Dr R. Sanderson" <[email-masked]>
Date: Thu, 12 Feb 2009 10:03:51 +0000

How does this compare to Zetoc at Mimas, which also provides RSS feeds 
for journal ToCs?

Rob

---

From: "Bucknell, Terry" <[email-masked]>
Date: Thu, 12 Feb 2009 10:21:22 +0000

I'll do my best to clarify the differences between Zetoc and ticTOCs, as best as I understand them:

Zetoc covers about 20,000 journals, including journals that are print-only, or that exist online but do not provide their own RSS feeds

ticTOCs covers about 12,000, limited to journals that provide their own RSS feeds (so this excludes print-only journals in the main)

Zetoc is based the British Library's acquisitions of print issues, with data re-keyed into to system, which means that it may be a few weeks between an issue being published an appearing in Zetoc.

ticTOCs uses feeds from the publishers (or their online hosts), so they are as up to date as the publisher wants to make them. Sometimes ticTOCs offers the latest issue feed and the 'articles in press feed', if that is what the publishers offer.

Zetoc only contains tables of contents

ticTOCs contains whatever the publisher chooses to include in its feed, which may include abstracts, subject terms, DOIs, and graphical abstracts (especially for chemistry titles)

Zetoc is hosted at MIMAS

ticTOCs is hosted at MIMAS

Zetoc provides email alerts of RSS feeds

ticTOCs provides RSS feeds only (but it's getting much easier to get your feeds into your email client if that's the way you want to work, right?)

So to summarise, Zetoc covers more journals, but ticTOCs should be more up to date and contains richer content.

Terry

Terry Bucknell

-----Original Message-----
From: Code for Libraries [mailto:[email-masked]] On Behalf Of Dr R. Sanderson
Sent: 12 February 2009 10:04
To: [email-masked]
Subject: Re: [CODE4LIB] ticTOCs makes its data available to developers

Rob

---

From: "Dr R. Sanderson" <[email-masked]>
Date: Thu, 12 Feb 2009 11:57:39 +0000

Thanks Terry, a really good comparison!

One more that I came up with, in thinking about this slightly further 
... ticTOCs is open to the public whereas ZETOC requires an 
institutional login to access the data.  A big plus on ticTOCs' side!

Rob

On Thu, 12 Feb 2009, Bucknell, Terry wrote:

> Zetoc covers about 20,000 journals, including journals that are 
>print-only, or that exist online but do not provide their own RSS feeds
> ticTOCs covers about 12,000, limited to journals that provide their 
>own RSS feeds (so this excludes print-only journals in the main)
> Zetoc is based the British Library's acquisitions of print issues, 
>with data re-keyed into to system, which means that it may be a few 
>weeks between an issue being published an appearing in Zetoc.
> ticTOCs uses feeds from the publishers (or their online hosts), so 
>they are as up to date as the publisher wants to make them. Sometimes 
> ticTOCs contains whatever the publisher chooses to include in its 
>feed, which may include abstracts, subject terms, DOIs, and graphical 
>abstracts (especially for chemistry titles)
>
> So to summarise, Zetoc covers more journals, but ticTOCs should be 
>more up to date and contains richer content.

---

From: "Bucknell, Terry" <[email-masked]>
Date: Thu, 12 Feb 2009 12:15:51 +0000

I knew there was something I forgot to mention!

Terry

-----Original Message-----
From: Code for Libraries [mailto:[email-masked]] On Behalf Of Dr R. Sanderson
Sent: 12 February 2009 11:58
To: [email-masked]
Subject: Re: [CODE4LIB] ticTOCs makes its data available to developers

Rob

---

From: John Fereira <[email-masked]>
Date: Thu, 12 Feb 2009 07:22:10 -0500

I was one of the developers and primary maintainer for severals years 
for a TOC services at Cornell that was created about 5 years ago.  The 
UI is pretty dated but it still is used quite a bit although it does 
note produce an RSS feed.  It's only available to Cornell patrons 
because it's integrated with our catalog and ez-proxy system such that a 
patron can subscribe to a journal TOC, receive the TOC as an email 
message when it becomes available then click on any article int the TOC 
and withing 1-2 clicks see the full text of the article.

The user also has the option of viewing TOCs in multiple formats.  This 
is facilitated by taking the incoming TOC from the vendor, transforming 
it to XML, the applying a XSL style sheet to produce different formats 
including plain text, html, endnote, refworks, and a couple of others.

---

From: Jonathan Rochkind <[email-masked]>
Date: Thu, 12 Feb 2009 12:13:42 -0500

Doh, is Zetoc not free?  Nevermind my excitement about it in that case. :)

Jonathan

---

From: Jonathan Rochkind <[email-masked]>
Date: Thu, 12 Feb 2009 12:13:12 -0500

I hadn't known about Zetoc either!  How did I miss that?

They both seem very useful.

One of the tricks with using ticTOCs, is that the RSS feeds (provided by 
the publisher) may include links to article full text that may or may 
not be accessible to any given institution's patrons, depending on 
whether that institution buys content from that publisher. Figuring out 
how to have software either filter out these inaccessible links, or even 
better yet figure out a way to generate an OpenURL link that might get 
the user to the full text for that article from a _different_ source -- 
kind of tricky.

I'm not quite sure how to deal with this yet, thinking about wanting to 
use TicTOCs stuff in my software. I am religiously opposed to giving 
users links to things they can't access, without warning.

So in that sense, Zetoc is actually easier because it's simpler. Since 
it doesn't in fact come from the vendor(s), it shouldn't include any 
vendor-specific URLs, right?   It does less, but since it does it 
simpler, it's a bit more straightforward and 'normalized', I'm thinking.

So I'm excited about looking into Zetoc (Umlaut service!), thanks for 
the pointer, I hadn't heard of Zetoc before.

Jonathan

---

From: "Bucknell, Terry" <[email-masked]>
Date: Thu, 12 Feb 2009 21:52:21 +0000

If your institution uses EZproxy then you can of course link to ticTOCs via EZproxy and you should find that full-text articles are then available to your patrons (where entitled of course). That's what we do at Liverpool.

If your institution has configured a LibX toolbar and the publisher's feeds include DOIs then LibX turns those DOIs into OpenURL links.

It sounds like what you would really like to be able to do though is to pre-query your link resolver to determine (and indicate) if you have full-text access. For that, I think you'd need all feeds to include DOIs and be structured consistently so that you could extract it, build and OpenURL and query your knowledgebase.

Another aspect of ticTOCs is that we have a group who are looking to come up with a set of best practice recommendations for publishers, about how to structure their feeds and what to include in them. CrossRef are involved with this so the recommendations will certainly say that DOIs should be included, and the recommendations should be disseminated to publishers' technical people by CrossRef, so we do expect them to be taken up in time.

Zetoc is free to UK universities - apologies for forgetting to take off my Limey blinkers!

Terry Bucknell

________________________________________
From: Code for Libraries [[email-masked]] On Behalf Of Jonathan Rochkind [[email-masked]]
Sent: 12 February 2009 17:13
To: [email-masked]
Subject: Re: [CODE4LIB] ticTOCs makes its data available to developers

Jonathan

---

From: Jonathan Rochkind <[email-masked]>
Date: Thu, 12 Feb 2009 17:01:25 -0500

> If your institution uses EZproxy then you can of course link to ticTOCs via EZproxy and you should find that full-text articles are then available to your patrons (where entitled of course). That's…
It's the "where entitled" that is the sticking point. It's quite 
possible, and even likely, that some of the URLs referenced in ticTOCs 
are not entitled to my patrons.  This is a non-trivial problem.

I'm glad you're looking at reccommendations for best 
practices/standardization for publisher RSS feeds.

One of the key requirements, for the uses I can think of, is that for an 
article-level entry, either an OpenURL context object should be included 
in the entry somewhere (possibly using COinS), or structured citation 
information sufficient to construct an OpenURL context object should be 
included (normally, minimally issn, year, vol, issue, start page number).

I hope you consider that in your reccomendations.

Jonathan

---

From: Eric Lease Morgan <[email-masked]>
Date: Thu, 12 Feb 2009 21:21:32 -0500

On 2/11/09 5:11 PM, "Bucknell, Terry" <[email-masked]> wrote:

> We are working on creating APIs to let groups like the code4lib community
> extract our data in more flexible ways, but it has been pointed out to us -
> see 
> http://robotlibrarian.billdueber.com/tictocs-give-us-a-file-pretty-pretty-pret
> ty-please/ - that all you really need (at least at first) is a simple
> tab-delimited file that contains titles, ISSNs, and feed URIs for all of the
> journals in tocTOCs. We now provide precisely this at

This is pretty cool. I can see:

  1. Selecting one or more of the RSS feeds that fit within
     the collection development policy of a particular library

  2. Regularly visiting the RSS feeds to extract the metadata
     of newly available articles

  3. Adding that metadata to a library's "next generation"
     library catalog/index

  4. And you can figure out the rest

Such a thing would be complementary to the article-level metadata available
from the DOAJ. Hmmm...  ticTOC++

-- 
Eric Lease Morgan
Head, Digital Access and Information Architecture Department
Hesburgh Libraries, University of Notre Dame

(574) 631-8604

---

From: "Boheemen, Peter van" <[email-masked]>
Date: Wed, 18 Feb 2009 21:34:53 +0100

Terry,
 
I was very pleased with the tab delimited file. I have read it into a table and joined it to our catalog, that is now showing rss buttons in the A-Z list and 'recent articles' when presenting a full record presentation of a single catalog record.
I discovered two problems with the file however.
1. I found two lines containing carriage returns, messing up these rows. (see 
2. There are titles in the list that do have a title and an issn, but that do not have a url of a rss feed. (e.g. Cell Differentiation)
 
Do you know of these problems ?
 
Regards,
 
Peter
 
Drs. P.J.C. van Boheemen
Hoofd Applicatieontwikkeling en beheer - Bibliotheek Wageningen UR
Head of Application Development and Management - Wageningen University and Research Library
tel. +31 317 48 25 17                                                                                    http://library.wur.nl <http://library.wur.nl/> 
P Please consider the environment before printing this e-mail

________________________________

From: Code for Libraries on behalf of Bucknell, Terry
Sent: Wed 11-2-2009 23:11
To: [email-masked]
Subject: [CODE4LIB] ticTOCs makes its data available to developers

Share and enjoy.

Terry Bucknell

---

From: "Bucknell, Terry" <[email-masked]>
Date: Wed, 18 Feb 2009 22:57:34 +0000

Peter,

Yes, previous emails off-list had alerted us first to 70 or so titles with carriage returns, and (after we'd tidied those up) yesterday to just two:

    4815    Genes & Development
    11707    Quality and Safety in Health Care

I hope they were the ones that you found. They should be OK now. If not, feel free to email off-list to tell me the two new culprits are!

We have been busy developing more flexible APIs and in the course of that today we realised that we were including some records that don't have feeds (and that don't appear in our web interface). We will make sure that we tidy those up. We also appreciate that we have some updating to do because of new launches and title transfers. In the longer term we are looking to publisher-initiated updates to our database via CrossRef.

Thank you for sharing what you have done with our data. We welcome 'case studies' which we can use to suggest what people can do with this stuff. Please share with any user group for your cataloguing system too!

I'll email this list again once we think the data has been cleaned up, and once we have other APIs to try out and comment on.

Terry Bucknell

________________________________________
From: Code for Libraries [[email-masked]] On Behalf Of Boheemen, Peter van [[email-masked]]
Sent: 18 February 2009 20:34
To: [email-masked]
Subject: Re: [CODE4LIB] ticTOCs makes its data available to developers

Terry,

Regards,

Peter

Drs. P.J.C. van Boheemen

Share and enjoy.

Terry Bucknell

---

From: Bob Duncan <[email-masked]>
Date: Thu, 19 Feb 2009 09:25:00 -0500

At 05:57 PM 2/18/2009, Terry wrote:
>. . .
>We have been busy developing more flexible APIs and in the course of 
>that today we realised that we were including some records that 
>don't have feeds (and that don't appear in our web interface). We 
>will make sure that we tidy those up. We also appreciate that we 
>have some updating to do because of new launches and title 
>transfers. In the longer term we are looking to publisher-initiated 
>updates to our database via CrossRef.

On the flipside, are you aware that there are also feed URLs for 
discontinued journals?  Somehow a journal that stopped publishing in 
1996 or 2000 doesn't seem very feed-worthy.  (Most of the ones I 
encountered were for ScienceDirect journals; publisher-initiated 
updates aren't all they're cracked up to be if the publisher is 
creating feeds across the board, regardless of whether there's any 
new content to feed.)

Bob Duncan

~!~!~!~!~!~!~!~!~!~!~!~!~
Robert E. Duncan
Systems Librarian
Editor of IT Communications
Lafayette College
Easton, PA  18042
[email-masked]
http://library.lafayette.edu/

---

From: "Bucknell, Terry" <[email-masked]>
Date: Thu, 19 Feb 2009 15:19:01 +0000

Yes, we're aware that we have feeds for dead journals too and are working on a mechanism to strip those out - but thanks for checking that we knew!

Terry

Terry Bucknell

-----Original Message-----
From: Code for Libraries [mailto:[email-masked]] On Behalf Of Bob Duncan
Sent: 19 February 2009 14:25
To: [email-masked]
Subject: Re: [CODE4LIB] ticTOCs makes its data available to developers

Bob Duncan

---

From: Roy Tennant <[email-masked]>
Date: Thu, 19 Feb 2009 14:36:41 -0800

Terry,
I appreciate you making this data available. FWIW (and that wouldn't be
much) I integrated your RSS data with my somewhat stale data of
peer-reviewed journals at

<http://roytennant.com/proto/peer/>

Roy

> As you may know, ticTOCs is a project funded by JISC in the UK to create a
> single, freely available source of RSS feeds for tables of contents - see
> http://www.tictocs.ac.uk/ . Our database now contains over 12,000 journals
> from over 430 publishers. Up until now the only way to get feeds out of
> ticTOCs has been to use our web interface to search for feeds and then export
> them as an OPML file, or one at a time to a feed reader of your choice.
> 
> We hope that you will use this data to populate your catalog, A-Z journals
> list or whatever with RSS feed icons/links, or embedded TOCs.  We look forward
> to the day when SFX, SerialsSolutions and the like are all using our data!
> 
> confident that we are very close to ensuring that the future of ticTOCs is
> assured for at least the next three years, and will continue to be free.
> 
> 
> Share and enjoy.
> 
> 
> 
> Terry Bucknell

--