Subject: Re: [CODE4LIB] ticTOCs makes its data available to developers

From: Laurence Lockton <[email-masked]>
Date: Tue, 17 Feb 2009 11:47:29 +0000

Eric,

You might be interested to know then that Lund University Libraries, the 
people behind the DOAJ, have been doing this for years, since before 
publisher RSS feeds and NGCs. They make it available to other libraries too 
(for a fee) with your holdings indexed so you can search for full text 
articles only. See 
<http://www.lub.lu.se/en/search/information-about-elinlund.html>

-- 

Laurence Lockton
University of Bath
UK

> Date:    Thu, 12 Feb 2009 21:21:32 -0500
> From:    Eric Lease Morgan <[email-masked]>
> Subject: Re: ticTOCs makes its data available to developers
>
> On 2/11/09 5:11 PM, "Bucknell, Terry" <[email-masked]>
> wrote:
>
>> We are working on creating APIs to let groups like the code4lib community
>> extract our data in more flexible ways, but it has been pointed out to
>> us - see
>> http://robotlibrarian.billdueber.com/tictocs-give-us-a-file-pretty-prett
>> y-pret ty-please/ - that all you really need (at least at first) is a
>> simple tab-delimited file that contains titles, ISSNs, and feed URIs for
>> all of the journals in tocTOCs. We now provide precisely this at
>> http://www.tictocs.ac.uk/text.php.
>
>
> This is pretty cool. I can see:
>
>   1. Selecting one or more of the RSS feeds that fit within
>      the collection development policy of a particular library
>
>   2. Regularly visiting the RSS feeds to extract the metadata
>      of newly available articles
>
>   3. Adding that metadata to a library's "next generation"
>      library catalog/index
>
>   4. And you can figure out the rest
>
> Such a thing would be complementary to the article-level metadata
> available from the DOAJ. Hmmm...  ticTOC++
>
> -- 
> Eric Lease Morgan
> Head, Digital Access and Information Architecture Department
> Hesburgh Libraries, University of Notre Dame
>
> (574) 631-8604
>
> ------------------------------

---

From: Eric Lease Morgan <[email-masked]>
Date: Tue, 17 Feb 2009 08:11:50 -0500

> <http://www.lub.lu.se/en/search/information-about-elinlund.html>

Very interesting. Thank you for bringing this to our attention, and I'd like
to comment on "make it available to other libraries" part.

I always thought it would be interesting to distribute indexes of the DOAJ
content more widely. More specifically:

  * create (Lucene) indexes for all the OAI DOAJ article sets
  * distribute the indexes through something like BitTorrent
  * provide a way to mix and merge the selected indexes
  * provide tools to search the result

In such a way a library could select subsets apropos to their collection
development policy, and maybe integrate the whole thing into their "NGC".
There is no reason why the indexes would have to be limited to OAI DOAJ
sets, but it could also include other OAI-accessible content, or content
extracted from mirrored journal literature.

In short, library as bibliographic index publisher.

-- 
Eric Lease Morgan

---

From: Tim Cornwell <[email-masked]>
Date: Tue, 17 Feb 2009 09:03:03 -0500

>...
> I always thought it would be interesting to distribute 
> indexes of the DOAJ content more widely.
>...

Fwiw:

The NSDL currently harvests metadata, crawls content, and indexes both for nine of the
seventeen DOAJ subjects.  We gather science, math, engineering, and technology related
DOAJ subjects:

Subject            (item counts)
---------------------------------
Technology and Engineering (15,248)
Physics and Astronomy (5,712)
Mathematics and Statistics (10,726)
Health Sciences (88,726)
Earth and Environmental Science (12,227)
Social Sciences (27,952)
Chemistry (12,089)
Biology and Life Sciences (45,987)
Agriculture and Food Sciences (21,923)

The NSDL search service is described here:

  http://ncore.nsdl.org/index.php?menu=services&submenu=services!search

The search UI and API are documented here: 

  http://wiki.nsdl.org/index.php/Community:Search

The above are maintained as separate collections, and the API allows for filtering by one
or more collection.

All NSDL metadata content is available via OAI-PMH here:
  http://ndr.nsdl.org/oai

-Tim

Timothy Cornwell, Programmer/Analyst
National Science Digital Library (http://nsdl.org)
301 College Avenue
Ithaca,  NY 14850
(607)255-3297

> -----Original Message-----
> From: Code for Libraries [mailto:[email-masked]] On 
> Behalf Of Eric Lease Morgan
> Sent: Tuesday, February 17, 2009 8:12 AM
> To: [email-masked]
> Subject: Re: [CODE4LIB] ticTOCs makes its data available to developers
>