Subject: Re: [CODE4LIB] Linux tools for making PDFs

From: Mark Jordan <[email-masked]>
Date: Tue, 3 Feb 2009 16:02:22 -0800

Yan, not sure how it handles east Asian characters, but imagemagick will create PDFs, e.g., 

convert FILE.jpg FILE.pdf

See http://www.imagemagick.org/script/convert.php for more info.

Mark

----- "Yan Han" <[email-masked]> wrote:

> Hello, 
> 
>  
> 
> Do you know a tool running under Linux to make PDFs from images?  I
> use
> Adobe Acrobat professional in Windows to create PDFs from image
> files.
> However, Acrobat does not handle image files with east Asian
> characters.
> 
> 
>  
> 
>  
> 
> Yan

---

From: Anand Chitipothu <[email-masked]>
Date: Wed, 4 Feb 2009 06:51:32 +0530

> convert FILE.jpg FILE.pdf

I have used this for converting an SVG image with some text in Telugu
language without any issues.

---

From: Jim Tuttle <[email-masked]>
Date: Wed, 4 Feb 2009 08:54:23 -0500

I had some issues (can't remember what!) with the Imagemagick convert
tool.  I've been using tiffcp and tiffcp and tiff2pdf in the
libtiff-tools Debian package.

I use python to parse the file names of TIFF files, build a list of
filenames that will comprise a PDF, use tiffcp to stitch them together,
then use tiff2pdf to convert the multi-image TIFF to PDF.

Then I pass the PDFs to someone else to OCR with Acrobat, which is a
pain.  I'd sure like to have a good Linux option to integrate into the
above process.

Jim

-- 
*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*
Jim Tuttle
http://braggtown.com