Subject: [CODE4LIB] activestate and marc::batch

From: Eric Lease Morgan <[email-masked]>
Date: Thu, 1 Oct 2009 15:02:06 -0400

I need some advice about ActiveState Perl and MARC::Batch.  
Specifically, once I install ActiveState Perl on a Windows computer,  
will I be able to install MARC::Batch and all of its friends as well?

I wrote a Perl script that summarizes the content of sets of MARC  
records. My fellow catalogers have discovered MARCEdit, but they need  
my program in order to analyze their content. Yes, I could give them a  
command-line to a Linux host, but the ActiveState Perl approach may be  
better.

Can I install MARC::Batch on a Windows computer running ActiveState  
Perl, and if so, then what are some of the things I need to watch out  
for?

-- 
Eric Lease Morgan
University of Notre Dame

---

From: Mark Jordan <[email-masked]>
Date: Thu, 1 Oct 2009 12:18:36 -0700

Eric,

Yes, running 

ppm install MARC-Record

will do the trick. I have never encountered a gotcha running MARC::Record and friends on ActiveState.

Mark

Mark Jordan
Head of Library Systems
W.A.C. Bennett Library, Simon Fraser University
Burnaby, British Columbia, V5A 1S6, Canada
Voice: 778.782.5753 / Fax: 778.782.3023
[email-masked]

---

From: Bryan Baldus <[email-masked]>
Date: Thu, 1 Oct 2009 14:21:58 -0500

On Thursday, October 01, 2009 2:02 PM, Eric Lease Morgan wrote:
>Specifically, once I install ActiveState Perl on a Windows computer, will I be able to install MARC::Batch and all of its friends as well?

I have no problems running ActiveState Perl with the MARC::Batch/MARC::Record distribution set of modules. The only problems I've experienced were with MARC::Charset and MARC::File::XML. I haven't had a significant need to use these modules, but when I attempted to install them, if I recall correctly, I had trouble with the XML parsing modules/dependencies/set-up. Someone with more experience working with XML parsing modules would likely be more successful.

Also, when installing MARC::Lint and MARC::Errorchecks through ppm, I believe ppm may complain or fail to install one of the modules due to the overlapping MARC::Lint::CodeData module included with both.

After installing the MARC::* modules using ppm, I'll usually manually update all of the .pm files with the most recent copy (from SourceForge), placing each in its appropriate spot in C:\Perl\site\lib\MARC\. I believe this manual process may be part of the source of my problems with Charset and XML (though for those, I have attempted to follow the official/standard automated installation process).

I hope this helps,

Bryan Baldus
[email-masked]
[email-masked]
http://home.inwave.com/eija

---

From: "Walker, David" <[email-masked]>
Date: Thu, 1 Oct 2009 12:54:41 -0700

I had the same problems with MARC:Charset and MARC:File:XML.  Had to compile them myself using Microsoft's nmake program.

Here's my less-than-ideal notes.  I may have missed some things at the end here, too.  Sorry, I switched to using yaz-dump instead, since that did what I wanted.

1. Install ActiveState Perl
2. Download and unpack 'nmake' from microsoft [1] drop files in perl/bin
3. Restart the computer (to get the env varirables set)
4. Lanuch ppm from the command line, install:
     * marc-record
     * xml-sax
     * xml-sax-expat
5. Run this from the command line to fix an oversight in the ppm install
 perl -MXML::SAX -e "XML::SAX->add_parser('XML::SAX::Expat')->save_parsers()"
6. Download and unpack MARC::Charset and MARC:File:XML
7. Go into each of the directories created for those and issue this from the command line:
 perl Makefile.pl
 nmake
 nmake test
 nmake install

Hope this is useful.

--Dave

[1]  http://johnbokma.com/perl/make-for-windows.html -- this page describes how to use it and provides a link to the MS site where you can download it (for free).

==================
David Walker
Library Web Services Manager
California State University
http://xerxes.calstate.edu
________________________________________
From: Code for Libraries [[email-masked]] On Behalf Of Bryan Baldus [[email-masked]]
Sent: Thursday, October 01, 2009 12:21 PM
To: [email-masked]
Subject: Re: [CODE4LIB] activestate and marc::batch

I hope this helps,

Bryan Baldus