Subject: [CODE4LIB] New MARC-related Perl scripts--440s, 008lang zxx

From: Bryan Baldus <[email-masked]>
Date: Wed, 29 Jul 2009 07:43:47 -0500

I have posted 2 new Perl .pl programs to my website [1]. Both use a module, MARC::QBI::Misc, not currently available, but it is used only for file handling, so that section of the program should be revised according to local needs.

440to490-830.txt [2]: Converts 440 to 490-830 pairs. Retains subfield 'x' (ISSN) from 440; deletes all square brackets from 830, adds period at the end of the 830 if punctuation is not already present. If any quotes or apostrophes exist in the 440, a period is added before the quote(s) or apostrophe(s) in the 830. I've only done limited testing, so results may not be 100% correct yet.

008langblanktozxx.txt [3]: Converts 008/35-37 from 3 blank spaces to zxx.

##############

Not yet started, but next on my list:

-Convert 'c' in books 008/33 (comic strips) to 008/24-27 '6' (Comics/graphic novels); revise 008/33 to 0 or 1, depending on fiction vs. non-fiction.

-Convert 041 subfield 'b' to 'j' for videorecording records.

##############

I welcome any comments or corrections.

[1] <http://home.inwave.com/eija/>
[2] <http://home.inwave.com/eija/fullrecscripts/Cleanup_full_recs/440to490-830.txt>
[3] <http://home.inwave.com/eija/fullrecscripts/Cleanup_full_recs/008langblanktozxx.txt>

Thank you for your time,

Bryan Baldus
[email-masked]
[email-masked]
http://home.inwave.com/eija

---

From: David Pattern <[email-masked]>
Date: Fri, 31 Jul 2009 16:53:59 +0100

Hi everyone

Just a quick plug for a developer competition that's being run by the JISC funded MOSAIC ("Making Our Shared Activity Information Count") Project in the UK: http://www.sero.co.uk/jisc-mosaic-competition.html

The usage data can be found for download via: http://library.hud.ac.uk/wikis/mosaic/index.php/Project_Data

...and the "Data Collection Guide" explains the XML format of the data: http://library.hud.ac.uk/wikis/mosaic/index.php/Project_Documentation

At present, it's just book usage data from the University of Huddersfield that's available to play around with, but we're hoping that it will be joined by some usage data from a few other UK academic libraries in due course.

As the XML usage data files are pretty big (i.e. opening them in Internet Explorer is a sure fire way of killing a PC!), I've put together a quick & dirty API for grabbing subsets of the data: http://www.daveyp.com/blog/archives/953

Tony Hirst (from the Open University in the UK) has done a helpful blog post here: http://bit.ly/8RjYU

In terms of the competition, it's open to anyone (i.e. not just developers based in the UK).  The prizes are in UK sterling and the competition is being run according to UK law (just in case competition laws vary from country to country).

Have fun!

Dave Pattern
Library Systems Manager
University of Huddersfield

<img src="http://www.hud.ac.uk/images/emails/neutral_navy_blue_003976.gif" alt="Inspiring tomorrow's professionals">
---
This transmission is confidential and may be legally privileged. If you receive it in error, please notify us immediately by e-mail and remove it from your system. If the content of this e-mail does not relate to the business of the University of Huddersfield, then we do not endorse it and will accept no liability.