Subject: Re: [CODE4LIB] Something completely different

From: Genny Engel <[email-masked]>
Date: Tue, 7 Apr 2009 11:52:21 -0700

Also back to the original question, what is an ILS in the first place?
 
The discussion has focused on bibliographic records, but that's just one part of what's in the ILS in use at the library where I work.  I see one of the big problems with current ILSs being not so much the ILS per se, but library managers'/librarians' expectations that they should have a single core system that handles all the following functionality:
 
- maintaining a database of patron records with attached fine and fee information, which books they have out, what is waiting on the hold shelf for them, etc.
 
- maintaining a library accounting hierarchy with the ability to run reports like "it's halfway through the year and you've spent 90% of your budget for children's fiction"
 
- maintaining an acquisitions system so records for purchases are reflected into the accounting system and also as new bib records for on-order materials
 
- serials check-in so that missing issues can be claimed
 
- and of course a cataloging module and an OPAC.
 
Without the ability to support all the back-end processing and accounting, simply replacing the front-end OPAC and the bibliographic database does nothing to eliminate the need for an ILS, unless it also opens the way to feed data in and out of cheap off-the-shelf accounting and purchasing systems that aren't library-specific.  A lot of libraries still won't want to put together even that much out of parts, and will prefer an ILS, but if it were me, I think I'd look at reengineering some of the parts to become more interchangeable with stuff like standard accounting software.
 
I must admit I was kind of horrified when I first got here and found that all this functionality was resident in a single system.  No wonder these things are so honking expensive.

 
Genny Engel
Sonoma County Library
[email-masked] 
707 545-0831 x581
www.sonomalibrary.org 

>>> [email-masked] 04/07/09 08:59AM >>>
On Sun, Apr 5, 2009 at 10:40 AM, Peter Schlumpf <[email-masked]> wrote:

> I want to get back to simple things.  Imagine if there were no Marc records.  Minimal layers of abstraction.  No politics.  No vendors.  No SQL straightjacket.  What would an ILS look like without those things?

Back to this original question, [...]

---

From: Sharon Foster <[email-masked]>
Date: Tue, 7 Apr 2009 15:17:10 -0400

Which is why the interface specifications are at least as important,
if not more important, as the specs for each of the modules that you
enumerated. If the interfaces are well-defined, then the components
can be designed and developed with a minimum of further interactions
among developers. In fact, there might eventually be more than one
implementation of a particular module, allowing a library to assemble
an ILS out of interchangeable components. (I'm assuming open
source--it seems unlikely that proprietary vendors will ever come
around.)

Sharon M. Foster, 91.7% Librarian
Speaker-to-Computers
http://www.vsa-software.com/mlsportfolio/

> Also back to the original question, what is an ILS in the first place?
[...]