Subject: [CODE4LIB] software package for Elec. Theses/dissertations

From: "Han, Yan" <[email-masked]>
Date: Wed, 7 Jan 2009 16:57:28 -0700

Hello, Colleagues,

As ProQuest/UMI switched its delivery platform for Electronic Theses and dissertations(ETD), I have developed a small software package to process ETD. The software package does:

1.       Unzip ProQuest/UMI ETD delivery Zipped files, and create one directory per ETD.

2.       Rename these ETDs into other preferred file names (in my case, Wang_arizona_0009D_10075.xml à azu_etd_10075_sip1_m.xml) 

3.       Generate digital signature for digital preservation.

4.       Create MARC records from ProQuest/UMI XML files.  (i.e. a MRK file will be generated for direct loading to catalog. I use III innovative and Koha)

5.       Create embargo notification and moving embargo ETDs to a different directory for future loading

This package saves me a lot of time to process hundreds of ETDs. The package (size of 50kb) has a Java compiled code (class file) and Perl Scripts. Currently I run it on Linux, but it can be run in Windows. 

If anyone wants to have it or give it a try, please contact me. 

p.s. I also have a package handling ProQuest old platform (BePress) ETD files. 

Thanks, 

Yan Han

The University of Arizona Libraries

---

From: Myung-Ja Han <[email-masked]>
Date: Wed, 7 Jan 2009 21:06:25 -0600

Hello Yan,

Could you send me your program?
I would like to try on.

Thanks,
mj

On Wed, Jan 7, 2009 at 5:57 PM, Han, Yan <[email-masked]> wrote:

> Hello, Colleagues,
>
>
>
> As ProQuest/UMI switched its delivery platform for Electronic Theses and
> dissertations(ETD), I have developed a small software package to process
> ETD. The software package does:
>
> 2.       Rename these ETDs into other preferred file names (in my case,
> Wang_arizona_0009D_10075.xml à azu_etd_10075_sip1_m.xml)
>
> 4.       Create MARC records from ProQuest/UMI XML files.  (i.e. a MRK file
> will be generated for direct loading to catalog. I use III innovative and
> Koha)
>
> This package saves me a lot of time to process hundreds of ETDs. The
> package (size of 50kb) has a Java compiled code (class file) and Perl
> Scripts. Currently I run it on Linux, but it can be run in Windows.
>
>
>

-- 
Myung-Ja (mj) Han
Metadata Librarian
University of Illinois at Urbana-Champaign

---

From: Tim McGeary <[email-masked]>
Date: Thu, 8 Jan 2009 10:29:45 -0500

Yan,

I would also like to try the software.  Thanks for offering!

Tim

Tim McGeary
Senior Systems Specialist
Lehigh University
610-758-4998
[email-masked]
Google Talk: timmcgeary
Yahoo IM: timmcgeary

Han, Yan wrote:
> Hello, Colleagues,
> 
> 
> 
> As ProQuest/UMI switched its delivery platform for Electronic Theses
> and dissertations(ETD), I have developed a small software package to
> process ETD. The software package does:
> 
> 2.       Rename these ETDs into other preferred file names (in my
> case, Wang_arizona_0009D_10075.xml à azu_etd_10075_sip1_m.xml)
> 
> 4.       Create MARC records from ProQuest/UMI XML files.  (i.e. a
> MRK file will be generated for direct loading to catalog. I use III
> innovative and Koha)
>