Subject: Re: [CODE4LIB] The Dewey Dilemma

From: Emily Lynema <[email-masked]>
Date: Fri, 13 Nov 2009 08:46:16 -0500

I may be a little off the mark throwing this into the conversation, but when you start talking about call numbers and browse I have to note that we just put in a code4lib proposal to talk about the online browsing system we created based on call number at NCSU. It's early in these explorations, but we see this as a first step to a 'find more like this' system that might utilize 'other dimensions of likeness' to create visually browse-able sets of resources, both print and electronic. Call number is just an easy first place to start to utilize browsing to find more.

How this may be different than what you are talking about in that this approach is in the space of 'find something you like and then find more', rather than beginning the discovery experience by choosing clusters of things to browse. In all honesty, I'm not sure that we've found that users *want* to begin their discovery experience with a browse, as hierarchical browsing (of LCC, for example) is obscured by the fact that they often don't have a high level understanding of the topic area they are interested in investigating. In practice, they often start specific to get something good and then want more  like that.

I note that we developed a 'cover flow' view for this browse tool that obscures the call number from the user at first pass, and even going that far is challenged by more traditional proponents of call number searching / browsing within the library. 

To see the beta in action, click 'Browse Shelf' from this catalog record:
http://www2.lib.ncsu.edu/catalog/record/NCSU1623286

Based on the code4lib proposal list, I think Stanford is working in a similar area with Blacklight, as well.

-emily

------------------------------

Date:    Thu, 12 Nov 2009 12:16:20 -0500
From:    Jonathan Rochkind <[email-masked]>
Subject: Re: The Dewey Dilemma

I definitely agree that providing for some sort of "browse" based on 
similar things being together is crucial, and something that is largely 
still awaiting "next generation" experiments in. (Although NCSU did it a 
bit with LCC in their Endeca catalog, simply by providing an LCC facet. 
I think there's probably something more powerful that could be done).

The classification systems we've got might be some of the best data we 
have to bass that on (although not the only way to do it. There might 
also be a way to do it with LCSH alone, using the relationships in 
LCSH.  It would be interesting to experiment with doing this based on 
purely text-analysis data mining techniques too).

But even if I was using the DDC or LLC to do this, I'd try to avoid 
making the user look at the actual _class numbers_!   You need to have 
encoded classes and relationships (ideally hieararchical) between 
classes to do this, but there are other ways to encode that that don't 
require fileable numbers, and even if you are doing it with the 
traditional fileable number mechanism, you don't neccesarily need to 
show the number to the user!

Cindy Harper wrote:

> > I haven't followed this conversation completely - but I'll throw in a
> > (serious) 2 cents.  I've always been partial to the efforts to offer users
> > the ability to browse a subject area (using recognition memory), rather than
> > giving up on any imposition of order and resort to search-only (using recall
> > memory).  I think you'll find that the HCI people acknowledge that the two
> > types of memory are very distinct.
> >
> > I think the most important potential role of classification systems is to
> > facilitate browsing.  Of course, everyone has different representations of
> > how ideas subdivide into broader and narrower terms.  But presented with an
> > easy way of viewing another's structure, they can usually _recognize_ the
> > scheme.
> >
> > Subjects don't lend themselves to one linear hierarchy, but there are many
> > subsections that do - I picture it as a collection (the cosmic stew) of
> > hierarchically-related collections (molecules) of subjects (atoms).  Now if
> > some search engine would enable you to retrieve the molecules and browse
> > what other atoms are grouped nearby in this molecule, the browsing function
> > would be served.
> >
> > I know there has been work in data visualization that approaches this - I've
> > thought of trying to do some data mining in library catalogs to bring out
> > clusters of terms that could simulate the molecules.
> >
> > It's the users who don't have a complete mental model of the keyword
> > universe that I'm interested in addressing.
> >
> >
> >
> > Cindy Harper, Systems Librarian
> > Colgate University Libraries
> > [email-masked]
> > 315-228-7363
> >
> >
> >
> > On Thu, Nov 12, 2009 at 10:22 AM, Miksa, Shawne <[email-masked]> wrote:
> >
> >   
>   
>> >> It is interesting--spent some time last night re-reading the Introductions
>> >> to the 1st edition and the current 22nd edition of DDC.
>> >>
>> >> In the Preface of the 1st edition Dewey wrote "The system was devised for
>> >> cataloguing and indexing purposes, but it was found on trial to be equally
>> >> valuable for numbering and arranging books and pamphlets on the shelves."
>> >> (Dewey, 1876, p3)  He also says "The impossibility of making a satisfactory
>> >> classification of all knowledge as preserved in books, has been appreciated
>> >> from the first, and nothing of the kind attempted" and that "Theoretically,
>> >> the division of every subject into just nine heads is absurd." (p.4)
>> >>
>> >> In the 22nd edition published in 2003 the DDC editors define classification
>> >> and its purpose:
>> >>      "2.1 Classification provides a system for organizing knowledge.
>> >> Classification may be used to organize knowledge represented in any form,
>> >> e.g., books, documents, electronic resources.
>> >>      2.2 Notation is the system of symbols used to represent the classes in
>> >> a classification system. In the Dewey Decimal Classification, the notation
>> >> is expressed in Arabic numerals. The notation gives both the unique meaning
>> >> of the class and its relation to other classes.The notation provides a
>> >> universal language to identify the class and related classes, regardless of
>> >> the fact that different words or languages may be used to describe the
>> >> classes." (DDC22, vol.1, p
>> >>
>> >> In reading through the entire Introduction there is not one mention of
>> >> using the numbers for physical arrangement of the resources. The definition
>> >> of Call number (Book number) is "a set of letters, numerals, or other
>> >> symbols (in combination or alone) used by a library to identify a specific
>> >> copy of a work. A call number may consist of the class number, book number,
>> >> and other data such as date, volume number, copy number, and location
>> >> symbol." (DDC22, vol. 1, p lxvi)
>> >>
>> >> Logically and realistically, we know that the built numbers assigned to
>> >> resources are used for physical arrangement library. But, it is important to
>> >> note the absence of any requirement to do so. This is what some libraries
>> >> have done when moving to other ways of arranging, but I would contend their
>> >> reasons for doing so are largely based on this misperception of how DDC
>> >> works as a classification system as well as the following of the "tradition"
>> >> of using the numbers for arrangement (i.e., this is how its always been
>> >> done, no questions asked). This would be a very interesting study --a small
>> >> one for an article, perhaps, or more detailed study for a dissertation.
>> >>
>> >> The book "Moving Beyond the Presentation Layer: content and context in the
>> >> Dewey Decimal Classification (DDC) System" published in 2006 by Haworth
>> >> Press (also as Cataloging and Classification Quarterly, volume 42, numbers
>> >> 3/4), and edited by Joan S. Mitchell and Diane Vizine-Goetz, seeks to look
>> >> beyond the "familiar linear notation sequence" and explore how it can be
>> >> used in web environment. It's a great read--I highly recommend it,
>> >> especially Karen Markey's article on use of classification in the online
>> >> environment.
>> >>
>> >> In looking through several textbooks on classifying with DDC, the
>> >> distinction between the classification number and the addition of a book
>> >> number (sometimes called the cutter number or a "unique identifier") is the
>> >> only real mention of any use for physical arrangement on the shelf. Without
>> >> that addition then arrangement is quite difficult. I would be curious to
>> >> know if libraries that no longer use DDC for shelving had been using the
>> >> whole "book number" or just the classification number. I've often observed
>> >> class numbers being randomly "lopped off" to make a shorter notation to fit
>> >> on the spine. On one cringe-worthy occasion I found a number that didn't
>> >> even exist in the schedules--someone had taken the original number and
>> >> rounded it up.
>> >>
>> >> In the survey of catalogers in North Texas public libraries that I
>> >> conducted in 2005-2006, I found that out of 104 respondents (representing a
>> >> 60% response rate) only 33 (32%) used DDC, 22nd edition, either daily,
>> >> weekly, or occasionally; an average of 17 (16.5%) used the older 21st or
>> >> 20th editions daily, weekly, or occasionally. At the same time, 18 (17%)
>> >> accessed DDC online through WebDewey.  61 respondents (59%) responded with
>> >> Not Applicable.  I feel this gives a good idea of how DDC is or isn't
>> >> understood, at least in this neck of the woods, but I would venture to say
>> >> that a national survey would produce similiar findings. (Miksa, S. ?A Survey
>> >> of Local Library Cataloging Tool and Resource Utilization.? Journal of
>> >> Education for Library and Information Science, vol. 49, no. 2, Spring 2008.
>> >> )
>> >>
>> >>
>> >> **************************************************************
>> >> Shawne D. Miksa, Ph.D.
>> >> Associate Professor
>> >> Department of Library and Information Sciences
>> >> College of Information
>> >> University of North Texas
>> >> email: [email-masked]
>> >> http://courses.unt.edu/smiksa/index.htm
>> >> office 940-565-3560 fax 940-565-3101
>> >> **************************************************************
>> >>
>> >>     
>>     
> >
> >   
>   

-- 
Emily Lynema
Associate Department Head
Information Technology, NCSU Libraries
919-513-8031
[email-masked]

---

From: "O.Stephens" <[email-masked]>
Date: Fri, 13 Nov 2009 14:36:10 +0000

I don't think this has made code4lib, and I thought that people might be interested to see the results of the recent 'MOSAIC' competition which challenged developers to find ways of exploiting library usage data (specifically circulation stats)

The results were announced last month, and I think there are some interesting prototypes in there - see http://blog.iedemonstrator.org/2009/10/22/jisc-mosiac-project-competition-winners/ for a rundown of the winners and some highly commended entries

For full disclosure - I did enter the competition, and my entry gets an honorable mention - but I'd highlight especially the 1st and 2nd place entries. I think the 1st is an intriguing way of visualising the data - perhaps opening up some opportunities for seredipitous discovery - it definitely drew me in and had me browsing to unexpected places. I love the 2nd place entry in terms of putting a financial value on what a library has provided for a course.

Anyway - I hope others find these prototypes of interest.

Owen

Owen Stephens
TELSTAR Project Manager
Library and Learning Resources Centre
The Open University
Walton Hall
Milton Keynes, MK7 6AA

T: +44 (0) 1908 858701
F: +44 (0) 1908 653571
E: [email-masked]

The Open University is incorporated by Royal Charter (RC 000391), an exempt charity in England & Wales and a charity registered in Scotland (SC 038302).