Subject: [CODE4LIB] ProQuest theses & dissertation xml gateway?

From: Ranti Junus <[email-masked]>
Date: Fri, 6 Nov 2009 16:29:50 -0500

Hi All,

Has anybody did a query against ProQuest Theses & Dissertation XML
gateway to get XML records back?
Would you mind sharing the info on how to do that?

Thanks in advance.

ranti.

-- 
Bulk mail.  Postage paid.

---

From: "Witt, Michael C." <[email-masked]>
Date: Mon, 9 Nov 2009 08:38:41 -0500

To my knowledge, ProQuest does not have a web service that returns XML but you can use Z39.50 or ftp to retrieve MARC records and then flip them to XML locally.  If you use Digital Commons (bepress IR product), it provides an OAI-PMH and SRU interface to the same records downstream as XML.  Hope this helps you.

-
Michael Witt, Purdue University
Interdisciplinary Research Librarian
Assistant Professor of Library Science
http://www.lib.purdue.edu/research/witt/

> -----Original Message-----
> From: Code for Libraries [mailto:[email-masked]] On Behalf Of Ranti
> Junus
> Sent: Friday, November 06, 2009 4:30 PM
> To: [email-masked]
> Subject: [CODE4LIB] ProQuest theses & dissertation xml gateway?
> 
> Hi All,
>

---

From: "Witt, Michael C." <[email-masked]>
Date: Mon, 9 Nov 2009 09:27:54 -0500

I stand corrected.  ProQuest apparently has an SRU/W interface but requires you to contact them and request access on a user-by-user basis.  I called their tech support this morning, but they wouldn't give me its baseURL without my signing a nondisclosure agreement (huh?).  You may be able to get this information by looking at the configuration or plugin for it in your federated search engine or by calling them and getting a different support technician than the one I spoke to.  :-)

-

> From: Witt, Michael C.
> Sent: Monday, November 09, 2009 8:39 AM
> To: 'Code for Libraries'
> Subject: RE: [CODE4LIB] ProQuest theses & dissertation xml gateway?
> 
> To my knowledge, ProQuest does not have a web service that returns XML but you
> can use Z39.50 or ftp to retrieve MARC records and then flip them to XML
> locally.  If you use Digital Commons (bepress IR product), it provides an OAI-
> PMH and SRU interface to the same records downstream as XML.  Hope this helps
> you.
> 
> -

---

From: Ranti Junus <[email-masked]>
Date: Mon, 9 Nov 2009 10:55:33 -0500

Ah so. Thank you for checking it. All I want is to just pull our own
Theses & Dissertations.
Well, I ended up calling them and asked for the records to be
delivered to us. :-)

thanks,
ranti.

-- 
Bulk mail.  Postage paid.