Subject: [CODE4LIB] PICAplus to MODS conversion

From: Neubert Joachim <[email-masked]>
Date: Tue, 13 Jan 2009 10:03:10 +0100

Has anybody built a conversion from PICA+ to MODS and is willing to
share the code?
 
Regards, Joachim

---

From: Jakob Voss <[email-masked]>
Date: Wed, 21 Jan 2009 17:05:06 +0100

> Has anybody built a conversion from PICA+ to MODS and is willing to

First there is not one PICA+ but different variants like there are 
different MARC variants. Second the most PICA+ to anything conversions 
that I know use the "FCV" conversion language that was developed by PICA 
an is neither documented nor standardized - so you won't be able to do 
something with it unless you run your own PICA system. At GBV we export 
MODS via MARC and the XSLT provided by the LOC, the chain is

GBV-PICA+ --(FCV)--> MARC ---> MARCXML --(XSLT)--> MODS

As you can imagine, the metadata quality does not get better with each 
step like alway when you do conversion between metadata formats. But its 
better than having to write n*n single conversions.

Greetings,
Jakob

-- 
Jakob Voß <[email-masked]>, skype: nichtich
Verbundzentrale des GBV (VZG) / Common Library Network
Platz der Goettinger Sieben 1, 37073 Göttingen, Germany
+49 (0)551 39-10242, http://www.gbv.de

---

From: Neubert Joachim <[email-masked]>
Date: Thu, 22 Jan 2009 16:19:47 +0100

We thought about this chain already, but were afraid of the inescapeble loss of data quality. As we think about using MODS as the basic format for a new version of our EconBiz portal, and our main record set is in GBV-PICA+, that's a crucial point for sucess. 

Maybe we could re-use the your FCV? (for building the chain you lined out or as a possible starting point to build a direct conversion - which we happily would pass back). 

Kind regards, Joachim

> -----Ursprüngliche Nachricht-----
> Von: Code for Libraries [mailto:[email-masked]] Im 
> Auftrag von Jakob Voss
> Gesendet: Mittwoch, 21. Januar 2009 17:05
> An: [email-masked]
> Betreff: Re: [CODE4LIB] PICAplus to MODS conversion
> 
> Joachim Neubert wrote:
> 
> First there is not one PICA+ but different variants like 
> there are different MARC variants. Second the most PICA+ to 
> anything conversions that I know use the "FCV" conversion 
> language that was developed by PICA an is neither documented 
> nor standardized - so you won't be able to do something with 
> it unless you run your own PICA system. At GBV we export MODS 
> via MARC and the XSLT provided by the LOC, the chain is
> 
> As you can imagine, the metadata quality does not get better 
> with each step like alway when you do conversion between 
> metadata formats. But its better than having to write n*n 
> single conversions.
> 
> Greetings,
> Jakob
> 
> --
> Verbundzentrale des GBV (VZG) / Common Library Network Platz 
> der Goettinger Sieben 1, 37073 Göttingen, Germany