Subject: Re: [CODE4LIB] Something completely different

From: Peter Schlumpf <[email-masked]>
Date: Tue, 7 Apr 2009 22:39:32 -0400

An interesting thread!  It will take me a while for me to digest the ideas.

What I had in mind for something different is this:  Think of a single database of only associations between objects, and nothing more than that.  Objects defined in this database can reference any and all other objects in the database.  These objects could represent anything:  Title records or item records in an opac.  A collection of files on a computer.  Web sites.  Links.  Database queries.  All of the above.  Each object in this database contains just enough information to say that it exists and has a pointer to the thing in the outside world that it represents.

Although the basic system would allow the objects in it to link to eachother in arbitrary ways, we could impose rules on it to create a system.  An OPAC.  A map. Other things that I can't think of right now.  I think a key thought here is that it is a database of pure relationships that can be set up and manipulated.  But the descriptive data is stored elsewhere.

It allows for an interesting extension too -- weighting those associations.  Suppose we use it to create a search structure, and each time we go from one object referencing another we increment a counter for that link by one.

There are many ways to implement something like this, and I have one in mind, but this is sort of the theory behind it.  It is going back to simple things.

Peter Schlumpf

-----Original Message-----
>From: Karen Coyle <[email-masked]>
>Sent: Apr 6, 2009 1:49 PM
>To: [email-masked]
>Subject: Re: [CODE4LIB] Something completely different
>
>Cloutman, David wrote:
>> I'm open to seeing new approaches to the ILS in general. A related
>> question I had the other day, speaking of MARC, is what would an
>> alternative bibliographic data format look like if it was designed with
>> the intent for opening access to the data our ILS systems to developers
>> in a more informal manner? I was thinking of an XML format that a
>> developer could work with without formal training, 
>
>Well, speaking of 'without formal training' -- I posted this to the Open 
>Library technology list, but using the OL, which is triple-based and 
>open access, I was able to create a simple demo Pipe of how you could 
>determine the earliest date of publication of a book (with an interest 
>in looking at potential copyright status). Caveat is that the API I'm is 
>still pretty stubby, so it only retrieves on exact title (this will be 
>fixed sometime in the future).
>
>The pipe is here:
>
>http://pipes.yahoo.com/pipes/pipe.info?_id=216efa8c3b04764ca77ad181b1cc66e4
>
>kc
>
>> the basics of which
>> could be learned in an hour, and could reasonably represent the
>> essential fields of the 90% of records that are most likely to be viewed
>> by a public library patron. In my mind, such a format would allow
>> creators of community-based web sites to pull data from their local
>> library, and repurpose it without having to learn a lot of arcane
>> formats (e.g. MARC) or esoteric protocols (e.g. Z39.50). The sacrifice,
>> of course, would be loosing some of the richness MARC allows, but I
>> think in many common situations the really complex records are not what
>> patrons are interested in. You may want to consider prototyping this in
>> your application. I see such an effort to be vital in making our systems
>> relevant in future computing environments, and I am skeptical that a
>> simple, workable solution would come out the initial efforts of a
>> standardization committee.
>>
>> Just my 2 cents.
>>
>> - David
>>
>> ---
>> David Cloutman <[email-masked]>
>> Electronic Services Librarian
>> Marin County Free Library 
>>
>> -----Original Message-----
>> From: Code for Libraries [mailto:[email-masked]] On Behalf Of
>> Peter Schlumpf
>> Sent: Sunday, April 05, 2009 8:40 AM
>> To: [email-masked]
>> Subject: [CODE4LIB] Something completely different
>>
>>
>> Greetings!
>>
>> I have been lurking on (or ignoring) this forum for years.  And
>> libraries too.  Some of you may know me.  I am the Avanti guy.  I am,
>> perhaps, the first person to try to produce an open source ILS back in
>> 1999, though there is a David Duncan out there who tried before I did. I
>> was there when all this stuff was coming together.
>>
>> Since then I have seen a lot of good things happen.  There's Koha.
>> There's Evergreen.  They are good things.  I have also seen first hand
>> how libraries get screwed over and over by commercial vendors with their
>> crappy software.  I believe free software is the answer to that.  I have
>> neglected Avanti for years, but now I am ready to return to it.
>>
>> I want to get back to simple things.  Imagine if there were no Marc
>> records.  Minimal layers of abstraction.  No politics.  No vendors.  No
>> SQL straightjacket.  What would an ILS look like without those things?
>> Sometimes the biggest prison is between the ears.
>>
>> I am in a position to do this now, and that's what I have decided to do.
>> I am getting busy.
>>
>> Peter Schlumpf
>>
>> Email Disclaimer: http://www.co.marin.ca.us/nav/misc/EmailDisclaimer.cfm
>>
>>
>>   
>
>
>-- 
>-----------------------------------
>Karen Coyle / Digital Library Consultant
>[email-masked] http://www.kcoyle.net
>ph.: 510-540-7596   skype: kcoylenet
>fx.: 510-848-3913
>mo.: 510-435-8234
>------------------------------------

---

From: "Benjamin O'Steen" <[email-masked]>
Date: Wed, 8 Apr 2009 10:23:46 +0100

So... like a Fedora repository where you actually use the RELS-EXT? :)
You've pretty much outlined how I use Fedora right there!

Ben

---

From: Alex Osborne <[email-masked]>
Date: Wed, 8 Apr 2009 19:40:41 +1000

Hi Peter,

Peter Schlumpf wrote:
> What I had in mind for something different is this:  Think of a
> single database of only associations between objects, and nothing
> more than that.

If I'm understanding you correctly, what you have in mind is a
triplestore.  A database for storing purely relationship triples and
nothing else.  A triple is made up of the name of an object, the name of
a type of relationship and a name of another object.  A few example
abstract triples might be:

(The Lord of the Rings, author, J. R. R. Tolkien)
(The Hobbit, sequel, The Lord of The Rings)
(J. R. R. Tolkien, pet, Fido)
(Fido, species, Canis lupus familiaris)
(Canis lupus familiaris, commonName, Dog)

etc

RDF is a particular implementation of this abstract concept, where the
names of both the objects and relationships are URIs.  An RDF
triplestore is a piece of software that stores these relationships and
allows them to be queried flexibly and efficiently (in theory).

> It allows for an interesting extension too -- weighting those
> associations.  Suppose we use it to create a search structure, and
> each time we go from one object referencing another we increment a
> counter for that link by one.

I'm a little confused by this.  What would the use case be?  Are you
talking about a popularity score for each relationship to weight
searches with?

Cheers,

Alex