Subject: [CODE4LIB] Ten years

From: Peter Schlumpf <[email-masked]>
Date: Sat, 18 Apr 2009 09:17:33 -0400

This might be a good time to reflect upon where we've been and where we're headed.  Almost exactly ten years have passed, I think, since open source software in libraries became self-aware as a movement.  Sure, there has always been open source software, but I would mark the real start as when the oss4lib listserv came into being.  It provided a forum for like-minded folks to kick around ideas and discuss what they were doing.

I remember ALA 2000 in Chicago.  That was cool!  Tim O'Reilly graciously gave us space at his booth there, letting us show off the early projects we were doing.  And to any of you who happened to be at NERCOMP at Wesleyan University in Connecticut the following year -- I apologise.  I am not an extemporaneous speaker, as I discovered!

Then Koha happened.  Then Evergreen, and a multitude of other projects.  Overall, I am pleased by what has happened.  Open source software for libraries has matured into a real option for any library.  My little project fell by the wayside during that time, but it's always been there -- I just haven't done much with it.  I am returning to it now with fresh ideas.

What do the rest of you think about the past ten years?  What about the next ten?

Peter Schlumpf
Avanti Library Systems
http://www.avantilibrarysystems.com

---

From: Roy Tennant <[email-masked]>
Date: Sat, 18 Apr 2009 13:13:54 -0700

At first I was thinking "only ten years? Really?" But then I realized that
you were talking about true "library" open source software (as opposed to
librarians involved with open source projects, which clearly predated 1999),
and that it was when the movement became "self-aware". So then I became
curious when the oss4lib.org domain was registered and a quick WHOIS lookup
told me:

Domain Name:OSS4LIB.ORG
Created On:17-Nov-1999 23:05:50 UTC

So perhaps ten years isn't that far off after all. I also had no idea it was
registered by someone in Portugal.
Roy

On 4/18/09 4/18/09 € 6:17 AM, "Peter Schlumpf" <[email-masked]>
wrote:

> This might be a good time to reflect upon where we've been and where we're
> headed.  Almost exactly ten years have passed, I think, since open source
> software in libraries became self-aware as a movement.  Sure, there has always
> been open source software, but I would mark the real start as when the oss4lib
> listserv came into being.  It provided a forum for like-minded folks to kick
> around ideas and discuss what they were doing.
> 
> I remember ALA 2000 in Chicago.  That was cool!  Tim O'Reilly graciously gave
> us space at his booth there, letting us show off the early projects we were
> doing.  And to any of you who happened to be at NERCOMP at Wesleyan University
> in Connecticut the following year -- I apologise.  I am not an extemporaneous
> speaker, as I discovered!
> 
> Then Koha happened.  Then Evergreen, and a multitude of other projects.
> Overall, I am pleased by what has happened.  Open source software for
> libraries has matured into a real option for any library.  My little project
> fell by the wayside during that time, but it's always been there -- I just
> haven't done much with it.  I am returning to it now with fresh ideas.
> 

--

---

From: Brenda Chawner <[email-masked]>
Date: Mon, 20 Apr 2009 11:46:14 +1200

My take: the projects are increasingly international, and now affect all aspects of library services, at least somewhere. I’m currently analysing my survey results (you may have received the invitation to participate last year), and I received responses from people in 33 countries, naming 43 individual projects (many of them library-specific, like Koha and Evergreen, and but others that were more general, like Plone and Drupal). FLOSS is almost mainstream for some things, particularly IRs and web content management, where the proprietary options are less mature (or too expensive for libraries).

I’ll be posting a better summary of the results when I have more to say (in a month or so, I hope). The other activity on my radar is developing an ‘advanced IT’ elective as part of our MLIS programme, and FLOSS licences, processes, and projects will be a large part of the curriculum. I’d be interested in hearing ideas from people here about what it should cover, and how much practical work (like scripting/writing CSS) it should include.

Brenda

--
Brenda Chawner
Senior Lecturer & LIM Programmes Director
School of Information Management
Victoria University of Wellington
P O Box 600, Wellington  NEW ZEALAND
(04) 463 5780 | fax (04) 463 5446 | Room EA201 | [email-masked]

---

From: Daniel Chudnov <[email-masked]>
Date: Mon, 20 Apr 2009 10:18:01 -0400

> Created On:17-Nov-1999 23:05:50 UTC

That's just the domain.  The site, and the list, went online in  
roughly February 1999, based at yale.  Wayback found out about it in  
april:

   http://web.archive.org/web/*/http://info.med.yale.edu/library/oss4lib

> registered by someone in Portugal.

All 280 of us here relocated the home office to Lisbon in 2006.  Where  
have you been?  And why don't you visit?

In case anybody wondered, that list is still alive, as are the  
majority of its subscribers.  Feel free to use it if you like.

   -Dan