Subject: [CODE4LIB] Digital imaging questions

From: "Deng, Sai" <[email-masked]>
Date: Thu, 18 Jun 2009 09:33:07 -0500

Hi, list,

A while ago, I read some interesting discussion on how to use camera to produce archival-quality images from this list. Now, I have some imaging questions and I think this might be a good list to turn to. Thank you in advance! We are trying to add some herbarium images to our DSpace. The specimen pictures will be taken at the Biology department and the library is responsible for depositing the images and transferring/mapping/adding metadata. On the testing stage, they use Fujifilm FinePix S8000fd digital camera

(http://www.fujifilmusa.com/support/ServiceSupportSoftwareContent.do?dbid=874716&prodcat=871639&sscucatid=664260). It produces 8 megapixel images, and it doesn't have raw/tiff support. It seems that it cannot produce archival quality images. Before we persuade the Biology department to switch their camera, I want to make sure it is absolutely necessary. The pictures they took look fine with human eyes, see an example at: http://library.wichita.edu/techserv/test/herbarium/Astenophylla1-02710.jpg

In order to make master images from a camera, it should be capable of producing raw or tiff images with 12 or above megapixels?

A related archiving question, the biology field standard is DarwinCore, however, DSpace doesn't support it. The Biology Dept. already has some data in spreadsheet. In this case, when it is impossible to map all the elements to Dublin Core, is it a good practice for us to set up several local elements mapped from DarwinCore?

Thanks a million,

Sai

Sai Deng
Metadata Catalog Librarian
Wichita State University Libraries
1845 Fairmount
Wichita, KS 67260-0068
Phone: (316) 978-5138
Fax:       (316) 978-3048
Email: [email-masked]
             [email-masked]

---

From: "Han, Yan" <[email-masked]>
Date: Thu, 18 Jun 2009 08:47:12 -0700

There are two things about archive images at least I can think of this moment:
1. the resolution: diff size/materials require different resolution. There is no one-size-fit-all. To make a judgment, I would like to know the image (color?), the size of the material?, 
2. the file format: TIFF is the recommended format due to its openness, stability, and lossless data over the time. If you believe that your jpeg file has enough resolution, I do not see any problem to convert it to tiff. 

Yan

________________________________________
From: Code for Libraries [[email-masked]] On Behalf Of Deng, Sai [[email-masked]]
Sent: Thursday, June 18, 2009 7:33 AM
To: [email-masked]
Subject: [CODE4LIB] Digital imaging questions

Hi, list,

Thanks a million,

Sai

Sai Deng

---

From: Andrew Hankinson <[email-masked]>
Date: Thu, 18 Jun 2009 12:02:45 -0400

Hi Sai,
"Archival Quality Images" has some meaning, but it might be helpful to look
up a standard and start your investigation for a new camera based on the
recommendations of that standard. You might find this page from the Library
of Congress helpful:

http://www.digitalpreservation.gov/formats/content/still.shtml

I think your indication that RAW/TIFF is a pretty safe bet, but being able
to point to an actual standard might make your case for a new camera a bit
more convincingly.  Other factors to take into account (other than
megapixels and format) are color reproduction, image 'noise' specifications,
DPI, lighting, (and probably many other things).

For DSpace you don't even need to map the elements of Dublin Core to
DarwinCore. Dspace has the ability to input different schema in its metadata
registry. You can then modify the "inputforms.xml" file in the Dspace config
directory to add the appropriate fields for the additional metadata fields.

Hope this helps!
-Andrew

On Thu, Jun 18, 2009 at 10:33 AM, Deng, Sai <[email-masked]> wrote:

> Hi, list,
>
>
>
> A while ago, I read some interesting discussion on how to use camera to
> produce archival-quality images from this list. Now, I have some imaging
> questions and I think this might be a good list to turn to. Thank you in
> advance! We are trying to add some herbarium images to our DSpace. The
> specimen pictures will be taken at the Biology department and the library is
> responsible for depositing the images and transferring/mapping/adding
> metadata. On the testing stage, they use Fujifilm FinePix S8000fd digital
> camera
>
> (
> http://www.fujifilmusa.com/support/ServiceSupportSoftwareContent.do?dbid=874716&prodcat=871639&sscucatid=664260).
> It produces 8 megapixel images, and it doesn't have raw/tiff support. It
> seems that it cannot produce archival quality images. Before we persuade the
> Biology department to switch their camera, I want to make sure it is
> absolutely necessary. The pictures they took look fine with human eyes, see
> an example at:
> http://library.wichita.edu/techserv/test/herbarium/Astenophylla1-02710.jpg
>
> In order to make master images from a camera, it should be capable of
> producing raw or tiff images with 12 or above megapixels?
>
>
>
> A related archiving question, the biology field standard is DarwinCore,
> however, DSpace doesn't support it. The Biology Dept. already has some data
> in spreadsheet. In this case, when it is impossible to map all the elements
> to Dublin Core, is it a good practice for us to set up several local
> elements mapped from DarwinCore?
>
> Thanks a million,
>
> Sai
>
>
> Sai Deng

---

From: "Deng, Sai" <[email-masked]>
Date: Thu, 18 Jun 2009 12:32:15 -0500

Andrew and Yan,
Thanks for the reply and the information!

About DSpace metadata registry, we can add new schema or new elements to it, but the elements won’t be searchable, right? (We can change the input-forms.xml to make it display in the submission workflow if we will have item by item submission.)

In our case, we already have the herbarium metadata in excel sheet created by Biology Dept. They are now in loose Darwin Core and kind of free style. If I would like to do data transformation (transform it to a mixture of DC and Darwin Core possibly) and batch import the xml to DSpace, how to proceed? Where should I add the Darwin Core metadata (in the dublin_core.xml as well)? It seems that it only has dcvalue element. 

Sai

-----Original Message-----
From: Code for Libraries [mailto:[email-masked]] On Behalf Of Andrew Hankinson
Sent: Thursday, June 18, 2009 11:03 AM
To: [email-masked]
Subject: Re: [CODE4LIB] Digital imaging questions

Hi Sai,

Hope this helps!
-Andrew

---

From: Andrew Hankinson <[email-masked]>
Date: Thu, 18 Jun 2009 14:38:38 -0400

I'm pretty sure you can add extra fields to the dublin_core.xml file and
import it. I think I did something like this a few years ago, but I'm a bit
fuzzy on the details.
For the metadata creation, it might be worth your while to save the Excel
spreadsheet to a CSV file and then write a parser (in Python or Ruby) that
will read the values from that spreadsheet and produce a dublin_core.xml
file. If you gather the photo files in the same location,
you can then use the DSpace bulk importer to import everything into
your collection.

See here:
http://www.tdl.org/wp-content/uploads/2009/04/DSpaceBatchImportFormat.pdf

You may be able to add extra fields to the search index. See here:
http://wiki.dspace.org/index.php/Modify_search_fields

On Thu, Jun 18, 2009 at 1:32 PM, Deng, Sai <[email-masked]> wrote:

> About DSpace metadata registry, we can add new schema or new elements to
> it, but the elements won’t be searchable, right? (We can change the
> input-forms.xml to make it display in the submission workflow if we will
> have item by item submission.)
>
> In our case, we already have the herbarium metadata in excel sheet created
> by Biology Dept. They are now in loose Darwin Core and kind of free style.
> If I would like to do data transformation (transform it to a mixture of DC
> and Darwin Core possibly) and batch import the xml to DSpace, how to
> proceed? Where should I add the Darwin Core metadata (in the dublin_core.xml
> as well)? It seems that it only has dcvalue element.
>
> Sai
>

---

From: Toke Eskildsen <[email-masked]>
Date: Fri, 19 Jun 2009 00:27:53 +0200

The Fujifilm FinePix S8000fd does have some issues with purple fringing (see http://www.dpreview.com/reviews/fujifilms8000fd/page5.asp for samples). In your image Astenophylla1-02710.jpg it is quite visible at the edge of the paper and around the bold letters in the bottom right corner.

The sensor of the camera is 1/2.35", 8MP. That is not a large sensor, but as you control the lightning, it should not matter all that much. Still, I must say that I found your image somewhat blurry, especially the flowers. Should I guess, I'd say that you positioned the camera a bit too close to the subject and did not use the macro function? If not, you should definitely try and test with another camera.

Another worrying issue is that the image appears to be very noisy in the blue channel. So much that it is visible to the naked eye when viewed on the screen 1:1. If you used normal household light bulbs for the lightning, that could be the answer as the camera has to boost the blue channel to compensate for the warm light.

I realize that your test-image is probably just a quick shot to see if the camera is usable for the task. However, in order to make a proper judgment you'll have to get a bit closer to expected shooting conditions. From the sample image itself, I'd say that you could do a lot better with either another (cheap) camera or better shooting conditions, depending on where the problem lies.

I wholly agree with Andrew that a camera with RAW and/or TIFF support would be preferable, especially if you're planning on using TIFF as the archival format anyway. You could buy a Canon PowerShot SD990, install CHDK (http://chdk.wikia.com/wiki/IXUS980IS) and get 14MP in RAW format for $430 (not a serious suggestion), but for quality the obvious choice is a DSLR. Better to have 8MP of high quality than 14MP of fairly okay.

NB: When inspecting the EXIF metadata, I noticed that PhotoShop has been involved in the workflow. The file size is also curiously large for a JPEG produced by a camera. Is the JPEG re-compressed? That makes it harder to judge image quality.

Regards,
Toke Eskildsen (Point'n'shoot camera user)
Sent: 18 June 2009 16:33

Hi, list,

Thanks a million,

Sai

Sai Deng

---

From: Jason Stirnaman <[email-masked]>
Date: Fri, 19 Jun 2009 08:49:30 -0500

> and then write a parser (in Python or Ruby) that

Sai,

That work has already been done in PHP: http://tds.terkko.helsinki.fi/utils/ I just used it for a small project. I tweaked it a tiny bit and tried to clarify the documentation, but otherwise it works really well.
Regarding the DSpace metadata registry, I'd recommend sending your question to dspace-tech maillist.

Jason
-- 

>>> On 6/18/2009 at 1:38 PM, in message
<[email-masked]>, Andrew Hankinson
<[email-masked]> wrote:
> http://www.fujifilmusa.com/support/ServiceSupportSoftwareContent.do?dbid=8747 
> 16&prodcat=871639&sscucatid=664260
>> ).