Subject: [NGC4LIB] The CERN Library publishes its book catalog as Open Data

From: Adrian Pohl <[email-masked]>
Date: Mon, 1 Feb 2010 13:33:00 +0100

Good news. The CERN library has published its data under a public domain license and works on migrating it into linked data. Hopefully lots of libraries (and at best OCLC with its forthcoming metadata policy) will follow this example.
 
Adrian

The CERN Library publishes its book catalog as Open Data

Librarians are in general very favourable to the principles of Open Access, but surprisingly few libraries have so far set free the data they produce themselves. As one of the first scientific libraries in the world, the CERN Library offers now the bibliographic book records, held in its library catalog, to be freely downloaded by any third party. The records are provided under the Public Domain Data License, a license that permits colleagues around the world to reuse and upgrade the data for any purpose. 
 
Jens Vigen, Head of the CERN Library, says: "Books should only be catalogued once. Currently the public purse pays for having the same book catalogued over and over again. Librarians should act as they preach: data sets created through public funding should be made freely available to anyone interested. Open Access is natural for us, here at CERN we believe in openness and reuse. There is a tremendous potential. By getting academic libraries worldwide involved in this movement, it will lead to a natural atmosphere of sharing and reusing bibliographic data in a rich landscape of so-called mash-up services, where most of the actors who will be involved, both among the users and the providers, will not even be library users or librarians. Our action is made in the spirit of the Berlin Declaration on Open Access to Knowledge in the Sciences and Humanities; bibliographic data belongs to the cultural heritage.All other signatories should align their policy accordingly." 
 
The data of CERN Library will be used by the Open Library Project to provide a webpage for every book and allow users to add content like table of contents, classifications and summaries. 
 
For massive reuse of data, the data will be provided soon by an open Z39.50, SRU and OAI interface via biblios.net, a repository of open bibliographic data. 
 
The whole dataset can be downloaded from
http://cern.ch/bookdata 
 
The press announcement is accompanied by a YouTube Video that can be found at:
http://www.youtube.com/watch?v=-CSmieTXbsk

---

From: Weinheimer Jim <[email-masked]>
Date: Mon, 1 Feb 2010 14:14:00 +0100

This is really great and I hope that other libraries will follow.

*But* the question will be how to incorporate all of this together in a coherent way. The standards of CERN are quite different from Anglo-American standards. Below is a record taken at random, with the record pf the same item in LC. After a quick look, I see that in CERN there is no size; in the LC record the place of publication reflects AACR2 practice of adding a place within the country of the cataloging agency; there are differences in the date of publication vs. date of copyright; no statement of responsibility and no edition statement in the CERN record; the paging itself is different. These last are important for AACR2's determination of copy vs. new edition. CERN's subjects reflect their narrower collecting focus vs. LCSH's broader focus, e.g. "Python" vs. "Python (Computer program language)." Noel Rappin's name does not have the date of birth as occurs in the NAF. There are several other differences, including some of differing cataloging philosophies.

None of this is to find fault, but rather, while the sharing is great, that is only a first step. How can we use these records in the best, most efficient way for our own purposes and for our users? Of course, some of these problems can be solved with URIs, but I don't believe everything can. Do we just settle for a mashup or can we do something else?

Jim Weinheimer

<record>
  <controlfield tag="001">984645</controlfield>
  <controlfield tag="005">20071109101316.0</controlfield>
  <datafield tag="020" ind1=" " ind2=" ">
    <subfield code="a">0596002475</subfield>
    <subfield code="u">print version, paperback</subfield>
 </datafield>
  <datafield tag="020" ind1=" " ind2=" ">
    <subfield code="a">9780596002475</subfield>
    <subfield code="u">print version, paperback</subfield>
 </datafield>
  <datafield tag="041" ind1=" " ind2=" ">
    <subfield code="a">eng</subfield>
 </datafield>
  <datafield tag="080" ind1=" " ind2=" ">
    <subfield code="a">004.438.Jython</subfield>
 </datafield>
  <datafield tag="100" ind1=" " ind2=" ">
    <subfield code="a">Pedroni, Samuele</subfield>
 </datafield>
  <datafield tag="245" ind1=" " ind2=" ">
    <subfield code="a">Jython</subfield>
    <subfield code="b">Essentials</subfield>
 </datafield>
  <datafield tag="246" ind1=" " ind2=" ">
    <subfield code="a">Rapid Scripting in Java</subfield>
    <subfield code="i">Cover title</subfield>
 </datafield>
  <datafield tag="260" ind1=" " ind2=" ">
    <subfield code="a">Beijing</subfield>
    <subfield code="b">O'Reilly</subfield>
    <subfield code="c">2002</subfield>
 </datafield>
  <datafield tag="300" ind1=" " ind2=" ">
    <subfield code="a">277 p</subfield>
 </datafield>
  <datafield tag="490" ind1=" " ind2=" ">
    <subfield code="a">O'Reilly &amp; Asociates books</subfield>
 </datafield>
  <datafield tag="650" ind1="1" ind2="7">
    <subfield code="2">SzGeCERN</subfield>
    <subfield code="a">Computing and Computers</subfield>
 </datafield>
  <datafield tag="653" ind1="1" ind2=" ">
    <subfield code="9">CERN</subfield>
    <subfield code="a">Jython</subfield>
 </datafield>
  <datafield tag="653" ind1="1" ind2=" ">
    <subfield code="9">CERN</subfield>
    <subfield code="a">Java</subfield>
 </datafield>
  <datafield tag="653" ind1="1" ind2=" ">
    <subfield code="9">CERN</subfield>
    <subfield code="a">Python</subfield>
 </datafield>
  <datafield tag="690" ind1="C" ind2=" ">
    <subfield code="a">BOOK</subfield>
 </datafield>
  <datafield tag="700" ind1=" " ind2=" ">
    <subfield code="a">Rappin, Noel</subfield>
 </datafield>
  <datafield tag="916" ind1=" " ind2=" ">
    <subfield code="d">200609</subfield>
    <subfield code="s">h</subfield>
    <subfield code="w">200638</subfield>
 </datafield>
  <datafield tag="960" ind1=" " ind2=" ">
    <subfield code="a">21</subfield>
 </datafield>
  <datafield tag="961" ind1=" " ind2=" ">
    <subfield code="c">20080407</subfield>
    <subfield code="h">2044</subfield>
    <subfield code="l">CER01</subfield>
    <subfield code="x">20060920</subfield>
 </datafield>
  <datafield tag="963" ind1=" " ind2=" ">
    <subfield code="a">PUBLIC</subfield>
 </datafield>
  <datafield tag="970" ind1=" " ind2=" ">
    <subfield code="a">002647668CER</subfield>
 </datafield>
  <datafield tag="980" ind1=" " ind2=" ">
    <subfield code="a">BOOK</subfield>
 </datafield>
  <datafield tag="964" ind1=" " ind2=" ">
    <subfield code="a">0001</subfield>
 </datafield>
</record>

LC Control No.: 	 2003266066
LCCN Permalink: 	http://lccn.loc.gov/2003266066
000 	01438cam a22003494a 450
001 	13108602
005 	20090729142230.0
008 	030303s2002 ch a b 001 0 eng
010 	__ |a 2003266066
015 	__ |a GBA2-Y6751
020 	__ |a 0596002475
035 	__ |a (OCoLC)ocm49044531
040 	__ |a UKM |c UKM |d CUS |d TXA |d CUY |d DAY |d DLC
042 	__ |a pcc
050 	00 |a QA76.73.J38 |b P43 2002
082 	04 |a 005.133 |2 21
100 	1_ |a Pedroni, Samuele.
245 	10 |a Jython essentials / |c Samuele Pedroni and Noel Rappin ; foreword by Jim Hugunin.
250 	__ |a 1st ed.
260 	__ |a Beijing ; |a Sebastopol, CA : |b O'Reilly, |c c2002.
300 	__ |a xx, 277 p. : |b ill. ; |c 23 cm.
500 	__ |a "Rapid scripting in Java"--Cover.
504 	__ |a Includes bibliographical references (p. xvi-xvii) and index.
650 	_0 |a Java (Computer program language)
650 	_0 |a Jython (Computer program language)
650 	_0 |a Python (Computer program language)
700 	1_ |a Rappin, Noel, |d 1971-
856 	42 |3 Publisher description |u http://www.loc.gov/catdir/enhancements/fy0715/2003266066-d.html
856 	42 |3 Contributor biographical information |u http://www.loc.gov/catdir/enhancements/fy0912/2003266066-b.html
906 	__ |a 7 |b cbc |c pccadap |d 2 |e ncip |f 20 |g y-gencatlg
925 	0_ |a acquire |b 2 shelf copy |x policy default
955 	__ |a ps05 2003-03-03 to ASCD |c jf05 2003-03-11 to subj. |d jf09 2003-03-11 to sl |e jf12 2003-03-12 to Dewey |a jf16 2003-07-11 copy2 to BCCD

James Weinheimer  [email-masked]
Director of Library and Information Services
The American University of Rome
via Pietro Roselli, 4
00153 Rome, Italy
voice- 011 39 06 58330919 ext. 258
fax-011 39 06 58330992

-----Original Message-----
From: Next generation catalogs for libraries [mailto:[email-masked]] On Behalf Of Adrian Pohl
Sent: Monday, February 01, 2010 1:33 PM
To: [email-masked]
Subject: [NGC4LIB] The CERN Library publishes its book catalog as Open Data

Adrian

---

From: "Mitchell, Michael" <[email-masked]>
Date: Mon, 1 Feb 2010 08:01:09 -0600

That's good. I don't understand the statement "surprisingly few
libraries have so far set free the data they produce themselves." There
are hundreds of libraries offering free direct Z39.50 access to their
bib records. Just because you don't like MARC doesn't negate the fact
that the information is easily available and free.

Michael Mitchell
Technical Services Librarian
Brazosport College
Lake Jackson, TX
michael.mitchell at brazosport.edu 
-----Original Message-----
From: Next generation catalogs for libraries
[mailto:[email-masked]] On Behalf Of Adrian Pohl
Sent: Monday, February 01, 2010 6:33 AM
To: [email-masked]
Subject: [NGC4LIB] The CERN Library publishes its book catalog as Open
Data

Good news. The CERN library has published its data under a public domain
license and works on migrating it into linked data. Hopefully lots of
libraries (and at best OCLC with its forthcoming metadata policy) will
follow this example.
 
Adrian

Librarians are in general very favourable to the principles of Open
Access, but surprisingly few libraries have so far set free the data
they produce themselves. As one of the first scientific libraries in the
world, the CERN Library offers now the bibliographic book records, held
in its library catalog, to be freely downloaded by any third party. The
records are provided under the Public Domain Data License, a license
that permits colleagues around the world to reuse and upgrade the data
for any purpose. 

Jens Vigen, Head of the CERN Library, says: "Books should only be
catalogued once. Currently the public purse pays for having the same
book catalogued over and over again. Librarians should act as they
preach: data sets created through public funding should be made freely
available to anyone interested. Open Access is natural for us, here at
CERN we believe in openness and reuse. There is a tremendous potential.
By getting academic libraries worldwide involved in this movement, it
will lead to a natural atmosphere of sharing and reusing bibliographic
data in a rich landscape of so-called mash-up services, where most of
the actors who will be involved, both among the users and the providers,
will not even be library users or librarians. Our action is made in the
spirit of the Berlin Declaration on Open Access to Knowledge in the
Sciences and Humanities; bibliographic data belongs to the cultural
heritage.All other signatories should align their policy accordingly." 
 
The data of CERN Library will be used by the Open Library Project to
provide a webpage for every book and allow users to add content like
table of contents, classifications and summaries. 
 
For massive reuse of data, the data will be provided soon by an open
Z39.50, SRU and OAI interface via biblios.net, a repository of open
bibliographic data. 

The press announcement is accompanied by a YouTube Video that can be
found at:
http://www.youtube.com/watch?v=-CSmieTXbsk

---

From: Bernhard Eversberg <[email-masked]>
Date: Mon, 1 Feb 2010 15:04:28 +0100

Weinheimer Jim schrieb:
> 
>  There are several other differences, including some of differing cataloging philosophies.
> 
There are indeed substantial other differences: there are no indicators
for names and titles, and none for almost everything else,
series titles are mostly abbreviated (like "Internat. Ser. Lin. Math.")
and always use 490 only. And no 008, nor a leader or other fixed fields.

I'm afraid this is a very diluted version of MARC. Will others
dumb down their data in exactly the same way or in any number
of different ways? Whom and how much might that help?

And then, for data as meager as this, MARCXML is an extremely voluminous
wrapper, there's at least five times more wrapping than there is data.
Though space is no issue any more, bandwidth is, and it can't
pass for an elegant means of exchange this way. That's not CERN's fault,
of course. But what's needed is a much more compact and more easily
understandable (human readable) communication format. Lacking this,
Z39.50 nd OAI-DC are currently doing a much better job.

B.Eversberg

---

From: David Pattern <[email-masked]>
Date: Mon, 1 Feb 2010 14:15:27 +0000

Surely the important thing here is the license?

Can I reuse Z39.50 data from library X in a commercial application?  Who knows?  Just because you expose something doesn't make it free for reuse or free of IPR.

By specifying it as Open Data with a Public Domain Dedication, anybody can do anything with the data.

Dave Pattern
Library Systems Manager
University of Huddersfield

-----Original Message-----
From: Next generation catalogs for libraries [mailto:[email-masked]] On Behalf Of Mitchell, Michael
Sent: 01 February 2010 14:01
To: [email-masked]
Subject: Re: [NGC4LIB] The CERN Library publishes its book catalog as Open Data

Michael Mitchell

---
This transmission is confidential and may be legally privileged. If you receive it in error, please notify us immediately by e-mail and remove it from your system. If the content of this e-mail does not relate to the business of the University of Huddersfield, then we do not endorse it and will accept no liability.

---

From: Adrian Pohl <[email-masked]>
Date: Mon, 1 Feb 2010 15:23:10 +0100

>>> "Mitchell, Michael" <[email-masked]> 01.02.2010 15:01 >>>
 
"Free access" doesn't equal open data. "Open" - as I understand it - implies the possibility to download the whole data at once. And you can't do that via Z39.50-access. See the open definition (http://opendefinition.org/) which says in short:
 
"A piece of knowledge is open if you are free to use, reuse, and redistribute it."
 
In the full definition it says: 
"The work shall be available as a whole..." with the comment: "As a whole' prevents the limitation of access by indirect means, for example by only allowing access to a few items of a database at a time."
 
So, while library data is free available it isn't 'open' in the widest sense of the word. And surely an open license makes it clear for every (re)user what she is allowed to do with the data. By now a good deal of data in the internet (not only bibliographic data) isn't licensed at all and leaves potential users clueless. That even applies to the data in the Linked Data Cloud (see http://cloudofdata.com/2009/10/licensing-of-linked-data/).
 
Adrian

---

From: Karen Coyle <[email-masked]>
Date: Mon, 1 Feb 2010 07:18:29 -0800

Whoa! Wait a minute! Do we reject all data that doesn't look like  
ours? Are we unable to make use of data from other communities? That's  
a pretty insular point of view. Why not look for how we can benefit  
from this data rather than rejecting it out of hand? Yes, they use  
different cataloging rules. But they have scientific reports that we  
will probably not find elsewhere.

No size? that only would matter to a library that was putting it on a  
shelf, and then only if it is an especially odd size. I've been  
thinking that we should drop size altogether except for ones that need  
special shelving. (For modern books, not rare books.)

Only the first place of publication is given? Show me an example where  
I need both in order to get a book to a user. (Actually, show me an  
example, in a modern book, where I need place of publication at all to  
get a book to a user.)

How different is "277 p." from "xx, 277 p."? Well I can tell you that  
no one outside of libraries has any clue as to what that "xx" means,  
but "277 p." in both of those statements is clear.

Different subject headings? I see that as *more* not *less*. We also  
get different subject headings from publishers, and often they are  
closer to what the user is seeking than LCSH.

Really, folks, try the glass half full approach, or die of thirst  
while others create flexible, open bibliographic resources.

kc

p.s. we will be ingesting these records into the Open Library, and  
quite honestly I don't think it'll be difficult.

-- 
Karen Coyle
[email-masked] http://kcoyle.net
ph: 1-510-540-7596
m: 1-510-435-8234
skype: kcoylenet

---

From: Weinheimer Jim <[email-masked]>
Date: Mon, 1 Feb 2010 16:54:01 +0100

Karen,

I agree with you 100% and why I went into the detail in the first place. I think one of our basic tasks will be to *work together* for the benefit of all. That does not mean that everything must be "dumbed down" but standards must be maintained somehow.

Having the open metadata from CERN is absolutely great, and Adrian explained the importance of truly open data very well, but somehow we all must find some kind of ways to cooperate, because otherwise, we will be doomed to recatalog the same things over and over and over again because the other standards don't measure up. In my own opinion, one of the first chores is for the metadata creators to understand the standards used by other communities, and this is why I initiated the Cooperative Cataloging Rules http://sites.google.com/site/opencatalogingrules/ (shameless self-promotion!).

This will be a painful process in many ways but I think if we don't do it ourselves, Google-like entities will do it for us by mashing everything together.

-----Original Message-----
From: Next generation catalogs for libraries [mailto:[email-masked]] On Behalf Of Karen Coyle
Sent: Monday, February 01, 2010 4:18 PM
To: [email-masked]
Subject: Re: [NGC4LIB] The CERN Library publishes its book catalog as Open Data

kc

---

From: Adrian Pohl <[email-masked]>
Date: Wed, 3 Feb 2010 14:39:04 +0100

Dan Brickley has made some interesting use of CERN library's data. He posted a visualization on flickr that gives an overview over the collection's composition based on UDC classes: http://www.flickr.com/photos/danbri/4326955233/
 
Patrick Danowski - Emerging Technologies Librarian at the CERN - says in a blogpost (http://www.bibliothek2null.de/2010/02/03/open-data-works/) that this is a nice example of a non-intended use of open data. And unintended (re)use of data is the main reason for opening up data in the first place...
 
Adrian

>>> Weinheimer Jim <[email-masked]> 01.02.2010 16:54 >>>
Karen,

-----Original Message-----
From: Next generation catalogs for libraries [mailto:[email-masked]] On Behalf Of Karen Coyle
Sent: Monday, February 01, 2010 4:18 PM
To: [email-masked]
Subject: Re: [NGC4LIB] The CERN Library publishes its book catalog as Open Data

kc