Subject: [NGC4LIB] When everyone starts with Google - follow-on to Jim Weinheimer Extend Search posting

From: Cindy Harper <[email-masked]>
Date: Mon, 24 May 2010 16:11:42 -0400

I also have a little project I've been thinking about for a while now
involving a browser plug-in. It would try to intercept searches sent to
Google, and give a pop-up with info on possible library resources. It's
still in development, but what I envision is to capture Google searches in
our public labs and send them to this application, that uses the library
catalog as a keyword index that leads to the appropriate subject guides. We
don't have indexed LibGuides, so this would serve in that role, plus it
would possibly translate more granular search phrases into the more general
topic areas that our subject guides cover.  Or at least it offers a pop-up
that advertises the materials the library pays for.

What it does is: a keyword search on the search phrase in the library
catalog;
                        sorts the call-number ranges of the results from
that search;
                        consults a mapping of call-number ranges to subject
guides;
                        presents the user with those possible subject guide
links.

The problems now:
   - It's based on III's Z39.50 server, which appears to have a big flaw
(that III says is corrected in the next release which we will load in
June).
  - It takes a while to retrieve and process the Z39.50 results
  - it's ASP .NET VB - I don't think that's a problem, but I need to
learn/convert to AJAX to simplify the processing of the responses to the
survey at the end.
  - will I even get approval to collect the info on users' Google searches
for this experimental use?
 - oh, yes, I have a little CSS problem I haven't fixed yet.

But you can try it and see what you think:
http://lisv06.colgate.edu/aftergoogle/default.aspx?searchargs=mathematics+assessment

Cindy Harper, Systems Librarian
Colgate University Libraries
[email-masked]
315-228-7363

---

From: Weinheimer Jim <[email-masked]>
Date: Tue, 25 May 2010 09:47:38 +0200

This is a very clever idea. I would think this could be done with a plugin, where the browser would automatically do a separate search into the tool you made, and a popup could appear. I don't think you would need any permissions from anyone--when people install the plugin, you would be taking the information from the browser, not from Google, and I could imagine that a agreement to do this could be taken for granted upon installation. If people decide they don't like it, they can always disable it.

You may be interested in my own version of the "Research Guides". Since I have very few staff, it is highly difficult for me to create these guides and keep them current. Therefore, I decided on a different route. I collected specific ones here on my Library Wiki: http://aurlibrary.wetpaint.com/page/Research+Guides but then I got an idea for a "Do-It-Yourself Research Guide Finder" at http://www.galileo.aur.it/opac-tmpl/npl/en/pages/diyfinder.html which lets you search Google for more specific research guides. All it does it take their search and add a more specific search to it. (I find I always have to "tweak" the query for better results, by the way) You can also get this to work with my plugin by choosing "Synonyms/Conceptual Tools" but that only hides the research guide finder!

Hmmmm....

Jim

James Weinheimer  [email-masked]
Director of Library and Information Services
The American University of Rome
via Pietro Roselli, 4
00153 Rome, Italy
voice- 011 39 06 58330919 ext. 258
fax-011 39 06 58330992

-----Original Message-----
From: Next generation catalogs for libraries [mailto:[email-masked]] On Behalf Of Cindy Harper
Sent: Monday, May 24, 2010 10:12 PM
To: [email-masked]
Subject: [NGC4LIB] When everyone starts with Google - follow-on to Jim Weinheimer Extend Search posting

The problems now:

---

From: Cindy Harper <[email-masked]>
Date: Tue, 25 May 2010 09:12:16 -0400

You have a wealth of great ideas on your pages!  I need to have our
reference people look through your pages to see what other ideas we can
copy.  We do of course look at other libraries' research guides when making
our own, and I had speculated about making an app that could build a
meta-research guide, but that would be a pretty difficult project.

On Tue, May 25, 2010 at 3:47 AM, Weinheimer Jim <[email-masked]>wrote:

> This is a very clever idea. I would think this could be done with a plugin,
> where the browser would automatically do a separate search into the tool you
> made, and a popup could appear. I don't think you would need any permissions
> from anyone--when people install the plugin, you would be taking the
> information from the browser, not from Google, and I could imagine that a
> agreement to do this could be taken for granted upon installation. If people
> decide they don't like it, they can always disable it.
>
> You may be interested in my own version of the "Research Guides". Since I
> have very few staff, it is highly difficult for me to create these guides
> and keep them current. Therefore, I decided on a different route. I
> collected specific ones here on my Library Wiki:
> http://aurlibrary.wetpaint.com/page/Research+Guides but then I got an idea
> for a "Do-It-Yourself Research Guide Finder" at
> http://www.galileo.aur.it/opac-tmpl/npl/en/pages/diyfinder.html which lets
> you search Google for more specific research guides. All it does it take
> their search and add a more specific search to it. (I find I always have to
> "tweak" the query for better results, by the way) You can also get this to
> work with my plugin by choosing "Synonyms/Conceptual Tools" but that only
> hides the research guide finder!
>
> Hmmmm....
>
> Jim
>
> From: Next generation catalogs for libraries [mailto:
> [email-masked]] On Behalf Of Cindy Harper

---

From: Ed Jones <[email-masked]>
Date: Wed, 26 May 2010 08:17:37 -0700

Along these lines, the LibX browser plug-in offers users the ability to automatically search the library catalog from a Google search results screen.  The library icon appears at the top of the Google search results page (right after the statement of the number of results), and clicking on it triggers a catalog keyword search for the terms you just entered into Google.

Ed Jones
National University, San Diego