Subject: Re: [NGC4LIB] Linking headings in bib records to other resources

From: "Goldner,Matt" <[email-masked]>
Date: Wed, 28 Apr 2010 09:00:34 -0400

This has been done in WorldCat.org to link to WorldCat Identities. You can find in  the Details section of full records. Identities was created by mining WorldCat for an authors works and works about any person or character. It is a popular option that users click on frequently. It can also be embedded in other services.

Matt Goldner
Product & Technology Advocate
OCLC

OCLC Online Computer Library Center, Inc.

----- Original Message -----
From: Next generation catalogs for libraries <[email-masked]>
To: [email-masked] <[email-masked]>
Sent: Wed Apr 28 08:41:52 2010
Subject: [NGC4LIB] Linking headings in bib records to other resources

Dear NGC4LIB readers,

Jimmie Lundgren said in a recent post "Another useful navigation tool ... is the ability to click on headings in displayed records to retrieve other records with those headings."  As is widely known, in OCLC WorldCat you can click on headings in bibliographic records to retrieve the authority record, if the heading has been "controlled."  ("Control" in this context appears to be equivalent to "link.")

Has anyone developed functionality to link headings in bibliographic records, not to an authority record, but to an outside source that provides further information?  For example: A personal name heading might be linked to an online biographical resource about that person.  

- Ian

Ian Fairclough
George Mason University
[email-masked]
703-993-2938 (office)
__________________________

---

From: Derek Rodriguez <[email-masked]>
Date: Wed, 28 Apr 2010 10:12:38 -0400

All,

    At TRLN <http://search.trln.org> we have implemented a feature that 
takes advantage of Worldcat Identities to suggest authorized name 
headings to users within results lists.  This falls into the category of 
"name suggester services" I think.

    How does it work?  When a user initiates an author search in Search 
TRLN, we send the query string to the WorldCat Identities NameFinder 
service and retrieve by JSON the 6 most popular (by OCLC holdings) 
authorized headings that match the search.  These headings are presented 
as hyperlinks at the top of the results list and when clicked generate 
new searches of Search TRLN.  NameFinder's fuzzy-matching algorithms 
boost the likelihood of retrieving a helpful heading in cases where 
users misspell a name.  To help with disambiguation, we display a link 
to the appropriate Identities page and a mouse-over tool tip displays 
publication dates and subject headings associated with the suggested 
heading.  You can see an example in this search: 
<http://search.trln.org/search?N=0&Nty=1&Ntk=Author&Ntt=john+adams>

    We're still gathering usability data on this feature, but we are 
hopeful that this provides a degree of name authority functionality 
within our Endeca application.     

    BTW, many thanks go to Ralph Levan at OCLC Research for his help in 
implementing this service.

    Derek  

-- 
Derek Rodriguez
Program Officer
Triangle Research Libraries Network
CB# 3940, Wilson Library
Chapel Hill, NC 27514-8890
919-962-8022 fax:919-962-4452
[email-masked]
http://www.trln.org

---

From: Eric Lease Morgan <[email-masked]>
Date: Wed, 28 Apr 2010 10:19:34 -0400

> "name suggester services" I think.

In the most recent issue of Code4Lib there was an article describing something very similar:

  Querying OCLC Web Services for Name, Subject, and ISBN
  
  Using Web services, search terms can be sent to WorldCat’s
  centralized authority and identifier files to retrieve
  authorized terminology that helps users get a comprehensive
  set of relevant search results. This article presents
  methods for searching names, subjects or ISBNs in various
  WorldCat databases and displaying the results to users.
  Exploiting WorldCat’s databases in this way opens up future
  possibilities for more seamless integration of
  authority-controlled vocabulary lists into new discovery
  interfaces and a reduction in libraries’ dependence on local
  name and subject authority files.
  
  By Ya’aqov Ziso, Ralph LeVan, and Eric Lease Morgan
  http://journal.code4lib.org/articles/2481

-- 
Eric Morgan
University of Notre Dame