Subject: [NGC4LIB] User interace design and trust

From: Peter Schlumpf <[email-masked]>
Date: Tue, 30 Mar 2010 14:12:47 -0600

The little faux pas that I committed yesterday by mixing my personal email
with the ngc4lib list sheds a little light on user interface issues.  I've
been thinking today why this happened.  It was late and I was tired last
night.  But I think part of the problem is the Gmail interface hides too
much, and makes it too easy to make such mistakes.  Now I am not trusting
it.  Is it really doing what I intend?  Am I really replying to that person
only, or am I replying to the group as well?  The Gmail interface isn't
clear about that.  I actually have to take a look at the raw email headers
to verify that what I intended actually happened.  And one can only do that
after the fact.

I think this can be applied to catalog interfaces as well.  Is it delivering
what the user intends, or is it trying to do too much behind a thick layer
of abstraction that makes a lot of assumptions about the user's intentions?
Trust is a big issue with user interface design.

Peter Schlumpf
http://www.avantilibrarysystems.com

---

From: Weinheimer Jim <[email-masked]>
Date: Wed, 31 Mar 2010 12:04:52 +0200

In this same vein, I just finished reading an article in the latest College & Research Libraries (Mar 2010, no. 2) "What are they learning? Pre-and post-assessment for LIBR I 100, Introduction to Library Research" by Jon Hufford. They did tests of students before and after an information literacy course.
What I found interesting were the results concerning users' understanding of the library catalog e.g.:

"What is the least likely resource to use to find citations to articles?
A - library's online catalog
B - electronic databases
C - internet
D - search engines
e - periodical indexes 

Pre: 6% chose a. Post: 28% chose a.

Another:
"It is possible to find full-text magazine articles in the library's online catalog." True-False

Pre: 18% chose False. Post: 22% chose falso.

And most telling:
"Which of the following kinds of information can be found in the Library's online catalog.
A - journal articles
B - journals the library owns
C - books on a certain topic
d - book reviews
e - sound recordings the library owns

Pre: 4% chose b,c,e. Post: 5% chose b,c,e. (I would have emphasized "catalog records" for journals, books, etc. the library owns, not the books themselves)

In fact, from this entire report, the students appear to show a much greater understanding of the digital materials and tools than the traditional library materials and tools. This mirrors my own experience. Young people (most people?) don't know what they are searching when they search Google vs. Google Books vs. Lexis-Nexis vs. an OPAC ... [et al.]. When I try to explain the differences of what they are searching in each database when they enter text into the search box, I see they are struggling, and I find it extremely complex to explain. I still believe that the traditional library catalog is becoming increasingly strange to our patron community.

I have tried to solve some of this with the Extend Search in my catalog to at least make it simpler to search all of these different places, but you are right: there needs to be a lot of serious work in interface design.

James Weinheimer  [email-masked]
Director of Library and Information Services
The American University of Rome
via Pietro Roselli, 4
00153 Rome, Italy
voice- 011 39 06 58330919 ext. 258
fax-011 39 06 58330992

-----Original Message-----
From: Next generation catalogs for libraries [mailto:[email-masked]] On Behalf Of Peter Schlumpf
Sent: Tuesday, March 30, 2010 10:13 PM
To: [email-masked]
Subject: [NGC4LIB] User interace design and trust

Peter Schlumpf

---

From: Bernhard Eversberg <[email-masked]>
Date: Wed, 31 Mar 2010 12:23:24 +0200

Weinheimer Jim wrote:

> ... there needs to be a lot of serious work in interface design.
> 

and don't forget to tack on glistening new labels "RDA" and "FRBRized".

B.Eversberg

---

From: Chad Fennell <[email-masked]>
Date: Wed, 31 Mar 2010 08:51:00 -0500

> to verify that what I intended actually happened.  And one can only do that

I love me some Gmail, but you're not alone:

"I can think of a half-dozen applications I regularly use where the
ejector seat button is inexplicably placed right next to the cabin
lights button. Let's take a look at our old friend GMail, for example"
http://www.codinghorror.com/blog/2010/03/the-opposite-of-fitts-law.html

There's a subtle art to all this, but there are also a few heuristics
that can help us to avoid really bad decisions.

-Chad

---

From: Laval Hunsucker <[email-masked]>
Date: Wed, 31 Mar 2010 12:43:36 -0700

> Is it delivering what the user intends, or is it
> trying to do too much behind a thick layer

Sometimes ( but not often enough to pass muster ) 
the former, in essence the latter. ( I.e., for *this*
user -- but users of course come in many flavors. )

To sum up :  still pretty crude.

 - Laval Hunsucker
   Breukelen, Nederland

----- Original Message ----
From: Peter Schlumpf <[email-masked]>
To: [email-masked]
Sent: Tue, March 30, 2010 10:12:47 PM
Subject: [NGC4LIB] User interace design and trust

Peter Schlumpf