Subject: Re: [NGC4LIB] After MARC...MODS?

From: James Weinheimer <[email-masked]>
Date: Mon, 26 Apr 2010 06:01:18 -0400

On Thu, 22 Apr 2010 21:53:44 +1000, Alexander Johannesen
<[email-masked]> wrote:

>On Thu, Apr 22, 2010 at 21:18, Weinheimer Jim <[email-masked]> wrote:
>> How about this? Pretend that you are interested in the history
>> of black people in agriculture in the United States. Tell me how
>> you would go about searching and retrieving information in
>> Google or Google Scholar or a related tool using full text.
>
>Well, I pop "black people in agriculture in the United States" and get
>back 1.3 million hits of which, one can assume, there is valuable
>information. I go through them, and copy and paste into my research
>document anything that smacks of gold.
>
>And this satisfy your use case 100%; this is someone with an interest.

Sorry I didn't respond to this earlier since I only saw it now. Your results
and reactions are extremely interesting. 

First:
You say that you get back "...1.3 million hits of which, one can assume,
there is valuable information. I go through them, and copy and paste into my
research document anything that smacks of gold." 

What??? You go through 1.3 million hits???? You are a really fast reader!
Sorry, but that one I will never believe. And this is one of the main
problems when my students find when they use a tool such as Google in
practice: the result is completely out of control. When they have gotten the
same types of results for simple purposes relating to their own general
interest, they don't care so much about the search result since it can be
fun to "surf." But when they are grappling with something important such as
writing a paper, where they have to stick to a specific topic, and they
could flunk out if they quote something stupid, they see Google as something
much less useful and more similar to a toy. And it frightens them.

While they feel there may be something there in the search result of 1.3
million (and I add: or not there, see below), but the results are in a
completely unpredictable order that change constantly, based on the number
of links to an item (and thus, place #1 is determined primarily by bloggers)
plus there are a number of other factors that determine ranking which are
business secrets of Google. It has been shown without a doubt that this
order can be manipulated for all sorts of purposes (for obvious examples,
see Google-Bombing in Wikipedia, but this is being done constantly in far
more subtle ways). As I tell my students, the Google use of the term
"relevance" does *not at all* equal their own understanding of the term
"relevance" and they should not confuse the two. The Google use is a
secretive business term but one chosen strategically to make their customers
more comfortable. It works.

Second:
What exactly are you looking at when you see the results from "black people
in agriculture in the United States" and also, what are you not looking at?
Well, you miss many original documents, because the term "blacks" was not
the word used for African-American people in agriculture in the early United
States. There were other terms used, some highly insulting today. When a
cataloger puts in metadata, it's a completely different matter. In a library
catalog, you don't have to search these older terms, but in full-text you
do, or they will never come up in the result--and you will never realize it.
As a result, you miss entire categories of really useful information. 

Other problems: "agriculture" is unnecessarily limiting. You would also have
to search at least "farming" but probably others as well. Searching "United
States" will miss most of the information in the individual states, where
there will be lots of possibly the most interesting resources. 

I won't discuss "quality of information" here, which is another huge problem
that people have to face every day. You say, "anything that smacks of gold"
but how am I supposed to know that? Also, I won't discuss exactly what
Google is and is not searching when you do a search, because this is another
of their closely-head secrets.

So we see that what at first glance appears to be extremely simple: typing a
few words into a box and getting a result, is incredibly complex and
terribly limiting. It takes an expert to understand how limiting it is.
Google has done an excellent job of making it seem to be simple, and they
have done this by designing a tool to *make people happy*, but we should not
confuse this with providing results that are reliable and comprehensible,
which is what people really want. And it has serious consequences, as
students will tell you.

I would suggest that when people see matters in this way, they will see the
immensity of such a task, and that they will have a bit more respect for the
work done in catalogs, which smooths the way for people. But of course, "we
won't get no respect!"

Perhaps this is too detailed for your purposes, but it certainly is not too
detailed for the students I work with, who are being serious about it and,
as I say, terribly worried about it since not dealing with it could derail
their entire careers.

Library catalogs are designed on different principles and have strengths in
exactly these areas, and this is why I think that creating a tool that would
bring the strengths of library catalogs together with full-text retrieval
tools would be the best. But simply ignoring what our tools can do would be
the same as allowing superstition and bias and even censorship to run rampant.

James Weinheimer  [email-masked]
Director of Library and Information Services
The American University of Rome
via Pietro Roselli, 4
00153 Rome, Italy

---

From: Alexander Johannesen <[email-masked]>
Date: Mon, 26 Apr 2010 20:49:05 +1000

Hola, Senor!

> What??? You go through 1.3 million hits???? You are a really fast reader!

I *think* you know what that statement really mean; I go through the
first five or six pages, middle-click on links that seem relevant for
me, and leave the Google results page open. I now have about 20 tabs
open, and I scroll through each and one looking for relevant info.
Some will have links, some will have text, some will have questions
where there might be answer. When these tabs are exhausted I check if
my urges have been satisfied. Yes? Done. No? Go through the next 5 or
6 pages of Google results, pop relevant pages into tabs, rinse, repeat
until all my naughty urges go away.

> the result is completely out of control.

Umm, it's not called "relevance ranked" because they are completely
out of control. They're called that because there is an implied
methodology of relevancy that may or may not match my preferences, but
they are *far* from out of control.

> When they have gotten the

I think you're extrapolating a little bit too much here, mostly
because I don't agree and have different experiences. I deal with
students a lot these days, helping them study for, well, "something
important like writing a paper", and there are really good techniques
one can use with Google. The first phase is to search in your own
words. Then you find more formalized statements, and you search for
those. Then you ad a few keywords to that, maybe a couple of words in
quotation to filter. You'll probably find some websites that look
proper, either by name or design, and you use the site: trick. You
know the drill.

The interesting part is ; did I get enough and good enough information
through this method?

> The Google use is a

Yes, it does work.

> in agriculture in the United States" and also, what are you not looking at?

There is a better librarian answer if I popped that same search into
an OPAC and got a few hundred pages of, um, something?

> States. There were other terms used, some highly insulting today.

But you're making a blanket statement on what is a process. You'd face
the *exact* same problem in a library catalog. And just like in the
catalog, you can get hints as to what to search for next.

> When a

Again, you're assuming people are complete idiots.

> of their closely-head secrets.

But there is *no* difference between the library catalog, its meta
data, and Google in any of the searches we're here discussing.
Problems here, and problems there. By me saying Google certainly
doesn't imply your ILS serves me any better. Where is this "better"
that you're talking about?

> work done in catalogs, which smooths the way for people. But of course, "we

The problem is that meta data *doesn't* solve this problem, but I bet
a small fortune that future textual analysis will.

> Perhaps this is too detailed for your purposes

I gave you a very detailed and very real use case. Can you solve it better?

> exactly these areas

How? Unless you mean "by invoking a reference librarian to do the
searches for you"?

> and this is why I think that creating a tool that would

I've yet to see how much better the library tools are. Prove me wrong.

Regards,

Alex
-- 
 Project Wrangler, SOA, Information Alchemist, UX, RESTafarian, Topic Maps
--- http://shelter.nu/blog/ ----------------------------------------------
------------------ http://www.google.com/profiles/alexander.johannesen ---

---

From: Bernhard Eversberg <[email-masked]>
Date: Mon, 26 Apr 2010 12:59:11 +0200

> which is what people really want. And it has serious consequences, as
What Google is excellent at is the "known-item search". You need only
know a characteristic phrase and its exact spelling(!), put it in
quotes, and you are happy.

This must not be confounded with the *subject search*, but this mixing
up of different functions is what happens all the time: users think
they get stuff *about* XYZ while they always only get stuff that
contains the character sequence "XYZ". Within a full text, various
synomyms and inflections of a term may occur and the impression may
arise that Google finds not what you entered but what you wanted, what
you had in mind. In this case, results might make you feel lucky, but
you'd not be happy to know that you missed better stuff that contained
the (politically or otherwise) more correct or more pertinent or
up-to-date wording. Not to speak of other languages ... But of course,
the million or so "results" do often contain stuff that looks quite
relevant, so in many cases the unlucky person turns away with it.
And of course, it doesn't always matter if you find the best stuff,
something "good enough" will do most of the time. But the experience
wires your attitude into thinking "G. finds stuff about XYZ".

What Google is the worst at is collocation searching (works by ...,
editions of ..., parts of ...).
What it doesn't do at all is any other arrangement than "relevance".
(A misleading metaphor, but everyone is happy with it.)

GBS does a much less "fuzzy" search. More often than not, you have
to enter an exact spelling or get nothing. With ISBNs, for example, in
the cases where they have only the metadata, you have to enter an ISBN
without hyphens or you end up not happy at all.

In another check last week, I found that about 25% of recent books
(1995 to present) currently on loan (i.e., in demand), are in GBS as
part of their "publisher program", which means available as "preview".
Not a one title was available in full (much different with 19th cent
titles!). 75% were only found as references, if at all. So, a "critical
mass" has not been reached yet.

B.Eversberg

---

From: Weinheimer Jim <[email-masked]>
Date: Mon, 26 Apr 2010 14:13:32 +0200

Alexander Johannesen wrote:
<snip>
I've yet to see how much better the library tools are. Prove me wrong.
</snip>

And therein lies the entire discussion. I proved the statement wrong and it is simply ignored, along with dismissing everything else I demonstrate. I desmonstrated that there is a difference between searching concepts and searching text, and that *people cannot search concepts in full-text tools such as Google. They search text. And within certain, known limits, people can search concepts in a library catalog.* Period. I realize that this must be very uncomfortable, but it cannot be denied, only ignored or to say that it's unnecessary.

But I think more than anything the following statement is revealing:
<snip>
> [about the term "relevance"] The Google use is a

Yes, it does work.
</snip>

Yes, it has worked. All of this deep skepticism toward libraries disappears in the face of the Google-hype. They have succeeded in making their results so comfortable that everyone is supposed to simply accept whatever the black box serves up to them. I find it interesting that even you, with your deep skepticism towards us, which I admire in many ways, have thrown it off towards Google. Why can't you be as skeptical toward Google as toward library tools?

Again, the library-type tools are not simple to use, but are an expert system. They have needed to be changed for a long time but I've gone into that in other messages and won't go into it here.

<snip>

</snip>

Not at all. It was just stated that people are supposed to simply accept whatever Google throws at them, after just looking through a few screens. Why would they suddenly become skeptical and display a much higher level of understanding to consider something like, "Oh! I shouldn't forget that I'm only searching terms and not concepts, so therefore, I must think about other words used for African-Americans in the past." And immediately be able to come up with half-a-dozen or so. I have met no one who has ever thought that way: students, or well-established scholars, *except* for some librarians. 

I personally think that people  who do not understand these sorts of things are not idiots, they are simply not experts. Much as if I don't know how to work on my television set it doesn't make me an idiot.  

Sorry, but to paraphrase:
"I've yet to see how much better the full-text tools are. Prove me wrong."

Regards,
James L. Weinheimer  [email-masked]
Director of Library and Information Services
The American University of Rome
Rome, Italy

---

From: Alexander Johannesen <[email-masked]>
Date: Mon, 26 Apr 2010 23:19:24 +1000

Hi,

On Mon, Apr 26, 2010 at 22:13, Weinheimer Jim <[email-masked]> wrote:
> And therein lies the entire discussion. I proved the statement wrong and
> it is simply ignored, along with dismissing everything else I demonstrate.

No, you've proved nothing. What are you holding up as evidence here?
You merely talking about the wonders of a different method doesn't
mean the different method by default is proven better. This is a tug
between methods, and to prove them you need to do the methods in the
tools that support them, and I suspect you agree with that one. But
you *haven't* pointed out what you do through your method that is
objectively better. You say it is better, that certain kinds of
searching demands it, yet where is the evidence that we *need* your
method, that it performs *better* than alternatives, that your tools
are better at *supporting* that method, and so on.

> I desmonstrated that there is a difference between searching concepts and
> searching text, and that *people cannot search concepts in full-text tools
>  such as Google. They search text.

What is the difference between a concept and a text? Nothing in itself
; they're both pieces of text string. The difference lies in the data
model behind the *tools*. The human aspect of this is completely void;
it's a null argument. The tools *may* have an advantage searching
concepts, but you have not demonstrated that this is so. Show me a
concept, even the African-American example, being done better, that
you somehow get to better results through your tools rather than
Google. Show me the juice.

> And within certain, known limits, people can search concepts in a
> library catalog.* Period. I realize that this must be very uncomfortable,
> but it cannot be denied, only ignored or to say that it's unnecessary.

No, it's not uncomfortable ; it's nonsense. Perhaps if you wish it
really, really hard you would hope it would be so, but it simply
isn't. Search Google with any concept, and you will get results. The
whole idea of what a concept is is pure bunk. Again, I dare you to
show me better search results in an OPAC than in Google. Any example
will do. Here's what I suspect will happen ;

You'll get lots of stuff. You start sifting through it to see what is
relevant, what is useful. You do additional searches, maybe similar
concepts, related subject headings, maybe even a hardcore librarian
combination of sorts. You end up with a shortlist of stuff.

How *exactly* is this different to how I used Google in my previous
email (and removing the word "concept" completely)?

> But I think more than anything the following statement is revealing:
...
> Yes, it does work.
> </snip>
>
> Yes, it has worked. All of this deep skepticism toward libraries
> disappears in the face of the Google-hype. They have succeeded in
> making their results so comfortable that everyone is supposed to
> simply accept whatever the black box serves up to them. I find it
> interesting that even you, with your deep skepticism towards us, which
> I admire in many ways, have thrown it off towards Google. Why can't
> you be as skeptical toward Google as toward library tools?

Well, there's a few things I need to say. The first is that remember
that I have developed several OPACs in the past. I'm not some idiot
observer on the sidelines talking crap, I happen to know very well -
probably better than most librarians - how the backend ILS and OPAC
systems work. And remember I'm also a data model buff, working with
semantic technologies ; the difference between two conceptual ways of
doing search on the same meta data lies in the data model. But here,
talking Google vs. libraries, there's a paradigm shift in how that
search works ; it's limited but precise (and I'm not talking about
data quality here) meta data vs. fuzzy and complex full-text. I know
how both works. I can evaluate which one does it best. And, sorry to
say, but due to a number of factors Google wins hands down (factors
that work against the library way include data quality, lossy data
model, rules so complex integrity falters, human validation, and a few
other bits and bobs). Google win by already being good, and will win
by still getting better.

But let's get something perfectly clear ; I'm not skeptical of
librarian knowledge, only the tools in place and the meta data
integrity which renders the knowledge pretty useless at times. I don't
have any deep skepticism towards you - the lovely and stubborn
librarians of the world! - I have a skeptic, or more to the point
depressing, hope of you guys being able to pull off tools and meta
data quality in order to promote that your knowledge is valuable to
the world. I don't see it happening, but I would love nothing more
than being proved wrong in this!

> Not at all. It was just stated that people are supposed to simply accept whatever Google throws at them

But you see, that simply isn't so! People don't accept whatever comes
out of Google anymore than they accept whatever comes out of your
OPAC. And to be frank, people are not stupid ; if they don't get the
results they want, they search again, at the library, using Google, or
going to the hardware store.

> Why would they suddenly become skeptical and display a much higher
> level of understanding to consider something like, "Oh! I shouldn't forget
> that I'm only searching terms and not concepts, so therefore, I must think
> about other words used for African-Americans in the past." And
> immediately be able to come up with half-a-dozen or so. I have met no
>  one who has ever thought that way: students, or well-established
> scholars, *except* for some librarians.

So what you're saying is that your OPAC does this? No, it most
probably does not. There might be a librarian sitting behind a desk
that might think this, so your point is more that the human guide is
valuable. Sure, no disagreement there. Doesn't make our tools
superior, though.

Oh, btw, Google has ontological suggestions by default now at the
bottom of the page. They're pretty good, and getting better. And
filtering. And sorting. And I'm sure they'll think of something funky
next. Like a thesaurii option.

> "I've yet to see how much better the full-text tools are. Prove me wrong."

Well, are we looking for books, or knowledge?

Regards,

Alex
--- http://shelter.nu/blog/ ----------------------------------------------
------------------ http://www.google.com/profiles/alexander.johannesen ---

---

From: Weinheimer Jim <[email-masked]>
Date: Mon, 26 Apr 2010 16:13:32 +0200

Alexander Johannesen wrote:
<snip>
No, you've proved nothing. What are you holding up as evidence here?
You merely talking about the wonders of a different method doesn't
mean the different method by default is proven better. 
</snip>

Pardon, I have never maintained that searching library catalogs is *better.* I have said that there are powers that are absolutely not in the Google-type searches, and that these powers are important. While you may continue to maintain that you can search concepts through these newer tools, or that it's unimportant to do so, many of my students certainly have problems with full-text and have wound up in deep holes. The Semantic Web project wouldn't need to be built. I demonstrated what you would miss by searching Google in the way you did "blacks agriculture united states", but those are all dismissed, and besides, how could somebody be aware of materials you never even see in the first place? You didn't see it; you were happy with the result you would get in Google, even after I showed some of the concepts you could not--by definition--possibly see or even know about. How are you supposed to know about these things that are in your "concept" but that don't appear in your se!
 arch result? 

(Somehow the entire argument seems reminiscent of the "Unknown unknowns" of Donald Rumsfeld. See "The Poetry of D.H. Rumsfeld" Seeley, Hart. The Poetry of D.H. Rumsfeld, Slate, April 2, 2003, at http://www.slate.com/id/2081042. See his "poem" The Unknown)  :-)

How do you do this in a library catalog? It's a lot of work. You have to find the authorized forms (i.e. "concepts") of everything, look at the cross-references for related "concepts," find catalog records that seem to match your search and search the "concepts" you find there. The tool is powerful if you know how to use it. But I can't show this in 5 minutes--that's why there is such a thing as bibliographic instruction and information literacy courses.

I fully agree that it is too much work to expect people to do this today. What people were forced into doing 25 years ago because there was no choice just doesn't work today. Different databases have to be merged, all kinds of helps for the users must be created and implemented. But searching by concepts is too important to simply dump, which is what it seems as if you are advocating.

<snip>
> library catalog.* Period. I realize that this must be very 
> uncomfortable, but it cannot be denied, only ignored or to say that it's unnecessary.

No, it's not uncomfortable ; it's nonsense.
</snip>

Of course it's nonsense. I'm glad you have such a deep expertise on the fundamentals of how a catalog works that it simply outshines all of my own experiences as well as that of many other catalogers on this list, so that our ideas can simply be dismissed as nonsense. Continue to insist that a search for "cats" or "blacks" or "Dostoyevsky" pull out their related "concepts" from Google, and maintain how useful they are to people. And people will believe it until it is not just a matter of surfing and hunting around, and information becomes a serious matter for them. That's when we have to pick them up.

This is one of the big problems that catalogers have towards many systems people. While catalogers and librarians are supposed to respect everything the systems people say about the power of the new searching (which my students will insist doesn't work much of the time, protestations to the contrary--but their complaints can all be ignored), these same systems people insist that they know everything we know, only more and better. 

I am happy in your faith in Google. It is truly unshakeable.

Regards,
James Weinheimer  [email-masked]
Director of Library and Information Services
The American University of Rome
via Pietro Roselli, 4
00153 Rome, Italy
voice- 011 39 06 58330919 ext. 258
fax-011 39 06 58330992

---

From: Peter Schlumpf <[email-masked]>
Date: Mon, 26 Apr 2010 09:17:17 -0500

On 4/26/10, Weinheimer Jim <[email-masked]> wrote:
> And therein lies the entire discussion. I proved the statement wrong and it
> is simply ignored, along with dismissing everything else I demonstrate. I
> desmonstrated that there is a difference between searching concepts and
> such as Google. They search text. And within certain, known limits, people
> can search concepts in a library catalog.* Period. I realize that this must
> be very uncomfortable, but it cannot be denied, only ignored or to say that
> it's unnecessary.

Anyway you look at it, both opacs and Google simply match patterns of text
and return the results.  To say otherwise for either is to suggest some sort
of inherent intelligence in the system itself.

Two things:

1.  80 percent of success is showing up.  Google definitely shows up.  It is
good enough for most people and in most situations, and it is continually
getting better all the time.  Amazon too actually appears far more useful to
me than most opacs today if you want to search for a book or learn about
it.  Most opacs don't shine a light to Amazon.  Good enough and constantly
improving is what matters.  Many librarians measure improvement of their
tools in years and decades.  Google and Amazon demonstrate measurable
improvement in months.

2.  In order to objectively evaluate full text tools with MARC based
catalogs, remove the human elements.  You cannot fall back on the reference
librarian as an active element in a search.  The tools must stand up on
their on technical merits.  A knife in the hands of an experienced chef does
not make it any sharper in any objective sense.  Likewise Google in the
hands of an experienced reference librarian will return different results.
If it requires an "expert" to use a tool effectively, something is wrong.
And no, users do they accept whatever Google throws at them.  To make the
assumption that they do disrespects the user.  Not all patrons need
handholding.

And a third thing.  What a cataloger thinks is an important semantic mapping
is not necessarily what is important to the user.  So all these static
semantic structures in MARC based opacs basically reflect the minds of
librarians -- not patrons.  Depending on how close those two worldviews are
to eachother they either mesh well or mesh poorly.  Static is an important
word here.  Imagine an opac with a semantic map that actually adjusts itself
automatically to the inputs that are thrown at it over time.  I'll bring
more thoughts on that idea later.

Peter Schlumpf
www.avantilibrarysystems.com

---

From: Weinheimer Jim <[email-masked]>
Date: Mon, 26 Apr 2010 17:03:08 +0200

Peter Schlumpf wrote:

<snip>
</snip.

While this is correct, it needs to be kept in mind that--for better or worse--this is *not* the way the OPAC, or the online public *card catalog* is designed to work. This is part of the knowledge that is being lost.

During the time of card catalog and before, people never searched "text" like they do today because it wasn't possible. They browsed cards that were arranged in a conceptual manner. You could arrange these concepts primarily in two ways. First was a classified way as they did in many European libraries, and so you would search for "dogs" under animals--vertebrates--mammals... (whatever the classification is). In the US, they opted for the "Dictionary catalog" which used alphabetical order (and then some classified arrangements after that) so that you searched for "dogs" by going to "D" and browsing to "dogs" and perhaps finding a cross-reference to "Canines."

This is still what we do. Isn't that freaky?! This is why I say that taking a record outside of the catalog it belongs to is a bit like taking a fish out of water: it can't really exist on its own because it is so reliant on so many other things. It becomes more or less senseless and will die on its own.

This is why you can search concepts in the catalog, and shows that people searched concepts before OPACs. In fact, they had no other choice. When computers arrived, catalogers used them as a more efficient way to *make cards,* not to find and access, and when online access came about (Online Public Access Catalogs), everybody just kept on doing their same old thing, while the systems people threw on keyword searching. This actually messed up the traditional, conceptual way to search the catalog and therefore, the traditional catalog card traditions disintegrated in the online environment. Nobody talked about it much; it was never fixed but just ignored.

Does this need to be changed? Of course (and keep in mind that RDA and FRBR do not change these functions in any fundamental way! That's one of the many reasons why I maintain they must be reconsidered), but the access the card catalog provided, and still provides through the OPACs, can still be extremely powerful, so long as they are used properly.

---

From: Alexander Johannesen <[email-masked]>
Date: Tue, 27 Apr 2010 14:29:11 +1000

Jim,

> Pardon, I have never maintained that searching library catalogs is
> *better.* I have said that there are powers that are absolutely not
> in the Google-type searches, and that these powers are important.

Ok, let's go through this together ; we are talking about how the one
is better at getting to results over the other. Your initial challenge
was in "Afro-Americans in US agriculture through history" where the
pitfalls are what certain concepts were called at various points
through time, so if you search for Afro-Americans you won't get the
more contemporary blacks (or worse). And you give anecdotal evidence
for you being correct that Google does a crap job at this.

Here's my point again ; there are many different ways of achieving the
"best" results, either through your way or the Google way or some
other way. This is all search methodology, and *not* eschatology of
the tools we use. These are human problems of a more linguistic nature
more than they are concepts that are embedded in our various cultures
and our data models.

How to get this point across? Let's build on logic ; if I can get from
A to B (the path of starting from nothing, and getting to the piece of
knowledge I sought) through means X, why is means Y important? By this
I'm not saying means Y is not important nor helpful nor interesting.
I'm asking *why* it is so. You might have an opinion and some
experience that tell you that means Y *is* important, maybe there's
some cross-pollinations going on there, tacit journeys of knowledge,
stronger basis of truth, whatever, something! But just stating that an
alternative means is important should be backed up with value
statements that points to value.

How do we get to knowledge? How do we get to *good* knowledge? What
does "good" mean? It used to be that we *only* got good knowledge
("good" as in trusted, verified, backed-up, written down, stored away,
agreed through consensus, etc.) through means Y. These days there's
also means X, Z and L. Their intrinsic importance is rooted in whether
they bring the good knowledge or not. How they do it is actually
irrelevant in a value-system based on the knowledge itself.  (Do also
note here that the value system for knowledge has changed just as
dramatically as the means and medium of knowledge has)

I suspect this is the cause for our disagreement. There is the
potential of knowledge (the corpus), then the found knowledge (the
search), and then the scrutiny of the found knowledge (eh, scrutiny).
Both our models (yours and mine in this dispute) have *greatly*
different results at every single point, the method of doing each
point differ, but the functionality of the points are exactly the
same. You might say that the quest is the same, the paths, lakes and
mountains are the same, but they all have different cities and towns
with different names around, and the language used are different.

It's easy to scrutinize the corpus for which is better (Google has
more, has different things, in more languages, unstructured), a little
harder looking at the search results, and most hard at the actual
scrutiny of what was found (especially hard in libraries where you
don't actually have the knowledge yet, just a physical "link" to it).
But this is not controversy. The real problem lies in the change of
value systems of knowledge, the change in access to the channels of
knowledge, and the changing shape of  knowledge itself. Knowledge is
not attached to concepts, is not found in meta data, it cannot be
found through a search on Google nor a reference librarian with spare
time ; you find it in the model in which you perceive that knowledge.
What I suspect we all (all who create computer systems that deal with
knowledge)  struggle to do is to create a computer system model that
match the mental model as far as possible so that knowledge is easier
to spot and consume.

Let me get a few words in in answer to your next statements to clarify ;

> While you may continue to maintain that you can search concepts through
> these newer tools, or that it's unimportant to do so, many of my students
> certainly have problems with full-text and have wound up in deep holes.

Jim, my point here was that "concepts" are themselves just a concept,
a human construct to define something that is mostly undefinable yet
recognizable as knowledge. "African-American" is such a concept that
some times holds value to the searcher, other times not. There is no
given intrinsic value in that concept on the knowledge it tries to
portray, so to speak. In order for the human brain to encapsulate the
knowledge it needs the external model to match with the internal
model. Concepts, as widely used, tries to perform this function, but
it is as fallible as there are other concepts that overlap and as many
other concepts are attached to the knowledge (and remember that *no*
concept is also a concept!) .

You have as much chance of getting the right piece of knowledge as
there are pieces of knowledge around. There's simply too many
parameters in the search to say that it holds any particular value
over any other method of doing so, and our example here is our library
specialist vs. Google dichotomy ; your method, in order to be a
contender for what we want to practice and persevere with, must be
able to demonstrate value. What value?

Well, that was what I wanted you to point out. And this next session
points to this, and I feel I must say something about ;

> The Semantic Web project wouldn't need to be built. I demonstrated
> what you would miss by searching Google in the way you did "blacks
> agriculture united states", but those are all dismissed

... because it's a straw man. I can do the same to you; if you
searched for Mark Twain you will miss out all of that which was
written by Samuel Clemens or Josh or Thomas Jefferson Snodgrass. Yeah,
I know ; rookie mistake, so off you go and do the right searches, tick
the right boxes, concoct the right search. Therein lies my point ; in
Google you do the same. And there just like in the library, if no one
tells you or gives you the hints of these alternative paths, you will
get stuck in a hole.

So what you're saying is, and I asked you this specifically in my last
post, that the librarian helping you search *is* this advantage you're
talking about, and in fact it is not how you can search for concepts,
tick the right boxes or concoct just the right arcane search riddle in
order to get the OPAC gods to answer properly. The librarian *knows*
these tricks, and demonstrates their awesome powers, just like someone
else like me can know the Google tricks and demonstrate my powers. The
methodology is the same, the path is the same. However, the data is
not, nor is the result.

> and besides, how could somebody be aware of materials you never
> even see in the first place?

The library doesn't do any better here.

> You didn't see it; you were happy with the result you would get in Google,
>  even after I showed some of the concepts you could not--by definition
> --possibly see or even know about. How are you supposed to know about
>  these things that are in your "concept" but that don't appear in your
> search result?

Here I feel you're grasping for straws (not least by saying I'm so
happy with whatever I get from Google. Didn't you read my Google
methodology?). Why are you so persistent in saying that the search
result possibly can't (by its very definition, no less!) give these
hints? Of course they do! Every single returned item is a hint of
where to go to or search for next. Remember, it's a network? A network
of fully available text? It's millions upon millions of links all
there to make to search around until you find what you're after. I'm
sure we can take off on some imaginary search and explain the good and
the bad of the method, but if you get to good knowledge, why does the
method matter? What value do you offer that is worth persevering with?

> How do you do this in a library catalog? It's a lot of work. You
> have to find the authorized forms (i.e. "concepts") of everything,
> look at the cross-references for related "concepts," find catalog
> records that seem to match your search and search the "concepts"
> you find there. The tool is powerful if you know how to use it.

As an aside, do you know that this is the very essence of Topic Maps
technology, something I've peddled here and other places for over 10
years? Sometimes I wonder if librarians ever pay attention to anything
outside people ever say. *grumble*

> But I can't show this in 5 minutes--that's why there is such a thing
> as bibliographic instruction and information literacy courses.

Their complexity does not bode well for explaining their value, though.

> Of course it's nonsense. I'm glad you have such a deep expertise on
> the fundamentals of how a catalog works that it simply outshines all
> of my own experiences as well as that of many other catalogers
> on this list, so that our ideas can simply be dismissed as nonsense.

No need to get snarky; I stated my credentials just to make sure that
I wouldn't be dismissed as an outsider who don't know what they're
talking about, like what a lot of librarians would do when they're
challenged. I know *something* about what goes on in the back there,
and I have some knowledge to judge what you say about concept search,
specialist search tools and their like. I'm not some Google loving
wanker who dismiss the good ol' librarian ways because I don't think
they're worth anything.

I'm trying to make you explain that value, a) so that I can understand
it better, and b) for you to scrutinize it better, and c) for all of
us to make sure we know that what we claim is good *really* is good.

> Continue to insist that a search for "cats"

In a discussion like this even *you* will have to give context. A
concept doesn't exist until you need it. I could indeed be looking for
plain normal feline cats, and my result would have been perfect. So
what cats are you on about?

> or "blacks"

1. Blacks clothing, 2. Wikipedia "Black" the color, 3. Wikipedia
"Black people" ; either of these give hints that your search was
wrong, and 3. specific details of what you should be looking for.

> or "Dostoyevsky"

Did you mean: Dostoevsky

> pull out their related "concepts" from Google, and maintain how
> useful they are to people. And people will believe it until it is not just
> a matter of surfing and hunting around, and information becomes
> a serious matter for them. That's when we have to pick them up.

I suspect that there are many, many people you don't pick up at all
because, well, they are better at searching Google. Or a semantic
search engine. Or the search in specialist tools. Or DBpedia. Or
Wikipedia.

Why do I get the feeling you think the web and Google are dead-ends in
finding good knowledge, that after the search result comes back,
*that* is the premise for the argument for Google? It sounds a bit,
um, strange coming from someone like you who have demonstrated in the
past deep knowledge of all the paths that lead to good knowledge.
Surely you haven't forgotten? Surely this is a misunderstanding
between us, where rhetorical devices gets a little overused in trying
to score points for your home team?

> This is one of the big problems that catalogers have towards many
> systems people. While catalogers and librarians are supposed to
> respect everything the systems people say about the power of the
> new searching (which my students will insist doesn't work much of the
> time, protestations to the contrary--but their complaints can all be
> ignored), these same systems people insist that they know everything
> we know, only more and better.

If you mean me as part of that systems people group, I'm saddened that
your reading comprehension of my mails and the generic gist of what
I'm trying to depict has gone down the gurgler. No one in this systems
people group fight for the librarian knowledge nuggets more than me.
Maybe you're confusing my scrutiny of their value in the future
library and non-library systems for a generic devaluation of library
knowledge?

> I am happy in your faith in Google. It is truly unshakeable.

I don't care about Google, nor do I care about any brand or method. I
do, however, care about what brings results. I do believe in getting
better results, quite a lot. That is the belief that is unshakable;
that we must always strive for getting better, and that there always
will be better ways. I don't care whether that is called Jim's crazy
system or Google. Results. End of story.

Alex
--- http://shelter.nu/blog/ ----------------------------------------------
------------------ http://www.google.com/profiles/alexander.johannesen ---

---

From: Weinheimer Jim <[email-masked]>
Date: Tue, 27 Apr 2010 10:23:13 +0200

Alex,

I think we are actually on the same side, more-or-less, but there are some basic points of difference in our world-views. This may, or may not, have to do with the world-views of our perspective roles as cataloger or systems person.

A Disquisition on the Idea of "Better"

It seems as if the goal of "better" search results should be accepted as a given. What could be more obvious than that? But it is important to understand above all that this is *not* true for a library catalog. It's also not true for many other things in our world. That may seem strange, but the evidence is all around us.

Library experience has shown that "better" is far too subjective to be a practical goal. What is better for me may very well be worse for you. As an illustration, I have always considered the process of cataloging to be similar to that of a mechanic (although I know this may irk some out there, from my working-class background, I consider comparison to a master mechanic to be a great compliment). The mechanic working on your car seeks to make your machine go *the way it is supposed to go.* If he tries to make your car go "better," it must give you pause because then it will be going *in the way it is not supposed to go.* While it may end up genuinely going "better," it may only appear that way to you and it may actually be worse in ways you don't even know and appear at unfortunate moments: polluting the atmosphere, being more prone to going out of control on curves, or in other ways.

This problem with coming up and implementing new ideas was something I pointed out in a thread I began about "lack of imagination" among catalogers. Boy, have I been excoriated for that one! But I still maintain it: the job of catalogers is to adhere to standards--just as mechanics must--and therefore, flights of imagination cannot be included within the system where those standards function. There can be brilliance within the system, and I have witnessed it many, many times, but not "flights of imagination." This may be good or bad, but if catalogers want to let their imaginations free, which I think is vital today, they must work outside the system where those standards function, otherwise, they destroy it.

Library catalogs aim for *reliable* search results and not the "best" results. If I am interested in "love" and search in a library catalog with full cross-references, and I do it correctly, that is, following the methods laid down in the 19th-century for using card and printed catalogs (please keep reading!), I look under "L" browse to "Love" and find:

Narrower Term:  Attachment behavior.
Narrower Term:  Communism and love.
Narrower Term:  Courtly love
Narrower Term:  Courtship.
Narrower Term:  God (Christianity)--Love.
Narrower Term:  God (Christianity)--Worship and love.
Narrower Term:  God (Hinduism)--Worship and love
Narrower Term:  God (Islam)--Love [proposed]
Narrower Term:  God (Islam)--Worship and love.
Narrower Term:  God (Islam)--Worship and love [proposed update]
Narrower Term:  God (Judaism)--Love.
Narrower Term:  God (Judaism)--Worship and love.
Narrower Term:  God--Love.
Narrower Term:  God--Worship and love.
Narrower Term:  Love, Maternal.
Narrower Term:  Love, Paternal.
Narrower Term:  Marriage.
Narrower Term:  Platonic love.
Narrower Term:  Summer romance
Narrower Term:  Unrequited love.
Narrower Term:  Yoga, Bhakti.
See Also:  First loves
See Also:  Friendship.
See Also:  Intimacy (Psychology)

I think this is a provocative display that actually opens my mind to new possibilities that otherwise, I most probably would never have thought of. (Love to Summer romance, or to Bhakti yoga!) When I look at the individual records under the heading/concept "love", I can be assured that I am looking at all items in my local collection (but not journal articles) where the topic of "love" equals 20% or more of the content (that is, *if* the catalogers behind the scenes have been trained to do this job and continue to do their jobs correctly, which is becoming increasingly problematic). Also, since there are so many books where 20% is on love, this topic has had to be subdivided into myriad groupings. And it is really handy to be able to separate out other things such as Love Act (Musical group) and Love actually (Motion picture). Please be aware that I also cannot use my imagination and decide that "Wedlock" is "better" than "Marriage" and enter it instead, because then the who!
 le system breaks down. 

Please understand, there can be no dispute about what I just wrote here. These are facts about how the machine works. These facts are being forgotten, and disputing them would be similar to arguing with your mechanic that the pistons shouldn't work this way, but some other way. While you can have whatever opinion you like, it doesn't change the fact that this is the way the pistons are supposed to work. Creating new records that fit into this system correctly is also highly complex.

Therefore, the library catalog does not aim for "better" results, but "reliable" results and "reliability" is based on a whole number of factors. I maintain that if Google is aiming for "better" results, that's fine but "better" still remains a terribly subjective term that in practice equals "the result that makes me happy, but I may be happy only because I don't know what I may be missing. If I knew what I was missing, I might not be happy, but if I don't know, then ignorance is bliss."

Now to change focus: can and should this traditional library catalog model, which relies on adherence to strict standards, be maintained in the new environment? This I do not know and I don't think anyone will know without some kind of genuine research and "flights of imagination". I will say that it is important to search by differentiated "personal, corporate, and geographic names" and "subjects" (I don't know so much about titles), and that it would be very nice to be able to distinguish one Michael Gorman from another Michael Gorman.

The current *method* of browsing headings is definitely 100% obsolete, and has been since about 5 minutes after the implementation of keyword searching in the catalog. I would certainly like to see some new attempts to make the power of our headings more obvious in the new environment instead of just abandoning them. At last we are getting some tools such as Aquabrowser, but I personally find them unconvincing. Vivisimo and Grokster are on the right track and have also provided some interesting attempts but I haven't seen anything with library-type headings.

If there are no imaginative attempts to make these traditional controls more useful today however, these standards probably will be abandoned as useless. These imaginative attempts presuppose open data however, and this has not been forthcoming from the library community. For example, while I applaud the id.loc.gov project, it was much too late, and we are still stuck with textual strings that must be browsed to be understandable, and therefore, we are still stuck in the 19th-century. If these incredible files had been put out 10 years ago for open development, they could very well have served as the backbone for the Semantic Web, but now, this will probably shift to something such as dbpedia, where I think we must get on board.

This is enough for now. I think that "better" will probably be the goal of the newer systems, although it must obviously be qualified by many, many caveats. 

Regards,

---

From: Bernhard Eversberg <[email-masked]>
Date: Tue, 27 Apr 2010 12:46:01 +0200

Weinheimer Jim wrote:
> 
> ... imaginative attempts presuppose open data however, and this has
 > not been forthcoming from the library community. For example,
 > while I applaud the id.loc.gov project, it was much too late,
 > and we are still stuck with textual strings that must be browsed
 > to be understandable, and therefore, we are still stuck in the
 > 19th-century. If these incredible files had been put out 10 years
 > ago for open development, they could very well have served as the
 > backbone for the Semantic Web, but now, this will probably shift
 > to something such as dbpedia, where I think we must get on board.
> 
For that reason, I have now merged German WikiPedia titles into the
recent free database of subject headings by DNB Frankfurt. Some 64.500
Wiki titles exactly matched DNB headings. Since the stuff is all
German, it will be useless for most on this forum to look at, but
DNB themselves had already collaborated with Wikipedia to get
links for personal names included in it, pointing into the Frankfurt
OPAC of the German National Bibliography. Now, the same could
be done for topics.

Something like a ...pedia, i.e. something open, would be needed
for RDA as well, instead of the black box we'll be getting now.
At a time when there are voices that the future of free reading is at
stake (Richard Stallman), the library world itself, historically the
citizen's resort for free knowledge resources, will not have
free access to the text of its (allegedly) most important
code of rules. How credible can we be if this happens? It bodes ill
for the success of RDA, I think, but it may be just as well because
RDA doesn't seem to be a blueprint for next generation catalogs
anyway. The fact of this happening, however, is a bad omen.

B.Eversberg

---

From: "Rinne, Nathan (ESC)" <[email-masked]>
Date: Tue, 27 Apr 2010 11:56:26 -0500

"The librarian *knows* these tricks, and demonstrates their awesome
powers, just like someone else like me can know the Google tricks and
demonstrate my powers."

Alex,

Of course, the structure of the Google system is secret and protected -
and open to all who would seek to understand it - where the structure of
the library's system is not.  It is transparent.  Therefore, of course,
the "Google tricks" you learn may or may not be useful later.
Therefore, like Jim's analogy with the mechanic, you can figure out
whether the system is working according to its design (and as we know,
in many cases with library databases, this is not the case).  There is
even a good chance that you can talk to the "mechanic" in the library
who knows what he's doing.  With Google, who knows what they are doing
with their ever-evolving secret sauce?  

Don't get me wrong: search engines like Google are valuable.  At the
same time, in a sense, one of these systems requires more "faith" than
the other.    Some users may be ready to take that plunge whole hog,
consigning OPACs and the like to the trash heap, but others of course
aren't ready, in the quest for mere "results", to "let go and let
Google" (and of course I'll teach my kids the same thing: namely, don't
trust systems that aren't transparent, that aren't potentially
knowable).       

And that, I think, may be one of the root reasons why there is this
persistent disagreement over how to see things.          

Regards, 

Nathan Rinne
Media Cataloging Technician
Educational Service Center
11200 93rd Avenue North
Maple Grove MN. 55369
Email: [email-masked]

-----Original Message-----
From: Next generation catalogs for libraries
[mailto:[email-masked]] On Behalf Of Alexander Johannesen
Sent: Monday, April 26, 2010 11:29 PM
To: [email-masked]
Subject: Re: [NGC4LIB] After MARC...MODS?

Jim,

Did you mean: Dostoevsky

Alex
-- 
 Project Wrangler, SOA, Information Alchemist, UX, RESTafarian, Topic
Maps
--- http://shelter.nu/blog/
----------------------------------------------
------------------ http://www.google.com/profiles/alexander.johannesen
---

---

From: "Rinne, Nathan (ESC)" <[email-masked]>
Date: Tue, 27 Apr 2010 11:58:45 -0500

My apologies.  I think every time I comment I have to correct myself.  

and open to all who would seek to understand it

and *is not* open to all who would seek to understand it

Nathan Rinne

-----Original Message-----
From: Rinne, Nathan (ESC) 
Sent: Tuesday, April 27, 2010 11:56 AM
To: 'Next generation catalogs for libraries'
Subject: RE: [NGC4LIB] After MARC...MODS?

Alex,

Regards, 

Nathan Rinne

-----Original Message-----

Jim,

Did you mean: Dostoevsky

Alex

---

From: Alexander Johannesen <[email-masked]>
Date: Wed, 28 Apr 2010 14:47:34 +1000

Jim and Nathan,

First Jim : "Better" and "reliable" are synonyms to the subjective
user, and I'm always writing from his or her perspective, never from
the librarian perspective, which perhaps not only clarify my language
and stance, but why we seem to have these contradicting views which
when scrutinized become agreement. I'm sure that "reliable" is - how
to put this? - a better goal, however I don't think I see users worry
about the operating word here, nor what your goal is per se.

Apart from that I don't have much to say as you didn't really address
many of the larger points I was making. :)

Nathan :
> the library's system is not.  It is transparent.

The library system may be open in theory, this we all agree too. But
in practice the system requires librarians to function, which is one
of my main points.

> Therefore, of course,

The Google tricks I learned 10 years ago are still valid today. I'm
sure the librarian tricks you learned 10 years ago are still valid,
too. All these tricks mostly amount to models of operations and
semantics of functionality, and these things usually stay the same. If
you look at how Google have changed their underlying methodology of
page ranking over the years it is however tremendously impressive how
they haven't broken the knowledge of usage. Will the same be the case
for the Next Generation Catalog?

> With Google, who knows what they are doing

Their business goal is to get the best results for their users. I see
no reason to fear that nor expect them to degrade or fail me in this.
They make money if I find my stuff, which is a better incentive than
the library system. (Note: speaking here of incentives, not goals or
ideals)

> (and of course I'll teach my kids the same thing: namely, don't

There is a tremendous amount of non-transparent systems out there,
including most ILS software in use today (sloooowly changing). I'm a
sucker for open-source and open data and open models, but don't kid
yourself into thinking that closed systems somehow should be less
trusted by their very state. Trust should come from the organisations
that back them up and develop them instead, to their record over time
and their stated goals and ideals.

Regards,

Alex
--- http://shelter.nu/blog/ ----------------------------------------------
------------------ http://www.google.com/profiles/alexander.johannesen ---

---

From: Weinheimer Jim <[email-masked]>
Date: Wed, 28 Apr 2010 10:07:37 +0200

<snip>

This is an important point that separates certain world-views that I must insist is both understood and accepted: "better" and "reliable" are not synonyms at all, and I think the general public can understand the difference when it's explained to them. It is much like many people I know who absolutely hate to drive a car: they hate maintaining the car, fighting the traffic, obeying the traffic signs and rules and so on and so on. But, for many it's the only practical way to get anywhere. As a result, they *have no choice* except to learn how to drive a car, learn about putting air in the tires, learn the traffic rules, follow the signs, read maps...  

"Better" doesn't even enter into the equation. Certainly, people can imagine lots of things as being "better" than this task they absolutely despise, but all of that remains in the realm of fantasy. *This* is how you drive a car. Period. And there are very good reasons why these rules and methods for driving a car exist, because otherwise if everybody were left to do whatever they think is "better," and ignore one-way streets and speed limits, let their brakes go to pieces, the result would be chaos. If you want to get from here to there reliably in a car, you have no choice except to do it a certain way. And it's very complicated.

This was the situation in the library and its catalog before keyword access. People learned (or were supposed to learn) how the catalog functioned, learned the "rules of the road" and followed along as they were supposed to. It was just like the situation with a car: the tools made were designed to get the patron to the materials they needed reliably, although it was not easy at all. They had no other choice since there was no other access into the collection except to browse the shelves more or less helplessly (if it was open stacks), and many chose this option. 

When keyword was introduced, it suddenly allowed people to drive "off the roads" and this was experienced as a sense of freedom. Librarians (I believe), while realizing keyword was introducing a bit of chaos into the catalog, shared this feeling of freedom, seeing it as a very useful *addition to the normal means of access* since the reliable means of access still existed. Yet in reality, as time passed these "normal means of access" became less and less known among our public (and among many librarians as well) and as a consequence, less and less used, and the former "reliability" was practically forgotten among them. Yet, the catalogers still maintained and added to these increasingly empty streets, pretending that they were being used as much as ever. This is obviously a practice that cannot continue indefinitely.

So again coming around to the point, it seems as if your suggestion is that we abandon these roads that we have been creating and maintaining over the generations in favor of these "wonderful and new" tools that are being created today. I, and many of my colleagues, say that the new methods cannot replicate what the old methods can do--and still do thanks to the fortunate circumstance that they have continued to be maintained throughout the years--and would prefer to adapt the old roads to the needs of the new environment. In this way, they could be rediscovered by the public. Naturally, the new methods you mention can be adopted and added, but the task of "reliable access" needs to be taken up anew and put at the forefront. 

<snip>

I ran out of time and I am again. But let me take one of your points:

<snip>
... because it's a straw man. I can do the same to you; if you searched for Mark Twain you will miss out all of that which was written by Samuel Clemens or Josh or Thomas Jefferson Snodgrass.
</snip>

There's a lot more than that. To see what you are missing and how to use the catalog correctly, see (you have to click on "Authorized and Notes," then "Authority Record" and then "Labelled Display" (Don't blame me. I didn't design it! :-) ):
http://authorities.loc.gov/cgi-bin/Pwebrecon.cgi?DB=local&Search_Arg=Twain,%20Mark,%201835-1910&Search_Code=SHED_&CNT=50+records+per+page

So, we see many other forms that will lead a searcher to the authorized form of "Twain, Mark, 1835-1910," plus the absolutely critical note:
For works of this author written under other names, search also under
	Clemens, Samuel Langhorne, 1835-1910,
	Snodgrass, Quintus Curtius, 1835-1910
	Louis de Conte, 1835-1910

This is because there is a bibliographic concept of "separate bibliographic identities" and it manifests itself in AACR2 rule 22.2B with the LCRI at: http://sites.google.com/site/opencatalogingrules/22-2b--choice-among-different-names--pseudonyms where it says contemporary authors have separate bibliographic identities, and therefore will have separate authority records for each name, plus a contemporary author is anybody who lived into the 20th century. Twain died in 1910, so therefore, he falls under this rule, and there are some nice guidelines to follow in this RI.

There are also other forms being brought together in the VIAF:
http://viaf.org/viaf/50566653#Twain,%20Mark,%201835-1910 

Welcome to my world! This is what bibliographic control is all about and it is not simple. I personally disagree with 22.2B and the entire idea of separate bibliographic identities, but it doesn't matter what I think. I must follow the rules, and that means that anybody who uses the library tools must follow them as well. No single person can know all of it.

So, considering that example I gave in one of my messages of searching "Dostoyevsky" and the typical Google response "Did you mean: Dostoevsky" seems rather facile in comparison.

I think these constructions are far too important to be discarded and it has yet to be shown that the new and wonderful tools, as promising as they may be, can provide even a hint of this control.

---

From: Alexander Johannesen <[email-masked]>
Date: Wed, 28 Apr 2010 20:09:39 +1000

Hiola,

Weinheimer Jim <[email-masked]> wrote:
> This is an important point that separates certain world-views that I must insist is both understood and accepted: "better" and "reliable" are not synonyms at all

I fear you're missing the point. We, the experts, know they are not.
They, the users, don't care. You can tell them, but they still won't
care. Besides, sometimes being reliable is - indeed! - better, so you
can't make blanket statements like that.

...

> [...] it seems as if your suggestion is that we abandon these roads that
> we have been creating and maintaining over the generations in favor
> of these "wonderful and new" tools that are being created today.

From your reading of my writing, am I really suggesting this? I can
tell you straight away that, no, I'm not, I'm doing the opposite; I'm
asking you to think more clearly about how this knowledge fits into
the modern changing world. Old knowledge and methodologies and models
are all fine and well as long as they fit into the now and the future.

You yourself admit that these arcane arts are at times counter to
helping the users find information and certainly don't fit into modern
computer systems, so all I'm trying to do is to push you guys into
answering some perhaps difficult questions that should be - I would
hope - not too hard to figure out, though baby steps if necessary. If
they are indeed so hard to figure out, you've got *really* big
problems, because the real world is not going to wait around for you
to figure this out. You need to figure it out and integrate it *now*,
or even better, yesterday.

I hold the library legacy in high regards, and I would love to
preserve and still use quite a lot of it. It is not that I don't
understand the rigid structure and why it is there, I don't really
need a lecture on that (although I always appreciate your efforts in
clarifying the history and peculiarities within) as much as I need
answers to what is worth preserving in light of modern computer
systems (because I don't think there's any doubt catalogs with
millions of records can't be handled properly through manual labor).
But this also requires a deeper knowledge if said computer systems.

> I, and many of my colleagues, say that the new methods cannot
> replicate what the old methods can do

Ok, to this my answers are 1. doubtful (I was first gonna go with
"hogwash" :), and 2. irrelevant. More details ;

1. I doubt many of you have deep knowledge of what is possible these
days through various forms of AI, clustered facets, semantic models
and various degrees of formal logic over reasonably fuzzy structures
of knowledge management. Of course it's easy to counter this by saying
"well, show me, I haven't seen it." Well of course you haven't ; no
librarian specialist has joined up with a systems expert to create it
yet (or, at least, I haven't seen it :). I mentioned Topic Maps a few
posts back for a reason ; they mimic (as in, their models match) very
closely that of librarian specialists systems, but of course in a more
modern suit and identity management to boot. And I go on about these
things because of all the people that one would hope would understand
this match would be librarians in general and cataloger specifically.
I have, however, in this respect failed miserably at doing so.

2. The gist of my last post was basically that it doesn't matter if
your expert systems finds the results because there's too many
parameters that work both ways (you might find what Google misses, you
will miss what Google finds, and is closer to complimentary at this
point), but also that any system that requires a specialist is a
doomed system. It hence doesn't matter how good you are when you're
not going to be around to do it. The only way to make this matter is
to a) scrutinize it and make it relevant, and b) integrate it into
society to make no mistake about the value you add.

...

> There's a lot more than that.

Sure. And you don't have any better solutions here than any other.
Except. Well. I've talked about identity management before in Topic
Maps, where entities are bound by identifiers that are also resolvers.
it not only solves this problem, but solves all the hassle that FRBR
brings to the table. But I digress.

...

> Welcome to my world! This is what bibliographic control is all about and it is not simple.

Well, is that because of the tools and methods chosen, or because it's
an actual difficult area? The reason I'm asking here is for example
the dreaded way of having birth and death years (sometimes, or too
often optional, or wrong) as part of the name as an identifier for
entities which you have to match and merge in order to make sense out
of (and most of the time get wrong). In the past these identifiers
were the best one could come up with because there were no computers,
no decentralized means of resolving them, no authority control across
different bodies. However, now we do. See where this is going?

> I personally disagree with 22.2B and the entire idea of separate
> bibliographic identities, but it doesn't matter what I think. I must follow
> the rules, and that means that anybody who uses the library tools
> must follow them as well. No single person can know all of it.

With better tools and better methods at least these things shouldn't
get in the way of making both librarian and patron life easier. It
astounds me to no end how shortsighted it is not to pursue and change
these fundamentals when you've got the chance. But then, that really
is the key; tool-makers and system librarians nor library management
don't see how it can be done in such a way as being backwards
compatible with both mindset and existing systems. Sad, really, but
this is one of those things that are hard to do but must be done in
order to stay afloat.

> So, considering that example I gave in one of my messages of searching "Dostoyevsky" and the typical Google response "Did you mean: Dostoevsky" seems rather facile in comparison.

Well, not really; normal people require nothing more. Even specialists
don't always require more. And even they can get to alternative
spellings and search for those, it's not like the world can't deal
with not being rigid either.

> I think these constructions are far too important to be discarded and it has yet to be shown that the new and wonderful tools, as promising as they may be, can provide even a hint of this control.

Even a hint? Seriously?

regards,

Alex
--- http://shelter.nu/blog/ ----------------------------------------------
------------------ http://www.google.com/profiles/alexander.johannesen ---

---

From: Weinheimer Jim <[email-masked]>
Date: Wed, 28 Apr 2010 13:33:37 +0200

Alex,

I think we are beginning to see eye-to-eye again. I agree that library methods are mainly 19th-century, our processes are 1970s, and the *public face* of what we are building is divorced from the needs of our users. I don't think FRBR or RDA solves or even seriously discusses any of this, and why I think it's all going down the wrong road.

So, the power that is represented by our authority files should be unleashed into... what? Topic maps? OK, I'm all for it! How about putting it all into a wiki or lots of wikis and let the world play? For example, the Mark Twain record is really useful and could be made much better, but not in its present format, and it's locked away in a closed database anyway. Let these things out for general experimentation, see what works and what doesn't, and go from there. This is impossible to do while the data remains walled off however. If it were up to me, all of it would be available in a couple of hours, but...

<snip>
I doubt many of you have deep knowledge of what is possible these days through various forms of AI, clustered facets, semantic models and various degrees of formal logic over reasonably fuzzy structures of knowledge management. Of course it's easy to counter this by saying "well, show me, I haven't seen it." Well of course you haven't ; no librarian specialist has joined up with a systems expert to create it yet (or, at least, I haven't seen it :).
</snip>

I can only hope something like this happens soon. Still, while I am sure I don't know everything about AI, I don't think that matters to the point I am trying to make, which is: currently, it can't do the job that we, as librarians, feel needs to be done. I may be wrong, but I haven't seen it yet, and I haven't seen anything even close. If you want us to believe you, it must be proven to us, even in a prototype. If we bring up the example of how we have controlled Mark Twain's name and ask if that control (not the method but the control) can be replicated in some way with AI, don't try to convince us that retaining that control is not important. Show us what the machines can do, and it is then our job to decide if it's good enough or not. But I am not just going to believe it.

And yes, it is precisely librarians and I think catalogers who should decide because they know what to look for, and not leave it to an inexperienced and naïve public. This is like some of the spiritualists who would claim they could talk to the dead and make tables walk around the room. They could fool lots of people, including professors with vast experience, but they couldn't fool Harry Houdini. It's the specialists in describing and organizing information (catalogers) who know the pitfalls.

Still, the *only* reason we do have the control we currently have over our materials is because of our adherence to the standards. If we throw off the standards, we throw off the control. Therefore, it must be clearly thought out.

<snip>
> Welcome to my world! This is what bibliographic control is all about and it is not simple.

Well, is that because of the tools and methods chosen, or because it's an actual difficult area? The reason I'm asking here is for example the dreaded way of having birth and death years (sometimes, or too often optional, or wrong) as part of the name as an identifier for entities which you have to match and merge in order to make sense out of (and most of the time get wrong). In the past these identifiers were the best one could come up with because there were no computers, no decentralized means of resolving them, no authority control across different bodies. However, now we do. See where this is going?
</snip>

I agree with a lot of this. For example, I think the Wikipedia disambiguation page is far superior to our methods, but still, the actual task itself of "disambiguation" is difficult, although I agree it can and must be made much simpler. We must always keep the standards in focus though; if we were not involved in a cooperative task, we would not have to follow standards shared with others, and we would be free to do anything we want. But shared standards involve other responsibilities.

Should the standards change? Absolutely, and RDA purports to do that, but in my opinion, it's just more of the some using other vocabulary, and why I initiated the Cooperative Cataloging Rules.

---

From: "Lundgren,Jimmie Harrell" <[email-masked]>
Date: Wed, 28 Apr 2010 08:03:27 -0400

Hi Jim,
Thanks for your very clear points about retrieval of names based on name authority. A new subject line seemed warranted. 

While I continue to believe that browse searching backed by authority record functionality is essential, I also have noticed the frequency with which users default to keyword searching. Providing clear guidance to keyword searchers has become an important option, so looking into the best ways to perform that will be helpful. It seems to me that a few ad hoc means of utilizing the power of name authority records have begun to emerge. I see this in the alternate name and subject search term recommendations being suggested in response to keyword searching in some systems.

Given the naïve Google-expecting approach we often bring to searching, post-search navigation options have become essential. Suggesting headings for authors, topics, geographical terms, form/genre terms, chronological terms, formats, etc. as facets allow users to bring order that may be meaningful for their tasks to bear in limiting large sets. Users tell me they like it. Simple options to reorder the retrieval sets alphabetically or chronologically are also very useful, especially for known-items or partly known items. While new users may not notice these right away, those who get even a little experience behind them begin to take advantage.

As a side comment, in the context of libraries serving user needs there are a host of user features emerging that it might be helpful to discuss on this list. One improvement that has been in demand where I live is better display for cell phone users of the online catalog. Another is more powerful post-catalog management and sharing tools for information resources that go beyond simple citation systems for power users. I used to think of these as fluff in the catalog, but have come around to appreciating their value for users. 

Another useful navigation tool that some might mistakenly dismiss as "old hat" is the ability to click on headings in displayed records to retrieve other records with those headings. This option has been around for a while, but is not always done well and is clearly not obsolete for users. 

Thanks for your patience, persistence, and positive thinking. 
Jimmie

Jimmie Lundgren 
Associate Chair & Contributed Cataloging Unit Head 
Cataloging & Metadata Dept. 
Smathers Library 
PO Box 117004 
University of Florida 
Gainesville, FL 32611-7004 
352-273-2725 
352-392-7365 (fax) 
[email-masked]

---

From: Weinheimer Jim <[email-masked]>
Date: Wed, 28 Apr 2010 14:52:42 +0200

Lundgren,Jimmie Harrell wrote:

<snip>
Given the naïve Google-expecting approach we often bring to searching, post-search navigation options have become essential. 
</snip>

"Post-search navigation" I like it. That's actually what we need.

All your suggestions sound great. As an additional one that I have tried to play with but failed completely, is to show the subject subdivisions of an authorized subject term in a word cloud instead of the textual strings.

Also, Ian Fairclough asked if anybody has linked to materials outside the web. I've done a lot with that in the display of my records, e.g.
http://www.galileo.aur.it/cgi-bin/koha/opac-detail.pl?bib=25874

with links into OCLC for citations, sharing capabilities, Google scans, and a nice link into Bernhard Eversberg's LCSH browser (which seems to be not working fully at the moment, I just noticed).

Additionally, I have instituted an "Extend Search" which attempts to do what you mention, but you need a "tutorial" on it. (It's Two-Minutes or Less!)
http://issuu.com/j.weinheimer/docs/extendingthesearch?mode=embed&viewMode=presentation&layout=http%3A%2F%2Fskin.issuu.com%2Fv%2Fcolor%2Flayout.xml&backgroundColor=61A900&showFlipBtn=true

I have been experimenting with changing the functionality of implementing the Extend Search from a javascript into a plugin to make it work for any webpage at all, but I've had technical problsms creating it. Still, I think doing that would make a very powerful tool.

---

From: Bernhard Eversberg <[email-masked]>
Date: Wed, 28 Apr 2010 15:36:39 +0200

> with links into OCLC for citations, sharing capabilities, Google scans, and a nice link into Bernhard Eversberg's LCSH browser (which seems to be not working fully at the moment, I just noticed).
It works again. (There's been some revision of scripts for certain 
improvements.)

May I mention again our trial with the DNB authorities to include links
to WikiPedia articles? de.WikiPedia themselves are doing that for
personal names articles linking to DNB OPAC.

B.E.

---

From: Janet Hill <[email-masked]>
Date: Wed, 28 Apr 2010 09:25:39 -0600

Alex says about Google:

Their business goal is to get the best results for their users.

To which I respond, not really in disagreement:  

Google's business goal is to continue making more money and to remain viable
and competitive as an enterprise.  To the extent that "better" results for
their users conforms to this goal, then that's what Google wants to achieve.
(Although Google may be thinking in terms of "better enough to keep the user
coming back" rather than thinking of "better and better in the abstract)

They do, however (as is the case with any for-profit institution) have to
look out for what is desired by the people who pay their bills, and when
there is a conflict of some sort between an abstract "better for the user"
and "better for our advertisers" (for example), they may need to opt for
"better for our advertisers."   Decisions about things like display order,
display formatting, relevance ranking, etc. may be influenced by such
business concerns.
--- Which amounts to a targeted definition of what constitutes "better."  
 
Because Google is a profitable enterprise, with way more resources than most
libraries or library consortia can lay claim to, striving for what is
"better enough to keep the user coming back and still satisfy our
advertisers" can result in an impressively powerful and useful tool that
others would do well to learn from.

It would be naïve, though, to assume that Google either is, or can afford to
be perceiving of or seeking some abstract concept of "better" for its own
sake. 

The Library of Congress Working Group on the future of Bibliographic Control
had a representative from Google among its members.  It may be worth
pondering that he noted that the continued work of the library community in
providing subject analysis and metadata was a valuable resource for Google,
which made Google's searches yield "better" results for the user than would
be the case without the library-supplied data .... and which meant that
Google didn't have to try to make plans to supply that data itself.

Janet Swan Hill, Professor
Associate Director for Technical Services
University of Colorado Libraries, CB184
Boulder, CO 80309
[email-masked]
     *****
"The thing about democracy, beloveds is that it is not neat, orderly, or
quiet.  It requires a certain relish for confusion."  Molly Ivins
Their business goal is to get the best results for their users.

---

From: Jonathan Rochkind <[email-masked]>
Date: Wed, 28 Apr 2010 12:31:59 -0400

I think there are ways to provide authority-backed guidance to users 
other than the traditional "browse search" which users don't like.

What if when the user does a keyword search, they get, along with their 
search results, a list of authorized (eg) names that also matched their 
query, that they can choose to 'drill down' into if they want?  The 
authorized name matches could be matches on any part of the name (not 
just the beginning of the name as in 'browse search'), and could include 
authorized names which matched on "lead in" terms too.

This is just one idea. But I have the strong suspicion that we can 
provide an interface which does the functions 'browse search' are 
intended to supply, but does so in a way users like BETTER than the 
traditional 'browse search'.  I am unaware of what current software does 
this, but there might be some examples. It'll take some development and 
some user testing to get there. But that's our job, right?

Jonathan

---

From: Laval Hunsucker <[email-masked]>
Date: Wed, 28 Apr 2010 09:58:08 -0700

Bernhard,

Interesting ;  however -- since some ( i.e. probably 
quite a few ) of us are *not* Germanless -- could you 
give us a nice handy relevant link or something ?
Useless is big word :-).

 - Laval Hunsucker
   Breukelen, Nederland ( a long-time fan, incidentally, 
  and frequent user, of the German Wikipedia )

----- Original Message ----
From: Bernhard Eversberg <[email-masked]>
To: [email-masked]
Sent: Tue, April 27, 2010 12:46:01 PM
Subject: Re: [NGC4LIB] After MARC...MODS?

B.Eversberg

---

From: Eric Lease Morgan <[email-masked]>
Date: Wed, 28 Apr 2010 13:46:49 -0400

On Apr 28, 2010, at 12:31 PM, Jonathan Rochkind wrote:

> query, that they can choose to 'drill down' into if they want?

This is what my prototype Name Finder and Subject Finder applications do, as described in the most recent issue of Code4Lib Journal, and demonstrated rudimentarily in the Name Finder and Term Finder applications. I believe Damian Katz has explored putting these sorts of features into VUFind.

[1] Journal - http://journal.code4lib.org/articles/2481
[2] Name Finder - http://zoia.library.nd.edu/sandbox/name-finder/
[3] Term Finder - http://zoia.library.nd.edu/sandbox/term-finder/

-- 
Eric Morgan

---

From: Demian Katz <[email-masked]>
Date: Wed, 28 Apr 2010 13:55:47 -0400

> This is what my prototype Name Finder and Subject Finder applications
> do, as described in the most recent issue of Code4Lib Journal, and
> demonstrated rudimentarily in the Name Finder and Term Finder
> applications. I believe Damian Katz has explored putting these sorts of
> features into VUFind.

Yes, you can play with some crude VuFind demos here:

http://vufind.org/demo_trunk/

Doing an author search will give you recommendations from Identities, and doing a subject search will give you recommendations from Terminologies.  I don't claim that the interface is very pretty, and the terminologies results are sometimes rather weird due to the lack of relevance ranking -- but hopefully this serves as a test of concept, and feedback is welcome.

- Demian

---

From: Jonathan Rochkind <[email-masked]>
Date: Wed, 28 Apr 2010 15:01:38 -0400

Interesting -- I was thinking recommendations from your actual local 
corpus, but from Identities/Terminologies might be even better -- but is 
there any way for the system to pre-warn you whether that particular 
Author or Term is actually found in the local corpus, to prevent you 
from clicking on it and getting 0 hits?

---

From: Demian Katz <[email-masked]>
Date: Wed, 28 Apr 2010 15:05:29 -0400

> from clicking on it and getting 0 hits?

I'm not aware of a good way to avoid the zero hits situation -- but a "0 hits" page doesn't need to be the end of the search -- if you incorporate good recommendations (i.e. links to WorldCat or various electronic resources) into your empty results screen, the user still may be able to benefit from the recommendations even if they don't find materials in the local catalog.

- Demian

---

From: Jonathan Rochkind <[email-masked]>
Date: Wed, 28 Apr 2010 15:15:45 -0400

I guess the only way, if you're starting from an external service, would 
be having your app do the search on your local corpus, for each 
suggestion,  before displaying the suggestions, so it can provide 
'yes/no' or a hit count next to each one.

I do see how in some cases the page can serve the user even if there's a 
0 local hit count. Depends on what the user wants. In some cases they're 
looking for local materials, and I think are likely to be frustrated if 
they don't know if there are any until they click (the traditional 
'browse list', which I am NOT advocating, generally puts a local hit 
count next to each heading).

Jonathan

---

From: S Perkins <[email-masked]>
Date: Wed, 28 Apr 2010 16:17:05 -0400

Eric:

Can you modify the name finder to use one or more middle initials?  I
found my name displayed as last name, fist name, middle initial when I
did a search as first name, last name but it could not find it if I
input first name middle initial, last name.

Also, can the order of display be alphabetized using all name parts?

Regards

Steven C Perkins

---

From: Eric Lease Morgan <[email-masked]>
Date: Wed, 28 Apr 2010 17:24:21 -0400

> Also, can the order of display be alphabetized using all name parts?

Yes, these things can be done, but my implementation was only a prototype -- an example of what could be done. As prototypes, the applications are not expected to be full-featured.

-- 
ELM

---

From: Alexander Johannesen <[email-masked]>
Date: Thu, 29 Apr 2010 13:44:15 +1000

Hiya,

Not much disagreement from me here, but I did want to address one thing ;

> --- Which amounts to a targeted definition of what constitutes "better."

I need to remind people that this *also* applies to libraries. You are
not exempt from the scrutiny of society (through politics) who does -
indeed - pay your bills, pay for the buildings, and depreciate your
values. "Better for our patrons" will always be your pogrom, and there
is no real difference between this and the Google business model of
"better for our users who will return again and again to put
advertisers money in our pockets" except in terms of _time_ (time to
market, time for society to decide enough is enough, time to make a
political decision, time you've got left until retirement, time for
more funding to become available, time for people to return to good
service or products, etc.)

> Google didn't have to try to make plans to supply that data itself.

I say; let Google buy the library world. *Then* we'll get some serious
action, both in terms of "better" and in terms of "reliable". They'll
get better, and you'll get funding and to prove your worth forever.
Win-win. :)

Regards,

Alex
--- http://shelter.nu/blog/ ----------------------------------------------
------------------ http://www.google.com/profiles/alexander.johannesen ---

---

From: Bernhard Eversberg <[email-masked]>
Date: Thu, 29 Apr 2010 08:38:15 +0200

> give us a nice handy relevant link or something ?
For what it's worth, here's the doorway into it:

http://www.biblio.tu-bs.de/db/a30/gnd.htm

The older companion to this is the LCSH browser:

http://www.biblio.tu-bs.de/db/lcsh

(But "browsing"? Brrr...)

B.Eversberg

---

From: Bernhard Eversberg <[email-masked]>
Date: Thu, 29 Apr 2010 09:50:56 +0200

> get better, and you'll get funding and to prove your worth forever.
A joke, of course. They know much better than that, obtaining the
collective results of a century of library work for free. Not just
the catalog data from OCLC (without which they couldn't be as good as
they are with the known-item search), but it is obvious that to get
carefully built and maintained collections for scanning is worth
immensely more than using just any stuff found in the vaults of
antiquarian bookstores or wherever.
They are welcome to do all this as long as the searching is free
and much of the stuff itself too, as far as copyright allows.
Theoretically, the whole operation might result in more transparent
tools and be more sustainable and trustworthy had it been done by
public entities, but they would have had to sacrifice a new aircraft
carrier or something. An unrealistic idea for any number of reasons,
even less so than your's.

B.Eversberg

---

From: Weinheimer Jim <[email-masked]>
Date: Thu, 29 Apr 2010 10:48:32 +0200

Bernhard Eversberg wrote:
<snop>
They [i.e. Google - JW] know much better than that, obtaining the collective results of a century of library work for free. Not just the catalog data from OCLC (without which they couldn't be as good as they are with the known-item search), but it is obvious that to get carefully built and maintained collections for scanning is worth immensely more than using just any stuff found in the vaults of antiquarian bookstores or wherever.
</snip>

I really want to believe this, but I'm not sure if you could find general agreement in the current environment. I have been looking very carefully at the Google Book Search interface because I think that once the Google-Publisher agreement is eventually approved, the Google Book interface will become the starting point for research. Why wouldn't it be? I know that back when I was a student, I would have absolutely loved it!

But when you examine the Google Book interface closely, it's quite frightening for a librarian. For example, the "cataloging information" is mashed-up and placed on the very bottom of the "About this book" page, precisely the spot where Google knows no one will ever go. But above the bibliographic metadata are just the sorts of tools *right now* that librarians are talking about developing, e.g. links into word clouds, reviews, mapping into Google Maps, and so on. They already exist, and done very well, I might add.

In any case, it is rather difficult to know exactly what is being searched in the Google Book Search text box (does it search the bibliographic metadata?) and more importantly, how the results are arranged for viewing. And I don't know how many people use the Advanced search, which of course, does not use authority files, so you get different results for "Dostoyevsky / Dostoevsky / Dostoevskii" and on and on.

What will be the use of a local catalog work in the kind of environment where people will be able to go to Google Books and get millions of things with a touch of a button? Why will we still expect these people to use our tools when they will find plenty to keep them busy in Google Books?

I don't know. I think we can offer many things Google will not be able to, but we have to reconsider what it is we do very deeply. We may encounter some very unpleasant truths. It won't be easy to grapple with much of this however, and that's why I appreciate people like Alex who can help us figure out some of these new directions.

---

From: Bernhard Eversberg <[email-masked]>
Date: Thu, 29 Apr 2010 11:03:07 +0200

Weinheimer Jim schrieb:
> 
> But when you examine the Google Book interface closely, it's quite frightening for a librarian. For example, the "cataloging information" is mashed-up and placed on the very bottom of the "About this book" page, precisely the spot where Google knows no one will ever go.

Most peculiarly hidden is the subject search. Once you know it, you can 
enter

subject:"Aboriginal australians -- history"

(or use the LCSH browser to do that for you)

and get relevant stuff. That search is very rigid. It doesn' work
without the quotes, nor with any letter left out or misspelled,
and there's no truncation. You have to enter the LCSH term exactly
in its correct spelling (like in any old OPAC) or you get a zero hit
message with some advice, but no list of headings that would match the
keywords or anything, no fuzzy search, word-stemming, spellchecking
or whatever - nothing.

So, they obviously do use the subject headings, but in a less than
half-hearted way. One can only wonder why. So please, try it out and
judge for yourself if LCSH is useful for GBS search or not. If not,
they might as well drop it with nobody the wiser.

B.E.

---

From: Alexander Johannesen <[email-masked]>
Date: Thu, 29 Apr 2010 19:17:35 +1000

> they might as well drop it with nobody the wiser.

Yeah, the subject heading search is a bit half-arsed, but who knows
how they'll deal with it in the future. They might be working on some
better (there's that word again!) version of it and release it when it
blows our minds (hence the current poor placement). Also, playing
around with the advanced interface yielded some good results ;

http://books.google.com.au/advanced_book_search

 I even found some books on deep beach ecology that neither WorldCat,
local library *nor* normal Google searches found. I'm impressed. Can't
wait for eBooks and more books entered into it so I can hook it
straight into my eReader, however I fear I'll loose a lot of money
that way ...

Alex
--- http://shelter.nu/blog/ ----------------------------------------------
------------------ http://www.google.com/profiles/alexander.johannesen ---

---

From: Janet Hill <[email-masked]>
Date: Thu, 29 Apr 2010 08:52:14 -0600

Alex says: I say; let Google buy the library world. *Then* we'll get some
serious
action, both in terms of "better" and in terms of "reliable". They'll
get better, and you'll get funding and to prove your worth forever.
Win-win. :)

And I respond (but chuckling ruefully):  they'll have to fight it out with
OCLC for world domination, and I'm not sure that any of us would be thrilled
with the result of the near-monopoly that might result, whichever came out
on top.  (any more than most of us are thrilled as more and more ILS's and
related operations go down the tubes, leaving the companies with a stronger
grip on saying "this can be done; this can't (for which, read "won't) etc.)

Janet Swan Hill, Professor
Associate Director for Technical Services
University of Colorado Libraries, CB184
Boulder, CO 80309
[email-masked]
     *****
Tradition is the handing-on of Fire, and not the worship of Ashes.
- Gustav Mahler

---

From: Laval Hunsucker <[email-masked]>
Date: Thu, 29 Apr 2010 12:44:48 -0700

Thanks very much.

 - Laval Hunsucker
   Breukelen, Nederland

----- Original Message ----
From: Bernhard Eversberg <[email-masked]>
To: [email-masked]
Sent: Thu, April 29, 2010 8:38:15 AM
Subject: Re: [NGC4LIB] After MARC...MODS?

Laval Hunsucker wrote:
> 
> Interesting ;  however -- since some ( i.e. probably quite a few ) of us are *not* Germanless -- could you give us a nice handy relevant link or something ?
> Useless is big word :-).
> 

B.Eversberg