Subject: Re: [NGC4LIB] New uses of subjects, authorities, etc.

From: Emily Lynema <[email-masked]>
Date: Thu, 29 Apr 2010 09:00:18 -0400

We've also done a bit of experimentation with subject authorities in the Search TRLN catalog. In this case, rather than pulling suggested subject headings from an outside service (like Terminologies), we are instead suggesting to users the most popular headings in the corpus of results returned from the search. This prevents the 0 hits scenario. But the real reason for pursuing this path was that initial comparative testing showed that users' keyword searches were *much* more likely to hit on text in a full record (particularly if it's enhanced with supplemental content like table of contents) than to hit on the cataloged 'see' or 'see also' terms in an authority record. Users type in all kinds of crazy unanticipated words.

This is a work in progress, but you can see the idea here:
http://search.trln.org/search?N=0&Nty=1&Ntk=Keyword&Ntt=revolutionary+war

This is easy to do in a faceted search system. I feel like I have seen other libraries also beginning to experiment in this area.

-emily

------------------------------

Date:    Wed, 28 Apr 2010 15:01:38 -0400
From:    Jonathan Rochkind <[email-masked]>
Subject: Re: New uses of subjects, authorities, etc.

Interesting -- I was thinking recommendations from your actual local 
corpus, but from Identities/Terminologies might be even better -- but is 
there any way for the system to pre-warn you whether that particular 
Author or Term is actually found in the local corpus, to prevent you 
from clicking on it and getting 0 hits?

Demian Katz wrote:

>> >> This is what my prototype Name Finder and Subject Finder applications
>> >> do, as described in the most recent issue of Code4Lib Journal, and
>> >> demonstrated rudimentarily in the Name Finder and Term Finder
>> >> applications. I believe Damian Katz has explored putting these sorts of
>> >> features into VUFind.
>> >>     
>>     
> >
> > Yes, you can play with some crude VuFind demos here:
> >
> > http://vufind.org/demo_trunk/
> >
> > Doing an author search will give you recommendations from Identities, and doing a subject search will give you recommendations from Terminologies.  I don't claim that the interface is very pretty, and the terminologies results are sometimes rather weird due to the lack of relevance ranking -- but hopefully this serves as a test of concept, and feedback is welcome.
> >
> > - Demian
> >
> >   
>   

-- 
Emily Lynema
Associate Department Head
Information Technology, NCSU Libraries
919-513-8031
[email-masked]

---

From: Jonathan Rochkind <[email-masked]>
Date: Thu, 29 Apr 2010 10:18:12 -0400

Emily Lynema wrote:
> But the real reason for pursuing this path was that initial comparative testing showed that users' keyword searches were *much* more likely to hit on text in a full record (particularly if it's enhanced with supplemental content like table of contents) than to hit on the cataloged 'see' or 'see also' terms in an authority record. 

If you could "publish" these results, including just as a blog post or 
whatever, it would be very helpful to me in determining my functional 
priorities at my institution.  There is some thought of importance of 
getting our Blacklight installation to index "see also" terms from 
authorities -- any information on how useful those have been found to be 
in an academic library environment is useful to me in gauging the true 
priority of this feature here.

Jonathan