Subject: [NGC4LIB] Fwd: Hungarian National Library published its entire OPAC and Digital Library as Linked Data

From: Ross Singer <[email-masked]>
Date: Tue, 13 Apr 2010 08:05:47 -0400

Interesting now that two European national libraries have done this so far.

-Ross.

---------- Forwarded message ----------
From: HORVATH Adam <[email-masked]>
Date: 2010/4/7
Subject: Hungarian National Library published its entire OPAC and
Digital Library as Linked Data
To: [email-masked]

The national library of Hungary - officially named as National
Széchényi Library (NSZL) - proudly announces that its entire OPAC and
Digital Library and the corresponding authority data have been
published as Linked Data. The used vocabularies are:

oRDFDC for bibliographic data,
oFOAF for name authority entries, and
oSKOS for subject terms and geographical names.

NSZL uses CoolURIs. Every resource has both RDF and HTML
representation.

Our RDFDC, FAOF and SKOS statements are linked together. Our name
authority is matched with the DBPedia name files and URI aliases are
handled as owl:sameAs statements.

NSZL also supports the HTML link auto-discovery.

Examples are:

OPAC records (RDFDC):
http://nektar.oszk.hu/resource/manifestation/2645471

Digital Library record (RDFDC):
http://oszkdk.oszk.hu/resource/DRJ/404

Name authority (FOAF):
http://nektar.oszk.hu/resource/auth/33589

Subject term (SKOS):
http://nektar.oszk.hu/resource/auth/magyar_irodalom

Any feedback is welcome.

NSZL followed and adapted the Swedish LIBRIS´s practices. We are
grateful for Martin Malmsten for his help. Skosification was done
under the TELplus project with the precious feedbacks of Antoine
Isaac.

For technical datailes please contact:
Kornel Horvath ([email-masked]) or
Zsolt Zachar ([email-masked])

Adam Horvath
================================================
Adam HORVATH
Director of Informatics
------------------------------------------------
NATIONAL SZECHENYI LIBRARY
Information Technology Department
Budapest, Budavari Palota F epulet, H-1827
 Tel.: +36-1-224-3737  Fax: +36-1-224-3705
-Email: [email-masked]    WWW: http://www.oszk.hu
================================================

---

From: Weinheimer Jim <[email-masked]>
Date: Tue, 13 Apr 2010 15:23:10 +0200

Very interesting that they are using dbpedia links for their authority. I can't see that they are in VIAF. It would be really interesting to find out more about this initiative. Are there others on the list who can provide some more information?

Thanks for sharing this!

James Weinheimer  [email-masked]
Director of Library and Information Services
The American University of Rome
via Pietro Roselli, 4
00153 Rome, Italy
voice- 011 39 06 58330919 ext. 258
fax-011 39 06 58330992

-----Original Message-----
From: Next generation catalogs for libraries [mailto:[email-masked]] On Behalf Of Ross Singer
Sent: Tuesday, April 13, 2010 2:06 PM
To: [email-masked]
Subject: [NGC4LIB] Fwd: Hungarian National Library published its entire OPAC and Digital Library as Linked Data

-Ross.

---------- Forwarded message ----------
From: HORVATH Adam <[email-masked]>
Date: 2010/4/7
Subject: Hungarian National Library published its entire OPAC and

Examples are:

OPAC records (RDFDC):

Name authority (FOAF):

Subject term (SKOS):

Any feedback is welcome.

Adam Horvath

---

From: Ross Singer <[email-masked]>
Date: Tue, 13 Apr 2010 09:41:34 -0400

> Very interesting that they are using dbpedia links for their authority. I can't see that they are in VIAF. It would be really interesting to find out more about this initiative. Are there others on…

I'm not sure they are using DBpedia as their authority as much as they
are maintaining their own authorities and matching them to DBpedia
(which is somewhat different).  VIAF does this, as well, although
their links are extraordinarily messy:

http://viaf.org/viaf/46946176.rdf

For example, they link to:
http://dbpedia.org/page/Wikipedia:WikiProject_Bob_Dylan

which is a *page* about the representation of Bob Dylan (not the
representation of Bob Dylan himself) -- they also model all of their
identities as skos:Concepts, which is problematic in other ways.

For the work I've been doing on LinkedLCCN, I've had to remodel the
VIAF data to be more accurate:

http://lccn.lcsubjects.org/people/n50030190#i
http://lccn.lcsubjects.org/people/n50030190.rdf

So, even if NSZL's authorities were represented in VIAF, it's
problematic from a linked data perspective.

-Ross.

---

From: Ed Jones <[email-masked]>
Date: Tue, 13 Apr 2010 07:35:04 -0700

Information on various reported SKOS implementations are at http://www.w3.org/2006/07/SWD/SKOS/reference/20090315/implementation.html.  Information reported on the two National Szechenyi Library implementations are at http://www.w3.org/2006/07/SWD/track/issues/207 (vocabulary and software) and http://www.w3.org/2006/07/SWD/track/issues/208 (SKOS converter). 

-----Original Message-----
From: Next generation catalogs for libraries [mailto:[email-masked]] On Behalf Of Weinheimer Jim
Sent: Tuesday, April 13, 2010 6:23 AM
To: [email-masked]
Subject: Re: [NGC4LIB] Fwd: Hungarian National Library published its entire OPAC and Digital Library as Linked Data

Thanks for sharing this!

-----Original Message-----
From: Next generation catalogs for libraries [mailto:[email-masked]] On Behalf Of Ross Singer
Sent: Tuesday, April 13, 2010 2:06 PM
To: [email-masked]
Subject: [NGC4LIB] Fwd: Hungarian National Library published its entire OPAC and Digital Library as Linked Data

-Ross.

---------- Forwarded message ----------
From: HORVATH Adam <[email-masked]>
Date: 2010/4/7
Subject: Hungarian National Library published its entire OPAC and

Examples are:

OPAC records (RDFDC):

Name authority (FOAF):

Subject term (SKOS):

Any feedback is welcome.

Adam Horvath

---

From: "Diane I. Hillmann" <[email-masked]>
Date: Tue, 13 Apr 2010 11:02:12 -0400

I think the lesson for us in this is that those who are serious about 
linked data will use what is openly available.  They will not use 
library data that is behind walls, in web-unfriendly formats, or with 
questionable re-use policies.  If we want to be recognized in that 
world, with our data being used where it can be most effective, we need 
to stop dithering and make it happen.

Diane

---

From: Karen Coyle <[email-masked]>
Date: Tue, 13 Apr 2010 08:15:57 -0700

Quoting Ross Singer <[email-masked]>:

> representation of Bob Dylan himself)

I must say that I don't see a significant difference between the use  
of a wikipedia page or the use of an LC name authority record to  
represent Dylan -- since Dylan himself cannot be reduced to linked  
data. I think we are all more comfortable with the LCNA because we  
understand its function as an identifier, but it's just a record in  
the same sense that wikipedia is just a page.

> -- they also model all of their

Yes, SKOS gets used because it's Simple and it is There. We need to  
develop some other "S"s - simple formats for other kinds of data.

Speaking of which, I took a look at FOAF and RDA/FRBR person entities,  
and the only overlap is that they both have names. I'll try to write  
it up, but it looks to me like we might be able to use FOAF for  
"social data" about our identified persons (mainly contemporary ones),  
and thus extend RDA, and RDA can help ground FOAF with more facts  
(date and place of birth, etc.). There's more... will work on it.

kc

-- 
Karen Coyle
[email-masked] http://kcoyle.net
ph: 1-510-540-7596
m: 1-510-435-8234
skype: kcoylenet

---

From: Ross Singer <[email-masked]>
Date: Tue, 13 Apr 2010 11:25:31 -0400

On Tue, Apr 13, 2010 at 11:02 AM, Diane I. Hillmann <[email-masked]> wrote:
> I think the lesson for us in this is that those who are serious about linked
> data will use what is openly available.  They will not use library data that
> is behind walls, in web-unfriendly formats, or with questionable re-use
> policies.  If we want to be recognized in that world, with our data being
> used where it can be most effective, we need to stop dithering and make it
> happen.

+1

This is a truly quotable quote here and I'm not sure how to emphasize
it enough to the powers that don't seem to understand.

"Priceless" is a bit of a double-entendre, no?  Nobody (outside of the
library domain) is going to pay to "license" our data, especially if
there are perfectly workable (and more easily consumable)
representations available.  It's proven that our data, when put under
a microscope, begins to show many more blemishes than we like to
admit.  If we make it unpalatable to reuse and, dare I say, improve,
why would anybody bother?

-Ross.

>> Very interesting that they are using dbpedia links for their authority. I
>> can't see that they are in VIAF. It would be really interesting to find out
>> more about this initiative. Are there others on the list who can provide
>> some more information?
>>
>>
>>
>

---

From: Ross Singer <[email-masked]>
Date: Tue, 13 Apr 2010 11:57:39 -0400

On Tue, Apr 13, 2010 at 11:15 AM, Karen Coyle <[email-masked]> wrote:

> I must say that I don't see a significant difference between the use of a
> wikipedia page or the use of an LC name authority record to represent Dylan
> -- since Dylan himself cannot be reduced to linked data. I think we are all
> more comfortable with the LCNA because we understand its function as an
> identifier, but it's just a record in the same sense that wikipedia is just
> a page.

Yes, well, it's not like the linked data community hasn't thought of
this or addressed this in some way (and I totally admit it's the
Kool-Aid of linked data -- you either take it or you don't) - it's the
distinction between information resources and non-information
resources (brief into here:
http://www.rdfabout.com/intro/?section=8).

Bob Dylan as an "entity" (that is, an identifier that represents Bob
Dylan) *can* be expressed, whether we choose to use the form
http://dbpedia.org/resource/Bob_Dylan or info:lccn/n50030190.  These
represent the identity "Bob Dylan" and we can make assertions about
him.  The wikipedia page (and, by extension, the DBpedia 'page' URI
that VIAF points to) are documents about Bob Dylan -- so if you refer
to those URIs, you're talking about the page about Bob Dylan, not the
singer-songwriter himself.  This level of indirection is important -
it helps differentiate documents from data.

I'm not saying that the Wikipedia URI isn't totally useful (pretty
easy hop to dbpedia, after all), it's just the way that OCLC is using
it is wrong, in this case.
> Yes, SKOS gets used because it's Simple and it is There. We need to develop
> some other "S"s - simple formats for other kinds of data.
>
Actually, SKOS as "simple" isn't the problem.  The problem is if you
think there's a difference between "concepts of things" and the
"things themselves".  Where this really comes into light is when you
think about the assertions you would make a skos:Concept, do these
make sense when you apply them to the thing in question?  For example,
when did Bob Dylan or the Grand Canyon become a "subject"?  VIAF says
"2009-03-03T12:03:19+00:00" for Bob and id.loc.gov says "1986-02-11"
for the Grand Canyon.

Obviously the Grand Canyon wasn't "created" on Feb. 11th 1986 (and,
I'm sure, neither was the subject heading, but that's another issue),
but there's value in keeping the human construct of "concept"
separated from the object in question.  The creation date, for
example, could tell a lot about when knowledge of a particular thing
came into being.  dc:modified tells a lot about when perceptions were
changed :)

> Speaking of which, I took a look at FOAF and RDA/FRBR person entities, and
> the only overlap is that they both have names. I'll try to write it up, but
> it looks to me like we might be able to use FOAF for "social data" about our
> identified persons (mainly contemporary ones), and thus extend RDA, and RDA
> can help ground FOAF with more facts (date and place of birth, etc.).
> There's more... will work on it.

I definitely agree this can cover many schemas and different domains
will have different contributions on the matter.  An environmental
scan like you're talking about here would be invaluable (don't equate
this with "priceless" :)) to find the ways to integrate ourselves
"with" the web rather than "around" it (which is what the RDA vocabs
tend to lean towards now).

-Ross.

---

From: Karen Coyle <[email-masked]>
Date: Tue, 13 Apr 2010 11:39:18 -0700

> came into being.  dc:modified tells a lot about when perceptions were

Well, I guess I just don't think we have a way to work with "things  
themselves" in something like SKOS, because the "K" means "knowledge"  
and the "S" means system, that is, somebody's system -- somebody's  
ideas about something.

It isn't immediately clear to me what VIAF means with their use of  
dcterms:created. Is DC being used in an administrative way?  
dcterms:created is defined as the "date of creation of the resource."   
That date could refer to when the "knowledge" was entered in that  
particular "system," and it looks like VIAF is using it that way. (But  
I can't find a definition of their schema other than saying they are  
using SKOS. Anyone?)

My presumption is that the If you want a beginning date for the thing  
itself, then you can add a DOB for Dylan, but you may have a hard time  
being precise about the Grand Canyon (although geologists may have a  
term for this). In either case, SKOS is too Simple to have data  
elements for this, but one could pull them in from other name spaces.

To me, SKOS is used for a thesaurus or other list of terms, and is by  
necessity artificial and contextual. The Grand Canyon will be treated  
differently in a geology thesaurus than in a controlled list of  
Western tourist destination. It's not like one of those is the real GC  
and the other isn't, even though they may be described differently.  
However, exactly what can be considered 'knowledge' vs. 'not  
knowledge' for entry into SKOS is beyond me.

I happen to think that "subjectness" is one of the more difficult  
things we will have to work with in creating a new data format, in  
particular a linked-data one. I have a hard time with FRBR's view of  
subjects as entities -- to me, subjectness is a relationship between  
things, not a characteristic of the things themselves. I'd be willing  
to say that any "resource" (in the RDF sense, that is anything you can  
identify) can be a subject of another resource. Having done that, I  
suppose you could do as FRBR/RDA has done and limit it to the entities  
it has defined, but as a relationship not an "is-ness".

kc

---

From: Jonathan Rochkind <[email-masked]>
Date: Tue, 13 Apr 2010 14:59:14 -0400

> and the "S" means system, that is, somebody's system -- somebody's  
We can assert knowledge about a thing itself, can we not? 

Saying that the painting the Mona Lisa was created in the 16th century 
is a _different_ assertion then saying that the wikipedia page 
http://en.wikipedia.org/wiki/Mona_Lisa was created on 12 August 2002.

It's pretty important to know if you're saying the painting was created 
on 12 August 2002, or the wikipedia page was, right?

The linked data/semantic web community has worked out conventions for 
being clear about which of these things (the "thing itself" or a web 
page about it) you are referring to in your assertions.

dbpedia has implemented those conventions, providing a way to be clear 
about which of those things you are making assertions about.  Which can 
be easily done in SKOS by simply choosing the proper URI to make 
assertions about, there is nothing about SKOS that prevents you from 
doing this, people do it all the time with SKOS, I think.

VIAF ignores those conventions, and, based on dbpedia data, makes 
assertions about wikipedia pages when it means to be making assertions 
about the "things themselves".  By using the dbpedia RDF improperly.

Seems pretty clear cut to me.

Jonathan

---

From: Ross Singer <[email-masked]>
Date: Tue, 13 Apr 2010 15:05:39 -0400

On Tue, Apr 13, 2010 at 2:39 PM, Karen Coyle <[email-masked]> wrote:

> necessity artificial and contextual.

Right, but that inherently means that it's something different.  The
hole in the ground in Arizona isn't artificial or contextual.  How we
think about it is.

Another sticky example would be broader terms/narrower terms.  A
concept may or may not have these; people and things don't have these.

> I happen to think that "subjectness" is one of the more difficult things we
> will have to work with in creating a new data format, in particular a
> linked-data one. I have a hard time with FRBR's view of subjects as entities
> -- to me, subjectness is a relationship between things, not a characteristic
> of the things themselves. I'd be willing to say that any "resource" (in the
> RDF sense, that is anything you can identify) can be a subject of another
> resource. Having done that, I suppose you could do as FRBR/RDA has done and
> limit it to the entities it has defined, but as a relationship not an
> "is-ness".
>
Well, I think Simon Spero subscribes to this list, so it's only a
matter of time before the "reading a book about unicorns while wearing
a unicorn hat" [1]  analogy pops up, but there is definitely a school
of thought (and apparently that school of thought was involved in the
making of SKOS) that feel like KOS exist in different plane than
reality [2].

The linked data community is currently quite divided about whether or
not there's a difference between "is-ness" and "about-ness" (the
NYTimes publishing of their personal names as SKOS certainly
kickstarted some of this)-- it's certainly much simpler on the surface
to say that "William Shakespeare as subject" is the exact same thing
as "William Shakespeare as human being", but there are longer term
effects of this that might need to be considered.

-Ross.
1.  http://www.ibiblio.org/fred2.0/wordpress/?p=30
2.  http://markmail.org/message/gcfbk5ilucu2c3bm

---

From: JONATHAN LEBRETON <[email-masked]>
Date: Tue, 13 Apr 2010 16:17:47 -0400

With apologies for duplicative postings. 

Head of Digital Library Initiatives
Temple University Libraries

The Temple University Libraries seek a Head of Digital Library Initiatives, an opportunity to lead a new service department in a library in the midst of dynamic growth, located in Philadelphia on the main campus of a vibrant, urban research university that is among the most diverse in the nation.  For more information about Temple and Philadelphia, visit www.temple.edu/about/

Description:
The Head of Digital Library Initiatives will aggressively expand the digital library program at Temple, providing vision and leadership in the creation and delivery of digital content. The incumbent will work closely and collaboratively with senior administrators, special collections, technical services, computing staff, and others to ensure fast-paced development of digital library initiatives which respond to the needs of Temple's community and align with collections and preservation priorities.  These include digitization of special collections and other library materials in text, image, and video formats, the development of digital repository systems to preserve and make accessible the intellectual output of Temple University, and the implementation of discovery tools related to these initiatives. In particular, the individual will
.	hire additional information technologist staff;
.	supervise full-time staff, as well as student assistants;
.	plan, prioritize, and coordinate or manage digitization production;
.	investigate and establish appropriate standards (technical, metadata, etc.) and quality control procedures; 
.	coordinate the library's web services;
.	maintain awareness and develop in-depth knowledge of new technology, relevant national standards and best practices, assessing and integrating these into library practices for best results as appropriate.

Compensation:
Competitive salary and benefits package, including a relocation allowance. Compensation will be commensurate with qualifications and experience.

Required:
Master's degree in Library Science, Information Science, Computer Science/Systems Management, Public History, or other allied discipline.   At least four years progressively responsible experience with the concepts and software/hardware applications used in organizing and presenting digital information. Demonstrated ability to plan, coordinate, and implement effective programs, complex projects, and services. Excellent organizational skills and demonstrated ability to handle complex analytical and detailed work. Excellent oral and written communication skills. Ability to work independently and collaboratively in a complex and rapidly changing environment.

Preferred:
The ideal candidate will present a strong combination of demonstrated experience and knowledge in the following areas: Metadata and associated functional standards, including XML/XSLT. Experience with developing interfaces for Web resources including knowledge of database management principles and software. Familiarity with one or more major digital content management systems appropriate for institutional repositories. Knowledge of current digital library technologies, standards, and best practices.  Experience with obtaining grant funding and managing grant-funded projects.

Application:
To apply for this position, please visit www.temple.edu click on Jobs@Temple, and then search by job number "TU-13131" (including the prefix "TU-". For full consideration, please submit your completed electronic application, along with a cover letter and resume, by May 15, 2010. 

Temple University is an Affirmative Action / Equal Opportunity Employer with a strong commitment to cultural diversity.

Jonathan LeBreton 
Sr. Associate University Librarian
Temple University Libraries
Paley M138,  1210 Polett Walk, Philadelphia PA 19122
voice: 215-204-8231
fax: 215-204-5201
mobile: 215-284-5070
email:  [email-masked]
email:  [email-masked]