Subject: [NGC4LIB] Linked Open Data prototype at the German National Library

From: Adrian Pohl <[email-masked]>
Date: Fri, 16 Apr 2010 15:14:33 +0200

Hallo,
 
the German National Library (DNB) has made public its Linked Data
prototype for authority data. It uses RDA, FOAF, the relationship
vocabulary and some DNB-made properties (GND-vocabulary) for person
authority data. For subject headings it uses SKOS, Dublin Core as well
as some newly minted GND-properties. It already contains links to
Wikipedia, DBpedia and viaf.org.
 
A documentation is available (only in German) here:
https://wiki.d-nb.de/display/LDS 
 
Here is the RDF/XML-representation of the authority data about Johann
Wolfgang von Goethe: http://devel.d-nb.de/linked/gnd/118540238/about
And the corresponding HTML-representation:
http://devel.d-nb.de/linked/gnd/118540238/
 
The data is also available as Open Data (actually I can't find a
licence) in N-Triple format:
http://datendienst.d-nb.de/cgi-bin/mabit.pl?cmd=fetch&userID=testdat&pass=testdat&mabheft=tdbdump_gnd.zip
(320 MB)
 
Because it's just a prototype and the underlying data is still subject
to changes you shouldn't link to it yet. The DNB wishes that the data
shouldn't be used in live systems. 
Some problems need to be resolved before leaving the prototype status,
for example: Until now the identifier for a person also is the
identifier for a HTML representation of the corresponding authority data
which conflicts Linked Data conventions. (See the URI of Johann Wolfgang
von Goethe for instance: http://d-nb.info/gnd/118540238)
 
It's great that the German National Library is taking action in the
Linked Data field and has realized - in contrast to other library
organizations - that it needs to change its business model away from
taking money for data!
 
Regards
Adrian

>>> "Binz, Vera" <[email-masked]> 16.04.2010 14:01 >>>
*** Mehrfachempfang bitten wir zu entschuldigen ***

Liebe Kolleginnen und Kollegen,

seit kurzem steht der Linked Data Service der Deutschen
Nationalbibliothek als Prototyp online zur Verfügung. Aktuell werden
etwa 1,8 Mio. Personen (aus der PND) und ca. 164.000 Sachschlagworte
(aus der SWD) dargestellt.

Wir möchten Sie einladen, den Service zu testen. Die Dokumentation, die
auch unsere Überlegungen bzgl. technischer Umsetzung und Modellierung
der Daten enthält, finden Sie unter: 

    https://wiki.d-nb.de/display/LDS 

Ansprechpartner: Dr. Jan Hannemann, [email-masked], Tel.
069-1525-1769

Wir freuen uns über Feedback, um dies bei der weiteren Umsetzung des
Linked Data Service berücksichtigen zu können. 

Viele Grüße 
Vera Binz

--
Vera Binz
Deutsche Nationalbibliothek 
Informationstechnik
Adickesallee 1
D-60322 Frankfurt am Main
Telefon: +49-69-1525-1771
Telefax: +49-69-1525-1799
mailto:[email-masked]
http://www.d-nb.de
-- 
http://www.inetbib.de

---

From: Tim Spalding <[email-masked]>
Date: Fri, 16 Apr 2010 10:22:17 -0400

This is wonderful. I can't want to have some time to play with it.

Does anyone know the relationship between the DNB and OCLC? I gather
there is some.

Does anyone want to step out on a limb and venture an explanation?
Surely the data contains elements that are ultimately dependent upon
what OCLC calls its records.

Tim

---

From: Ross Singer <[email-masked]>
Date: Fri, 16 Apr 2010 10:32:16 -0400

> what OCLC calls its records.

Tim, where do you get the idea that OCLC calls a national library's
authority data "its records"?  Where have they ever made that claim?

-Ross.

---

From: "Simpson, Sarah" <[email-masked]>
Date: Fri, 16 Apr 2010 10:02:42 -0500

I have to admit, I always hesitate to post a question of this sort to a list, for a variety of reasons.  However, as I try to figure out how I'm going to contribute to the cataloging world, honestly, you just seem like the best people to ask.

I'm a very good cataloger (and modest, too, as you can tell).  However, I am becoming very aware that in order to remain a good cataloger and make any forward progress, I am going to need to know other things than cataloging.  Specifically, technology.  I will need to learn more about the workings of our catalogs, what we know and need to tell our customers about the digital resources we have, what is necessary to share our data with the Web, and so on.

So, where do I start?  Are there particular things to learn about technology that would be the most useful, particular classes, particular topics?  What software do I need to know?  I want to learn what I need to know, but just have no idea where to start!  I have 3 universities and a community college in my immediate area, but do I need a computer science degree, or can I be more targeted than that?

I want to know why RDA is a good or bad idea, I want to be able to tell my library how big of a project it will be to implement, and to tell the truth, I want the background to be part of the discussion as RDA continues to be modified and improved.  ANYTHING you can tell me about how to learn what I need to know and what it is I need to know will be very, very much appreciated.

Sarah Simpson
Tulsa City-County Library

---

From: Oliver Flimm <[email-masked]>
Date: Fri, 16 Apr 2010 17:03:14 +0200

Hi,

> Does anyone know the relationship between the DNB and OCLC? I gather

DNB is working - together with OCLC and the LoC - on the
VIAF-Project. The authority files for persons (PND) and subject
headings (SWD) they just opened are all-DNB(tm) ;-)

After releasing our bibliographic data under CC0 we (=a working group
in our regional library center hbz with Adrian et al.) are tackling
the next milestone on our road to "linked" open data - URI's and
identifiers for manifestations of a given work. Should we use

a) our own ID's and risk fragmentation
b) re-use an already existing ID and try to import it into our data
c) use a match-key algorithm to generate a unique ID from a given
record, develop one and prove it's *really* good ;-)

Proprietary ID's like VIAF and OCLC-ID's are a no-go, of course. Using
proprietary ID's in linked *open* data is a contradiction in itself...

Also there is a need for a "global" Identifier, leaving b) and c).

ID's from OpenLibrary might be a good idea. The data is open, so we 
could match-and-merge its ID's into our own data. For all our record's
that aren't in OL we could upload it, get an ID and use it locally.

This would be a perfect symbiosis - each project contributing to the
other ;-)

I just started to evaluate whether OL is suitable to act as a
ID-automata to put in a record (search or upload) and get back
an ID for local reuse.

Of course there would be lot's of work to be done. Persistence of
identifiers, differences between cataloguing in Germany (RAK) and
elsewhere (AACR2), and so on.

Perhaps someone from OL is listening and can give me some feedback;-)

Regards,

O. Flimm

-- 
Universitaet zu Koeln :: Universitaets- und Stadtbibliothek
IT-Dienste :: Abteilung Universitaetsgesamtkatalog
Universitaetsstr. 33 :: D-50931 Koeln
Tel.: +49 221 470-3330 :: Fax: +49 221 470-5166
[email-masked] :: www.ub.uni-koeln.de

---

From: "Rinne, Nathan (ESC)" <[email-masked]>
Date: Fri, 16 Apr 2010 10:15:22 -0500

Sarah,

I'm in a similar position - feel like I'm way behind (with no time to
catch up).

I think in order to start to get your bearings I would regularly read
this list, Christine Schwartz's blog ( http://www.catalogingfutures.com/
), the Celeripedian blog ( http://celeripedean.wordpress.com/ ) and
Karen Coyle's blog (http://kcoyle.blogspot.com/ ), to name a few.

Regards,  

Nathan Rinne
Media Cataloging Technician
Educational Service Center
11200 93rd Avenue North
Maple Grove MN. 55369
Email: [email-masked]

-----Original Message-----
From: Next generation catalogs for libraries
[mailto:[email-masked]] On Behalf Of Simpson, Sarah
Sent: Friday, April 16, 2010 10:03 AM
To: [email-masked]
Subject: [NGC4LIB] What do I need to know?!

I have to admit, I always hesitate to post a question of this sort to a
list, for a variety of reasons.  However, as I try to figure out how I'm
going to contribute to the cataloging world, honestly, you just seem
like the best people to ask.

I'm a very good cataloger (and modest, too, as you can tell).  However,
I am becoming very aware that in order to remain a good cataloger and
make any forward progress, I am going to need to know other things than
cataloging.  Specifically, technology.  I will need to learn more about
the workings of our catalogs, what we know and need to tell our
customers about the digital resources we have, what is necessary to
share our data with the Web, and so on.

So, where do I start?  Are there particular things to learn about
technology that would be the most useful, particular classes, particular
topics?  What software do I need to know?  I want to learn what I need
to know, but just have no idea where to start!  I have 3 universities
and a community college in my immediate area, but do I need a computer
science degree, or can I be more targeted than that?

I want to know why RDA is a good or bad idea, I want to be able to tell
my library how big of a project it will be to implement, and to tell the
truth, I want the background to be part of the discussion as RDA
continues to be modified and improved.  ANYTHING you can tell me about
how to learn what I need to know and what it is I need to know will be
very, very much appreciated.

Sarah Simpson

---

From: MJ Suhonos <[email-masked]>
Date: Fri, 16 Apr 2010 11:16:45 -0400

I'd suggest trying to get a grasp on XML as a starting point.  Some will undoubtedly say that's not far enough, or that it's irrelevant next to the larger concepts like linked data, but really, XML represents the kind of web-world thinking that's going to power most of the implementations we see in the near future (as well as today, obviously).

If you're a "traditional" cataloguer and familiar with Library of Congress stuff, then I might suggest starting there (http://www.loc.gov/standards/) — get a sense of what MARCXML is, and why it's not very good, despite being XML.  Have a look at MODS and get an understanding of what a record in MODS looks like compared to what it would in MARC or MARCXML.  Then, have a look at EAD and/or the Dublin Core Metadata Element Set (search on DCMES) — try to understand how non-librarians would use these schemas to describe a (maybe digital or archival) resource.

That's just a starting point, but understanding the above should give you a better foundation to move on to other concepts like FRBR, RDA, RDF, Linked Data, etc.

MJ

---

From: Ed Jones <[email-masked]>
Date: Fri, 16 Apr 2010 08:40:07 -0700

For the curious, there's a very useful appendix (PDF) mapping from PICA to RDF at https://wiki.d-nb.de/download/attachments/34963694/Tabelle1.pdf  

Ed Jones

-----Original Message-----
From: Next generation catalogs for libraries [mailto:[email-masked]] On Behalf Of Adrian Pohl
Sent: Friday, April 16, 2010 6:15 AM
To: [email-masked]
Subject: [NGC4LIB] Linked Open Data prototype at the German National Library

Hallo,

 

 
 
Regards
Adrian

Viele Grüße 
Vera Binz

---

From: Ed Jones <[email-masked]>
Date: Fri, 16 Apr 2010 08:52:22 -0700

...and there are also some nice entity relationship diagrams that require no knowledge of German at https://wiki.d-nb.de/pages/viewpageattachments.action?pageId=34963694 (the PNG files)

Ed Jones

-----Original Message-----
From: Next generation catalogs for libraries [mailto:[email-masked]] On Behalf Of Adrian Pohl
Sent: Friday, April 16, 2010 6:15 AM
To: [email-masked]
Subject: [NGC4LIB] Linked Open Data prototype at the German National Library

Hallo,

 

 
 
Regards
Adrian

Viele Grüße 
Vera Binz

---

From: "Walker, David" <[email-masked]>
Date: Fri, 16 Apr 2010 10:23:22 -0700

> get a sense of what MARCXML is, and why it's not very good

I have to disagree that MARC-XML is "not very good."  

It's actually quite useful as an *intermediary* format between (ISO 2709) MARC and other schemas, like MODS, Dublin Core, and so on.  

Trying to go from a binary MARC file *directly* to MODS, for example, would be a pain.  So much easier to get the MARC into XML first, and then use XSLT to go from there to the schema of your choice.

--Dave

==================
David Walker
Library Web Services Manager
California State University
http://xerxes.calstate.edu
________________________________________
From: Next generation catalogs for libraries [[email-masked]] On Behalf Of MJ Suhonos [[email-masked]]
Sent: Friday, April 16, 2010 8:16 AM
To: [email-masked]
Subject: Re: [NGC4LIB] What do I need to know?!

MJ

---

From: MJ Suhonos <[email-masked]>
Date: Fri, 16 Apr 2010 13:31:01 -0400

> Trying to go from a binary MARC file *directly* to MODS, for example, would be a pain.  So much easier to get the MARC into XML first, and then use XSLT to go from there to the schema of your choic…

I agree with you 100% Dave, and that's precisely what I use it for myself.

But as a standalone format, it's *not* very good.  I didn't say "it's not very useful".  ;-)

MJ

---

From: Tim Spalding <[email-masked]>
Date: Fri, 16 Apr 2010 14:23:32 -0400

Sarah,

My inclination is to suggest you try to approach it from bottom up.
Buy a Ruby, Python, PERL or PHP book in the "Dummies" series and learn
enough programming to make you dangerous. I'd suggest something that
gets you into databases quickly. Most people don't realize how very
much programming a smart, organized person can learn in just a few
days. Once you have that, and have worked on a few fun projects of
your own, you can progress "up" to the sorts of questions you're
answering. Once you know what programming is, XML is cake, and RDA
just a flavor of cake.

I'm wary of the opposite way, where you try to learn technology from
the top down. Your knowledge then will always be tentative—a sort of
hearsay knowledge. You may acquire some knowledge, but you won't have
the authority to defend it. And don't librarians like authority? :)
Certainly you won't have a "skill" to put on your resume (and which,
outside libraries, could earn you twice your current salary). And you
certainly won't have a chance of discovering a new intellectual
passion.

Maybe, however, this is just how I learn. I'm a guy who took years of
dead languages because I couldn't stand the "hearsay experience" of
Aeschylus and Plautus in English. Since I didn't become an academic,
that time was largely wasted...

Do others think a top-down approach to technological knowledge is as
good or better than a bottom-up one?

Tim

---

From: Karen Coyle <[email-masked]>
Date: Fri, 16 Apr 2010 11:38:49 -0700

Adrian, thanks for sharing this. I hope some folks do interesting  
things with it.

Meanwhile, looking at the data, I see properties like:

gnd:variantNameForThePerson

There is a "Variant name for the person" in RDA, and it has a  
registered RDF form (with identifier). Have you considered using the  
RDA form? or registering your properties with a "same as" link?

kc

-- 
Karen Coyle
[email-masked] http://kcoyle.net
ph: 1-510-540-7596
m: 1-510-435-8234
skype: kcoylenet

---

From: MJ Suhonos <[email-masked]>
Date: Fri, 16 Apr 2010 14:41:35 -0400

> good or better than a bottom-up one?

Myself, I came from a bottom-up approach: years of programming in various languages, relational database principles, moving upwards through hierarchical models and abstraction frameworks.  From there, jumping into library school was very much a complete 180 to the top-down approach: abstract models, conceptual practices, information theory.  So, I've come from both ends, as it were.

I'd suggest the bottom-up approach if: a) you have the inclination to learn the nuts-and-bolts of the technology; and b) you have the time to do so.  I agree that a bright and motivated individual can learn a lot in a short time, but even that's a relative statement — and I'd caution against trivializing how foreign learning programming and related tech can be.  If you do make the effort, though, I agree with Tim that you'll have a much deeper foundation and set of tools for the longer term.

If instead you want to be able to ground some of the terminology that's flying around (which is the assumption that I made), then I'd recommend a more top-down approach since it probably aligns more closely with concepts that you're already familiar, and will certainly take less time.  RDA isn't too far a leap from AACR2; but Ruby is quite a leap from anything that any cataloguer I've ever met is familiar with.

The main reason I suggested XML is because I see it as being one of the middle-of-the-road concepts; bridging technical implementation and conceptual modelling — as evidenced by LoC's cataloguing standards being primarily XML-based.  But you could certainly go up or down from there, as well.

In brief:  if you think like a cataloguer, I'd suggest top-down; if you think like a programmer, I'd suggest bottom-up.  If you think in XML like I do, then God help you.  ;-)

MJ

---

From: Tim Spalding <[email-masked]>
Date: Fri, 16 Apr 2010 14:48:19 -0400

> In brief:  if you think like a cataloguer, I'd suggest top-down; if you think like a programmer, I'd suggest bottom-up.  If you think in XML like I do, then God help you.  ;-)

Okay, but don't underestimate yourself or overestimate how hard
programming is. At LibraryThing I've had occasion to train a number of
librarians from the "bottom up" and they've always been surprised at
how easy it is. The fact is, the catalogers I know well are all super
smart and mentally organized—the programmer skill set. On a number of
occasions I've seen them excel "real" programmers with ease.

Tim

---

From: "Jacobs, Jane W" <[email-masked]>
Date: Fri, 16 Apr 2010 14:48:46 -0400

I'm with Tim; get your hands dirty with some programming!  If nothing
else you'll have a jolly good time and enjoy your job a lot more.  If
you really accomplish something worthwhile you'll have job satisfaction
for a week at least.  But seriously, my experience is that very often,
despite having good IT people here, by the time I work out exactly what
I need to tell them in order to get to what I want I might as well
program it myself.  When I really can't I've at least gotten a grasp of
the complexities of the issue.
JJ

**Views expressed by the author do not necessarily represent those of
the Queens Library.**

Jane Jacobs
Asst. Coord., Catalog Division
Queens Borough Public Library
89-11 Merrick Blvd.
Jamaica, NY 11432
tel.: (718) 990-0804
e-mail: [email-masked]
FAX. (718) 990-8566

The information contained in this message may be privileged and confidential and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify us immediately by replying to the message and deleting it from your computer.-----Original Message-----
From: Next generation catalogs for libraries
[mailto:[email-masked]] On Behalf Of Tim Spalding
Sent: Friday, April 16, 2010 2:24 PM
To: [email-masked]
Subject: Re: What do I need to know?!

Sarah,

the top down. Your knowledge then will always be tentative-a sort of

Tim

---

From: Linda Ballinger <[email-masked]>
Date: Fri, 16 Apr 2010 13:53:09 -0500

Thanks to Sarah for starting this thread. It's a question I've been asking
myself a lot lately too. And thanks to those who have responded so far. I'm
especially interested in the suggestion to start from the bottom-up. I've
tried to keep myself familiar with MARCXML, MODS, and the like. But I keep
feeling that I'm not getting something. This bottom-up approach may be what
I'm looking for.

Tim, could you elaborate more on the languages you've suggested? Some brief
context (if that's possible) would help. Is any one of them a better
starting point than the others?

Linda Ballinger
Principal Cataloging Librarian
Newberry Library
Chicago, IL
[email-masked]

---

From: Trish Culkin <[email-masked]>
Date: Fri, 16 Apr 2010 13:21:24 -0600

Tim's statement re: "You may acquire some knowledge, but you won't have
the authority to defend it" struck home for me.

We started the CARL Corporation with librarians who grasped the concepts and
challenges of building ILS and OPAC applications, and who quickly learned
programming to put the concepts into play. These individuals ended up with a
very strong foundation, and even if they moved from programming to
management or product design, they always had the strongest voice at the
design table because they could "speak" (and illustrate, argue, and defend)
approaches with both clarity and authority.

Many people can describe the process for changing a tire, but actually
changing one -- jacking it up, breaking the bolts, setting the spare on the
wheel -- this is the best way to get the car back on the road.

-- 
Trish

---

From: "Hsi, Yuan Shang" <[email-masked]>
Date: Fri, 16 Apr 2010 16:37:29 -0400

I knew you will reply!!

Thanks,
Constance
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Yuan-shang Constance Hsi
Coordinator, Catalog Division
Queens Library
89-11 Merrick Blvd., Jamaica, NY 11432
PH 718 990-0730  FX 718 990-8566
[email-masked]

The information contained in this message may be privileged and confidential and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify us immediately by replying to the message and deleting it from your computer.-----Original Message-----
From: Next generation catalogs for libraries
[mailto:[email-masked]] On Behalf Of Jacobs, Jane W
Sent: Friday, April 16, 2010 2:49 PM
To: [email-masked]
Subject: Re: [NGC4LIB] What do I need to know?!

Jane Jacobs

The information contained in this message may be privileged and
confidential and protected from disclosure. If the reader of this
message is not the intended recipient, or an employee or agent
responsible for delivering this message to the intended recipient, you
are hereby notified that any dissemination, distribution or copying of
this communication is strictly prohibited. If you have received this
communication in error, please notify us immediately by replying to the
message and deleting it from your computer.-----Original Message-----
From: Next generation catalogs for libraries
[mailto:[email-masked]] On Behalf Of Tim Spalding
Sent: Friday, April 16, 2010 2:24 PM
To: [email-masked]
Subject: Re: What do I need to know?!

Sarah,

Tim

---

From: R Kemp <[email-masked]>
Date: Fri, 16 Apr 2010 16:25:19 -0700

Okay, here it goes - my first newbie post to a bunch of people who know a lot.  My background: I am a library school student with dreams of cataloging when she finishes next semester.  I have had paraprofessional experience as a copy cataloger.

Sarah, I'm assuming you have the Masters degree.  If so, I would recommend taking a class in XHTML.  XHTML is a hypertext markup language and is the basic building block of the Internet.  It will also help you - once you've finished - understand the different metadata systems out there as they are based on hypertext markup languages and (don't worry about what this means) SGML.

After XHTML, look for a metadata course.  Apparently there is one self-paced one at the LOC because my metadata instructor keeps referring to it!

RDA is not a huge concern of mine right now as I asked my public library boss what would happen when RDA finally came out.  She said "we will adopt it when the Library of Congress adopts it".  In the time between now and then, look for different courses on it offered by different organizations such as ALA, etc.

For database structure, have you taken any database software?  I am talking as simple as MS Access to a more sophisticated program such as Oracle with SQL, etc.  If you are concerned, take Access first, then start looking around.

What other people have said is true also.  However, this is the lowest level you can enter the places you have questions about.

Rebecca
 
> Date: Fri, 16 Apr 2010 10:02:42 -0500
> From: [email-masked]
 		 	   		  
_________________________________________________________________
The New Busy is not the old busy. Search, chat and e-mail from your inbox.
http://www.windowslive.com/campaign/thenewbusy?ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_3

---

From: "Simpson, Sarah" <[email-masked]>
Date: Fri, 16 Apr 2010 20:43:52 -0500

I've spoken with many of you directly, but I just wanted everyone to know how incredibly helpful these answers are to me, wow!!  Keep them coming, and thank you so much for the time you're taking to help out - I've been lurking and listening long enough to know this is the place for me, I just need to get the skills I need to contribute.  Thanks again!

Sarah

-----Original Message-----
From: Next generation catalogs for libraries [mailto:[email-masked]] On Behalf Of R Kemp
Sent: Friday, April 16, 2010 6:25 PM
To: [email-masked]
Subject: Re: [NGC4LIB] What do I need to know?!

Rebecca

---

From: "Miksa, Shawne" <[email-masked]>
Date: Fri, 16 Apr 2010 21:35:56 -0500

Sarah,

To learn about RDA, etc., I suggest you start right at the source--the Joint Steering Committee for the Development of RDA (http://www.rda-jsc.org/0903out.html ).  RDA is based in part on FRBR and FRAD so you will need to become familiar with those models. 

I've tried to keep a little page of resources for myself and my students--see http://courses.unt.edu/smiksa/preparing_for_resource_descripti.htm

**************************************************************
Shawne D. Miksa, Ph.D.
Associate Professor
Department of Library and Information Sciences
College of Information
University of North Texas
email: [email-masked]
http://courses.unt.edu/smiksa/index.htm
office 940-565-3560 fax 940-565-3101
**************************************************************
________________________________________
From: Next generation catalogs for libraries [[email-masked]] On Behalf Of Simpson, Sarah [[email-masked]]
Sent: Friday, April 16, 2010 8:43 PM
To: [email-masked]
Subject: Re: [NGC4LIB] What do I need to know?!

Sarah

-----Original Message-----
From: Next generation catalogs for libraries [mailto:[email-masked]] On Behalf Of R Kemp
Sent: Friday, April 16, 2010 6:25 PM
To: [email-masked]
Subject: Re: [NGC4LIB] What do I need to know?!

Rebecca

---

From: Alexander Johannesen <[email-masked]>
Date: Sat, 17 Apr 2010 12:54:00 +1000

Hi,

Um, well, hi there. And, uh, I was a bit hesitant in replying,
figuring I should just shut up, but unfortunately (for me) it's too
close to my heart to leave alone. But as some of you know, I can't
leave *anything* alone, especially that which I *should* leave alone.
So. Um.

First, let me restate what Tim said about catalogers; they are the
most impressive bunch of people I know, good instincts and certainly
have that programmer's mindset. They know about meta data, know about
good record-keeping skills, have learned about good backup practices,
and realizes that tools that you didn't make yourself and understand
mostly sucks. So.

Unless you know why you get into technology, don't just rush in, but
take a breath and explore *why* technology. No, there's nothing wrong
with digging into, say, programming or becoming an expert in knowledge
management systems and Wiki, but you should shape your technology path
based on what you think you might be best at. Here's why. As a
cataloger wanting to extend their skills there's nothing wrong about
pursuing technology, in fact, if you worry about the future it will
certainly make you employable outside of the library world, and that
is a good thing all in itself. But there are millions of technologists
out there already most of which are already infinitely better than you
at programming. You need to focus on what skills and knowledge you've
already got that can make you competitive in the real-world. Some
times you compete with them as they get employed at your library,
other times there might be a time when you might compete with them in
the real-world as your library gets shut down. Other times you compete
for resources for your project over others. You compete with others
ideas. You compete with others management skills, or process skills,
or whatever. We all compete. Just sayin', and reflections on this
should enter into your technology path.

Part 1 : Programming

Legend has it that programming requires a somewhat logic and / or
mathematical mind. It states further that it is just a matter of
telling the computer what it should do, and off we go, that technology
is nothing more than a reflection of humans in a logical and orderly
fashion. Needless to say, this isn't the case. Programming is a
creative process that happens to involve varying degrees of logic. If
you've only got one of those mindsets, if you're only creative or only
logical, you won't like it much.

Then the next thing to think about is where you think you want to go.
Exploring programming can be a lot of fun, and if fun is what you
want, look no further. But if you want to also become productive and
solve real problems, there's a few things that needs to be said as we
enter the world of software development which is split in three
equally sized boxes ; the Java box, the .Net box, and the misc. box.

Both Java and .Net are both frameworks which happens to have a
language (or two) in them; Java's language is also called Java, and
.Net's primary language is called C# (c sharp). They are both
object-oriented curly-bracketed in nature with a slew of APIs
(basically functions you ask the framework to do for you) you need to
know and understand to make any sense of them. The learning curve is
somewhat sloooooow because there is just so much to be learned, and
the framework is large and hard to move about. Consultants and large
companies thrive in this section.

The misc. box is everything else, including fun things.

The next thing to think about is at what level of technology are you
at now. Do you know what a browser is? Silly question, I know, but do
you *really* know what it is? Does this sound Greek to you (or
Norwegian if you're Greek or know Greek) ; it's a stateless client
application that asks a DNS server to resolve URIs, and sends (most of
the time) HTTP GET or POST requests to the resolved IP addresses, and
then render returning HTTP, HTTPS, FTP (and possibly other) responses,
or HTTP status codes
(http://en.wikipedia.org/wiki/List_of_HTTP_status_codes). Or if you
use the Opera browser, it contains a server as well, just to make life
even more interesting.

If it sounded Greek to you, working with Internet technology is going
to be hard at first. I could go on with the client - server false
dichotomy, I suppose, another chestnut of poorly understood pitfalls
and a language all in itself. Or even try to explain what a localhost
is in that soup? Do you understand IP addresses
(http://en.wikipedia.org/wiki/Internet_Protocol)? Read that page, and
if it makes your head hurt, Internet stuff in a technological sense
will only make you feel small and insignificant.

Creating programs in isolation is usually easier and mostly fun;
convert an XML to another through XSLT is fun; a JQuery demo gallery
can be fun; a Ruby internal model of a workflow can be fun; a PHP
framework for event-based and declarative programming is heaps fun!
But when you want to play with the world it becomes real complex real
fast. It will take a lot of time to get there.

Let's talk languages ;

Ruby, Python, Scala are somewhat fun but complex languages, but have
great communities. PHP is easy, and is one of the worlds most used
languages (LibraryThing uses it, for example) for its ease of
deployment. Perl is to be avoided unless you're a rock-star
programmer. Lisp is for academics. XSLT is underrated, Java is
overrated and bloated. C is for hackers, C++ is for programmers, C# is
for drones. And this is *strictly* my silly opinions that aren't true
to anyone but me. And you'll find that all programmers have differing
preferences and opinions on these matters. It is probably dangerous to
enter into a conversation about what language one should begin with,
because they *all* have their ups and downs, they all will be good or
bad for you depending on why you are, what you're like and how you
think.

I think my point so far is that if programming has slipped your mind,
then I'd warn you that that path leads to madness. Programming is not
easy. It is not always fun. Most of the time you won't even be
programming, but configuring stuff, or debugging code in trying to
find out why something doesn't work as expected.

Part 2 : Technology

Knowing glimpses of programming is fine, especially if you're managing
or dealing with programmers; You can squash any programming argument
from them through clever use of technology understanding (like "no,
the client-server paradigm is a false dichotomy") or, perhaps a better
example, guide and direct others in the right direction.

One thing I love about librarians is that they all have their pet area
of expertise. You'll be discussing some weird part of a MARC
sub-field, and you might blurt out "Who ever came up with *that*?" to
which a librarian with a fetish for MARC history pipes up the exact
person, the reasoning behind it, and all the fields affected (not to
mention that "we don't do it that way these days, anyway, this is
wrong, and this punctuation should be in this other field after the
slash instead").

Anyway, what is technology? It's just tools which these days happens
to be mostly digital. Ok, what does that mean? Well, it means that all
books will be scanned and turned into bits and bytes, and placed in
database systems that can search, retrieve and mangle them further.
That is a field worth exploring. Learn about how computers use pattern
recognition, sharpening and blurring filters, various ratio and edge
filtering, resolution scanning, zooming and sharpening techniques, all
to convert bitmaps of letters into vectors of coordinates on which the
system can match letters and words. Or learn about search and
indexing, how computers can store parts of a longer thing, use
mathematics to cluster similarities together, or MapReduce to deal
with huge amounts of data, or ... uh, a million other things involved.

Technology isn't scary, but there is one problem; it is always moving.
You can't learn one part of technology and expect to then know it. You
need to practice it, and you need to change as the technology change.
This is a challenge to a lot of people, so you might as well get it
straight away; technology never stays the same, it always move, it
shifts with human culture. The programming I knew 10 years ago is all
moot. The systems I worked on 20 years ago are all gone. Heck, the
systems I built last year is already gone. The purpose of my current
project is changing as we speak. The cultural baggage from when I
learned programming as a young lad still inhibits me today when
everything has changed. If you're a person that doesn't like change,
can I offer you a career in brick-laying instead? Because that's what
I feel like doing these days.

Anyway, I'll stop rambling now. And go and lay some bricks.

Regards,

Alex (the anti-Feist)

-- 
 Project Wrangler, SOA, Information Alchemist, UX, RESTafarian, Topic Maps
--- http://shelter.nu/blog/ ----------------------------------------------
------------------ http://www.google.com/profiles/alexander.johannesen ---

---

From: "Diane I. Hillmann" <[email-masked]>
Date: Sat, 17 Apr 2010 10:11:25 -0400

Alex,

I'm with you on this one.  I think it's far more important to delve into 
the technology in a more general sense, to be able to work WITH 
programmers, than it is to be able to program.  I would suggest that a 
person with cataloging background would be far better off learning data 
management technologies, RDF, vocabulary management (SKOS, for 
instance), and the many other things that will be driving our future, 
than to dabble in programming.

All I can say is that it's worked for me ...

Diane

On 4/16/10 10:54 PM, Alexander Johannesen wrote:
> On Sat, Apr 17, 2010 at 11:43, Simpson, Sarah<[email-masked]>  wrote:
>    
> .

---

From: Christine Schwartz <[email-masked]>
Date: Mon, 19 Apr 2010 13:20:24 -0400

Hi Sarah,

Sorry to add to this thread so late in the game (I've been really sick
lately).

I agree with MJ that studying XML is a good place to start. Practically all
the library metadata schemes use XML, so if you're going to transition into
a cataloger/metadata librarian you need to know XML.

Over the last 2 1/2 years I have learned the XQuery programming language,
not for fun, but because it's part of my job. I've used XQuery to search and
manipulate metadata, to build crosswalks, to re-build METS documents, etc. I
do think it is helpful to understand programming, but I know enough now to
know that I'm nowhere near the level I would need to be to leave the library
world and get a programming job (not that I want to). I do want to add,
though, that while I enjoy XQuery very much, I did not find it easy to
learn, but rather one of the most challenging things I have ever learned.

Right now, I want to be a really good metadata librarian, and I'm going to
let that goal dictate how much time I spend studying programming or any
other new technology.

Chris

Christine Schwartz
Metadata Librarian
Princeton Theological Seminary Library

On Fri, Apr 16, 2010 at 11:02 AM, Simpson, Sarah
<[email-masked]>wrote:

> going to contribute to the cataloging world, honestly, you just seem like
> the best people to ask.
>
> I'm a very good cataloger (and modest, too, as you can tell).  However, I
> am becoming very aware that in order to remain a good cataloger and make any
> forward progress, I am going to need to know other things than cataloging.
>  Specifically, technology.  I will need to learn more about the workings of
> our catalogs, what we know and need to tell our customers about the digital
> resources we have, what is necessary to share our data with the Web, and so
> on.
>
> topics?  What software do I need to know?  I want to learn what I need to
> know, but just have no idea where to start!  I have 3 universities and a
> community college in my immediate area, but do I need a computer science
> degree, or can I be more targeted than that?
>
> I want to know why RDA is a good or bad idea, I want to be able to tell my
> library how big of a project it will be to implement, and to tell the truth,
> I want the background to be part of the discussion as RDA continues to be
> modified and improved.  ANYTHING you can tell me about how to learn what I
> need to know and what it is I need to know will be very, very much
> appreciated.
>
> Sarah Simpson

---

From: Eric Lease Morgan <[email-masked]>
Date: Mon, 19 Apr 2010 14:35:58 -0400

> a cataloger/metadata librarian you need to know XML.

I wrote an XML tutorial/workshop that may be of interest to the group. From the introduction:

  XML is about distributing data and information
  unambiguously. Through this hands-on workshop you will
  learn: 1) what XML is, and 2) how it can be used to build
  library collections and faciliate library services in our
  globally networked environment.

  http://infomotions.com/musings/xml-in-libraries/

The tutorial/workshop comes with a bevy of examples, scripts, stylesheets, and sample data.

-- 
Eric Lease Morgan

---

From: Jonathan Rochkind <[email-masked]>
Date: Mon, 19 Apr 2010 14:41:08 -0400

What some of us have talked about for a while is that what catalogers 
and metadata engineers need to know is NOT how to program, but something 
about what some people call "computational thinking" -- how to arrange a 
problem so it can be solved by software, how to recognize what sort of 
problems can be solved by software and what sorts are more difficult or 
impossible.

But I have yet to find a good "curriculum" for that.  It's taught in a 
good computer science program along with learning how to program, but it 
ought to be possible, Jeannette Wing and the other "comptuational 
thinking" enthusiasts think, to teach it apart from programming entirely 
too.   But I don't know if there's a good curriculum available.

Jonathan

---

From: Christine Schwartz <[email-masked]>
Date: Mon, 19 Apr 2010 15:04:23 -0400

Jonathan,

I recently wrote an essay for a book (hope it gets published) on the
transition from cataloger to metadata librarian. And one of the reason I
give for why it's good for catalogers to learn how to program is that it's a
way to acquire the mindset, i.e., computational thinking, that's needed for
working with digital resources and metadata. You and Jeannette Wing are
cited in the essay.

I often struggle to put my finger on the difference between cataloging and
metadata creation, but it definitely requires a mental shift, a change in
the way we think about data.

Chris

On Mon, Apr 19, 2010 at 2:41 PM, Jonathan Rochkind <[email-masked]> wrote:

> What some of us have talked about for a while is that what catalogers and
> metadata engineers need to know is NOT how to program, but something about
> what some people call "computational thinking" -- how to arrange a problem
> so it can be solved by software, how to recognize what sort of problems can
> be solved by software and what sorts are more difficult or impossible.
>
> But I have yet to find a good "curriculum" for that.  It's taught in a good
> computer science program along with learning how to program, but it ought to
> be possible, Jeannette Wing and the other "comptuational thinking"
> enthusiasts think, to teach it apart from programming entirely too.   But I
> don't know if there's a good curriculum available.
>
> Jonathan
>
>
> Eric Lease Morgan wrote:
>

---

From: Jonathan Rochkind <[email-masked]>
Date: Mon, 19 Apr 2010 15:11:02 -0400

Awesome, look forward to reading it. 

Learning to program is definitely one way to develop the 'computational 
thinking' mindset, and the way that most of us who have it have 
developed it.  But I worry that depending on HOW you learn to program, 
it doesn't _neccesarily_ result in developing the computational thinking 
mindset in a very efficient way. Good computer science programs in 
universities (and they aren't all good) develop it in their students.  
But just learning to hack and script the way many of us do on the job is 
not neccesarily, IMO, going to lead to 'computational thinking' mindset, 
or at least it will take a LOT longer to develop it as a byproduct of 
unfocused experiments with programming than it would from a good 
curriculum targetted at computational thinking -- which woudln't 
neccesarily require learning to program at all.

But such a curriculum does not seem to exist yet.  Maybe Jeannette Wing 
will develop one!   Probably not though. Maybe some enterprising 
consultant or MLIS faculty member can get a grant to develop a free 
online course, "computational thinking for catalogers". One can dream.

Jonathan

---

From: "Lundgren,Jimmie Harrell" <[email-masked]>
Date: Tue, 20 Apr 2010 06:38:31 -0400

Did anyone mention the usefulness of basic skills in spreadsheets and SQL? Today's catalog manager is often required to manage and massage the catalog data in bulk. In my library the cataloging managers and collection management librarians have been lucky enough to draw on the skills of an experienced librarian who built SQL skills on top of a strong grasp of user services and cataloging. Sadly, we are losing him soon and someone else with that complement of skills would really look good. 

Jimmie Lundgren

---

From: "Simpson, Sarah" <[email-masked]>
Date: Tue, 20 Apr 2010 07:31:10 -0500

I really do want to thank absolutely everyone for their responses to my question!!  I have a lot of great things to explore and a lot of help as I begin to create a path for myself toward being better able to participate in what are very exciting times!  Everyone has been so generous with their knowledge and experience, I feel ready to get started.  Thanks again!!

Sarah

________________________________________
From: Next generation catalogs for libraries [[email-masked]] On Behalf Of Jonathan Rochkind [[email-masked]]
Sent: Monday, April 19, 2010 2:11 PM
To: [email-masked]
Subject: Re: [NGC4LIB] What do I need to know?!

Jonathan

---

From: Bill Dueber <[email-masked]>
Date: Tue, 20 Apr 2010 19:45:22 -0400

On Fri, Apr 16, 2010 at 1:31 PM, MJ Suhonos <[email-masked]> wrote:

> > It's actually quite useful as an *intermediary* format between (ISO 2709)
> MARC and other schemas, like MODS, Dublin Core, and so on.
>

Boy, I have to disagree again.

Let's start by saying there's no difference semantic between binary MARC and
MARC-XML. They're identical (i.e., round-trip-able) serializations of the
exact same data structure. Serializations are not "good" or "bad", they just
range from "less painful to work with" to "more painful to work with."

Having said that -- MARC-XML is demonstrably *better* than ISO 2709 in that
while every binary (ISO 2709) MARC record (at least those with "normal"
indicators, tags, etc) is easily represented in MARC-XML, the reverse is not
true because of the length issue. I've got plenty of records longer than
10,000 bytes in length, and for them binary MARC is worthless.

The MARC data structure (tags, indicators, subfields) is crappy, but that's
independent of its serialization. I've written up something about this at
http://robotlibrarian.billdueber.com/data-structures-and-serializations/

>
> > Trying to go from a binary MARC file *directly* to MODS, for example,
> would be a pain.  So much easier to get the MARC into XML first, and then
> use XSLT to go from there to the schema of your choice.
>
> > I'd suggest trying to get a grasp on XML as a starting point.  Some will
> undoubtedly say that's not far enough, or that it's irrelevant next to the
> larger concepts like linked data, but really, XML represents the kind of
> web-world thinking that's going to power most of the implementations we see
> in the near future (as well as today, obviously).
> >
> > If you're a "traditional" cataloguer and familiar with Library of
> Congress stuff, then I might suggest starting there (
> http://www.loc.gov/standards/) — get a sense of what MARCXML is, and why
> it's not very good, despite being XML.  Have a look at MODS and get an
> understanding of what a record in MODS looks like compared to what it would
> in MARC or MARCXML.  Then, have a look at EAD and/or the Dublin Core
> Metadata Element Set (search on DCMES) — try to understand how
> non-librarians would use these schemas to describe a (maybe digital or
> archival) resource.
> >
> > That's just a starting point, but understanding the above should give you
> a better foundation to move on to other concepts like FRBR, RDA, RDF, Linked
> Data, etc.
> >
> > MJ
> >
> I am becoming very aware that in order to remain a good cataloger and make
> any forward progress, I am going to need to know other things than
> cataloging.  Specifically, technology.  I will need to learn more about the
> workings of our catalogs, what we know and need to tell our customers about
> the digital resources we have, what is necessary to share our data with the
> Web, and so on.
> >>
> truth, I want the background to be part of the discussion as RDA continues
> to be modified and improved.  ANYTHING you can tell me about how to learn
> what I need to know and what it is I need to know will be very, very much
> appreciated.
> >>
> >> Sarah Simpson

-- 
Bill Dueber
Library Systems Programmer
University of Michigan Library

---

From: "Simpson, Sarah" <[email-masked]>
Date: Fri, 23 Apr 2010 11:32:54 -0500

Thanks so much, Chris - I was away at a conference all week, so am just getting back to reading the lists now.  This is very helpful information!!  Thanks for taking the time to answer!

Sarah 

-----Original Message-----
From: Next generation catalogs for libraries [mailto:[email-masked]] On Behalf Of Christine Schwartz
Sent: Monday, April 19, 2010 12:20 PM
To: [email-masked]
Subject: Re: [NGC4LIB] What do I need to know?!

Hi Sarah,

Chris

Christine Schwartz
Metadata Librarian