Subject: [NGC4LIB] information organization, systems, and terrorists

From: "Miksa, Shawne" <[email-masked]>
Date: Sun, 3 Jan 2010 11:07:32 -0600

It’s Sunday morning and I’m listening to CNN’s State of the Union while working on a chapter of my book.  I’m hearing mostly about the thwarted December 25th terrorist attack on the plane from Amsterdam to Detroit and the breakdown in the intelligence community as it concerns making the connections between information they had concerning the individual terrorist, his connection to Yemen, how and why things were missed that may have prevented him from being able to get on the plane in the first place, etc.  At the same time I’m trying to write a chapter on our library information systems, what they are, what are library catalogs today, objectives, FRBR, etc.  All of this brings to mind the complexity of an information system and the effect of that complexity on making those connections, the reliance and over-reliance on the technology (i.e., on commentator asked why the computer technology didn’t make the connection), and on human ability to make the connections, and so on.  If we shift that complexity to the kinds of information systems we in LIS create, populate, manipulate, maintain, and cross-connect to other systems---it begs the question of how much complexity can we expect to be able to maintain or work within?

Let’s pretend that every information resource we have in our system(s) represents one terrorist and we are the intelligence community. A terrorist attack is equivalent to a failure to meet an information need (e.g., someone presented what they thought was a thorough report with all the facts, but it turns out they missed a major piece of info and a major deal broke down or someone got an F on a paper because of lack of viable resources).

As the organizers of the information (the raw data), our tools are description, authority control of names and headings, inclusion and exclusion of shared vocabulary, both natural language and controlled, our interpretation of the intentions of the resource creator from both ourselves and outside resources (i.e., agents on the ground, snitches, etc.), our judgment based on the experience, or inexperience, we have accumulated during our life, and the ability of the system to make these same types of judgment (based on how it’s been programmed).  On top of that we as the organizers also have to have a strong understanding of the system or variety of systems that we work within, as well as information needs and information seeking abilities (human information behavior) of the users of those systems.  Furthermore, we realize that we have no control over how that information is used, misused, or not used by the user---which logically would push us to make even richer representations as a way of attracting the user so they might use the information correctly and make those connections.

Are we insane to think we can make all the appropriate connections in order to predict, and therefore prevent, a terrorist attack/info need not met? If someone dropped the ball and didn’t put the information they had into a system or “out there” in the info stream or simply made a poor representation of that information—all or part of which is apparently part of the problem as it concerns this Dec 25 attack—then the connection isn’t made and our defenses are weakened.  We share in the loss in the great game of information organization because missed connections may result in “deaths” of innocent individuals (i.e., useless reports, fail grades, etc.)

What is predictable and what is not?  For example, did the Dec 25th terrorist work into the equation the actions of the passengers on the plane, or the (thankfully) faulty bomb equipment?  We could translate this into our users coming to us to point out mistakes and/or missed connections between resources in our systems based on their personal knowledge/expertise.

Just thinking out loud. All of the varying opinions on the talk shows have me thinking about what we can expect and what we shouldn’t, action vs. inaction, complexity, connections, etc. How do we account for all of this when working within current information systems?

**************************************************************

Shawne D. Miksa, Ph.D.
Associate Professor
Department of Library and Information Sciences
College of Information
University of North Texas
email: [email-masked]<mailto:[email-masked]>
http://courses.unt.edu/smiksa/index.htm
office 940-565-3560 fax 940-565-3101
**************************************************************

---

From: Joe Hourcle <[email-masked]>
Date: Mon, 4 Jan 2010 10:15:28 -0500

On Sun, 3 Jan 2010, Miksa, Shawne wrote:

> It’s Sunday morning and I’m listening to CNN’s State of the Union while 
> working on a chapter of my book.  I’m hearing mostly about the thwarted 
> December 25th terrorist attack on the plane from Amsterdam to Detroit 
> and the breakdown in the intelligence community as it concerns making 
> the connections between information they had concerning the individual 
> terrorist, his connection to Yemen, how and why things were missed that 
> may have prevented him from being able to get on the plane in the first 
> place, etc.  At the same time I’m trying to write a chapter on our 
> library information systems, what they are, what are library catalogs 
> today, objectives, FRBR, etc.  All of this brings to mind the complexity 
> of an information system and the effect of that complexity on making 
> those connections, the reliance and over-reliance on the technology 
> (i.e., on commentator asked why the computer technology didn’t make the 
> connection), and on human ability to make the connections, and so on. 
> If we shift that complexity to the kinds of information systems we in 
> LIS create, populate, manipulate, maintain, and cross-connect to other 
> systems---it begs the question of how much complexity can we expect to 
> be able to maintain or work within?

I'm going to take a different approach to the problem, because the systems 
I design aren't your typical "library" systems.

The catalogs that I deal with fall into two broad catagories*.  They might 
go by other names in other science fields, but for solar physics:

 	data catalogs :
 		a record of the data collected and/or its processed forms

 	feature and event catalogs :
 		a science product, where a scientist (or software written
 		by a scientist) has identified something of interest

There is a *lot* of data.  For some missions, it's a few million 
observations, and there might be a few different forms of it on disk, so 
some scientists go to the event catalogs, pick out a region & time period 
of interest, and then do study on that part.

... but there are people who want us to merge all of the event & feature 
information back into the data catalogs.  Not even getting into the issues 
of data normalization, we still have a lot of questions:

 	1. Was this event found by the PI team from the instrument?
 		(if yes, well, the PI team can add it to 'their' data
 		catalog)
 	2. Was this event found using data from this instrument?
 		(if yes, they might have a legitimate argument)
 	3. Does the community agree about the methods used to identify
 		the event?
 		(eg, has it been peer-reviewed?)
 	4. Could the instrument have even seen the event?
 		(if it was a magnetic event, should it be listed in
 		telescope data ... well, yes, if someone wanted to follow
 		up and try to determine if there was evidence in other
 		instruments, but it could confuse people)

I was at a science team meeting, and we had one of the scientists ask us 
if our system could tell them if two events were the "same" -- and quite 
simply, it can't, because that's for the scientists to decide.

We can tell them that two events were seen at the same time, in the same 
place, but we won't tell that they are the same event.  Our system is 
there to make it easier for scientists to do their job, but not for us to 
replace the scientists, as there are so many edge cases and the science 
changes that it'd be impossible for us to deal with.

...

So, you're asking how this relates to intelligence ...

Say for instance that a scientist is analyzing data from two instruments, 
A and B ... They see a strange reading in A ... they cross-check the data 
in B, and find that B looks perfectly normal.

Two weeks later, they realize that the calibration on one of the 
instruments is wrong.  Suddenly, we might have the case where the event in 
A is scrubbed out, or we have the case where B confirms the findings of A.

Likewise, in intelligence, you might have cases where informants are found 
to be unreliable, and you have to go and re-assess all of the decisions 
made using that bad information.  This can have major cascading effects 
... but I don't know if any systems actually do this -- they answer the 
questions that are asked now, and so unless the question gets asked again, 
no one might ever know that the response has changed.

You would have to design a system that could respond to not only every 
question asked of it, but every time new information is added, to 
determine if it needs to re-process previous responses.  You'd run out of 
resources.

...

You then get people who want to run the analysis using alternate inputs. 
In the case of science, it might be that they want to use a different 
scientific model for ground water flow, or assume a different propogation 
model for coronal mass ejections.  In intelligence, I could see someone 
wanting to re-run analysis assuming that some accepted 'truth' didn't 
exist.

... but those aren't for the system-builders to decide; we can provide the 
tools, but the scientists / analysts / whomever have to decide to actually 
run the proper analysis.

...

As for why so much technology is brought in for intelligence.  Well, 
there's still a lot of humans involved**, but the cynic in me believes 
that it's easier for contractors to sell a pre-packaged technological 
"solution" than it is to convince some people to just hire more or more 
qualified people.

... which reminds me of an article the other day 
discussing Israel's approach to airport security :

 	http://www.thestar.com/iphone/news/world/article/744199---israelification-high-security-little-bother

... yes, there's technology in there (bomb proof areas, etc.), but the 
common sense apprach doesn't give someone an opportunity to sell more 
expensive bomb-sniffing gear, or full-body imagers, or whatever the 
security product of the week is.

-Joe

* We have other catalogs as well (eg, publications), but we don't 
currently link between publications and data, although we'd like to. 
There are proposals to require articles in Solar Physics (journal) to 
register an "event" so there'd be an unambiguous identifier to ... 
something, but that something has issues for long-lived, re-occurant 
features and those that might be at varying heights & depths, or that 
don't track with the normal solar rotation.

ps.  I have no experience in the intelligence community, but I have talked 
with some people at what used to be NGA about how they deal with the 'best 
size' of images to return to their analysts, and I've talked to some of 
the folks dealing with provenance tracking to deal with tracking when bad 
data was used to answer analysis questions, and with some people building 
large-scale triple stores to deal with tracking 'quality' of the 
information.

** Okay, I said I had no experience, but I did work summers in high school 
at an annex to the pentagon, and so was there twice a day with mail around 
the time of the first gulf war, and recently, I went to a retirement event 
at a secured facility where they wouldn't tell me specifically what they 
did, but based on the size of the building, there were a lot of people 
working there.  And unlike the pentagon, there was high security for the 
whole building.

---

From: Weinheimer Jim <[email-masked]>
Date: Tue, 5 Jan 2010 18:02:00 +0100

Shawne,

These are some thought-provoking comments. I think there is another consideration that must be included: general expectations. 

People expect much more than ever before, and a lot of these expectations are simply unrealistic. In your example, an argument could be made that the populace expects and demands 100% security. Of course, this is an impossibility, but nevertheless, when something untoward happens, as it always will, people believe that "something has gone wrong." Many times, it isn't that something has gone wrong; it's not that anyone has made a mistake; it's that no one has ever achieved 100% security. This means that things happen sooner or later, and that wil always have things to learn. I think this is something that people outside of the US understand somewhat better. For example, just a couple of days ago there was a bombing at a police station in southern Italy, most probably by the Mafia (http://www.siciliainformazioni.com/giornale//76320/calabria-bomb-seen-general-warning-attack-ndrangheta-signature-investigators.htm), but while people are angry and concerned, there has been nothing!
  about: who made the mistakes that allowed this to happen in the first place, and so on. There have been bombings in the UK, Spain and many other European countries, but their reactions are quite different from what seems to be going on in the US. I think we can also keep in mind the problem of relying on 100% economic security as well.

In these cases, I think there is a lot society can do, but there will still be a lot of risk left over.

Relating this to libraries, what are our patrons' expectations? I have not looked to see if there is any research in this area per se, but it is my professional experience that people's expectations for what they can get through information search and retrieval has changed a lot. For example,  if a library doesn't have a book, the public can get a copy through ILL or through some sort of arrangement where your patrons can go to another library where they can get the book. 20 years ago, that was considered a success. Today, I think such an option is considered more as a failure in the eyes of our patrons, and are becoming more and more of a failure all the time. People want *everything* and they want it *now* so if they have to go somewhere else, or have to wait a few days or weeks to get the information they want, or as I have seen more and more, if something is not available in an electronic version where they can search the full-text, they see it as a failure of the inform!
 ation search and retrieval system. I am not saying that this is a good thing that is happening, but happening it is and I don't have any idea how this can be stopped. Attached to this is the idea of Marcia Bates' "Principle of Least Effort" which I discussed on a list somewhere and I placed a copy on my blog at: http://catalogingmatters.blogspot.com/2009/06/re-in-praise-of-lazy-catalogers-was.html.
"Probably the single most frequently discovered finding on information seeking behavior is that people use the principle of least effort in their information seeking. This may seem reasonable and obvious, but the full significance of this finding must be understood. People do not just use information that is easy to find; they even use information they know to be of poor quality and less reliable--so long as it requires little effort to find--rather than using information they know to be of high quality and reliable, though harder to find." 

This has profound consequences for what we are doing, both in terms of systems development and perhaps more crucially, on user education.

This is why I keep harping on the FRBR user tasks, which necessarily are very closely related to user expectations: people want and expect something substantially different today from before. The FRBR user tasks are simply obsolete and the sooner we accept this, the better for our entire field. In fact, it is my experience that the rise of full-text searching has brought a consequent loss of the very concept of authority control (which was poorly understood to begin with), and as a result, even the *idea* of being able to find, for example "all of the works" of Mark Twain (within the traditional parameters of the rule of three etc.) no matter the form of the name on the item, is becoming less and less known among patrons and perhaps less and less appreciated. Once they understand the purpose and power of authority control, which is definitely not something that can be explained in sixty seconds, (for example, see the BBC article "Turning into digital goldfish" http://news.bb!
 c.co.uk/2/hi/science/nature/1834682.stm) This goes equally for all the European, US and UK students I have worked with.

We need to make tools that will berelevant to our users' needs , but before that we need to find out what their needs are, otherwise we are making tools relevant to the world before the 1990s but not to the world of today, let alone the world 20 years from now. 

James L. Weinheimer  [email-masked]
Director of Library and Information Services
The American University of Rome
Rome, Italy
________________________________________
From: Next generation catalogs for libraries [[email-masked]] On Behalf Of Miksa, Shawne [[email-masked]]
Sent: Sunday, January 03, 2010 6:07 PM
To: [email-masked]
Subject: [NGC4LIB] information organization, systems,  and terrorists

It’s Sunday morning and I’m listening to CNN’s State of the Union while working on a chapter of my book.  I’m hearing mostly about the thwarted December 25th terrorist attack on the plane from Amsterdam to Detroit and the breakdown in the intelligence community as it concerns making the connections between information they had concerning the individual terrorist, his connection to Yemen, how and why things were missed that may have prevented him from being able to get on the plane in the first place, etc.  At the same time I’m trying to write a chapter on our library information systems, what they are, what are library catalogs today, objectives, FRBR, etc.  All of this brings to mind the complexity of an information system and the effect of that complexity on making those connections, the reliance and over-reliance on the technology (i.e., on commentator asked why the computer technology didn’t make the connection), and on human ability to make the connections, and so on.  !
 If we shift that complexity to the kinds of information systems we in LIS create, populate, manipulate, maintain, and cross-connect to other systems---it begs the question of how much complexity can we expect to be able to maintain or work within?

As the organizers of the information (the raw data), our tools are description, authority control of names and headings, inclusion and exclusion of shared vocabulary, both natural language and controlled, our interpretation of the intentions of the resource creator from both ourselves and outside resources (i.e., agents on the ground, snitches, etc.), our judgment based on the experience, or inexperience, we have accumulated during our life, and the ability of the system to make these same types of judgment (based on how it’s been programmed).  On top of that we as the organizers also have to have a strong understanding of the system or variety of systems that we work within, as well as information needs and information seeking abilities (human information behavior) of the users of those systems.  Furthermore, we realize that we have no control over how that information is used, misused, or not used by the user---which logically would push us to make even richer representati!
 ons as a way of attracting the user so they might use the information correctly and make those connections.

Shawne D. Miksa, Ph.D.
Associate Professor

---

From: "B.G. Sloan" <[email-masked]>
Date: Tue, 5 Jan 2010 10:19:18 -0800

I think there's an obvious parallel here. Security personnel design terror alert systems assming they know how terrorists operate. Librarians design information systems assuming they know how library users operate.

--- On Tue, 1/5/10, Weinheimer Jim <[email-masked]> wrote:

From: Weinheimer Jim <[email-masked]>
Subject: Re: [NGC4LIB] information organization, systems, and terrorists
To: [email-masked]
Date: Tuesday, January 5, 2010, 12:02 PM

Shawne,

People expect much more than ever before, and a lot of these expectations are simply unrealistic. In your example, an argument could be made that the populace expects and demands 100% security. Of course, this is an impossibility, but nevertheless, when something untoward happens, as it always will, people believe that "something has gone wrong." Many times, it isn't that something has gone wrong; it's not that anyone has made a mistake; it's that no one has ever achieved 100% security. This means that things happen sooner or later, and that wil always have things to learn. I think this is something that people outside of the US understand somewhat better. For example, just a couple of days ago there was a bombing at a police station in southern Italy, most probably by the Mafia (http://www.siciliainformazioni.com/giornale//76320/calabria-bomb-seen-general-warning-attack-ndrangheta-signature-investigators.htm), but while people are angry and concerned,
 there has been nothing!
  about: who made the mistakes that allowed this to happen in the first place, and so on. There have been bombings in the UK, Spain and many other European countries, but their reactions are quite different from what seems to be going on in the US. I think we can also keep in mind the problem of relying on 100% economic security as well.

Relating this to libraries, what are our patrons' expectations? I have not looked to see if there is any research in this area per se, but it is my professional experience that people's expectations for what they can get through information search and retrieval has changed a lot. For example,  if a library doesn't have a book, the public can get a copy through ILL or through some sort of arrangement where your patrons can go to another library where they can get the book. 20 years ago, that was considered a success. Today, I think such an option is considered more as a failure in the eyes of our patrons, and are becoming more and more of a failure all the time. People want *everything* and they want it *now* so if they have to go somewhere else, or have to wait a few days or weeks to get the information they want, or as I have seen more and more, if something is not available in an electronic version where they can search the full-text, they see it as a
 failure of the inform!
ation search and retrieval system. I am not saying that this is a good thing that is happening, but happening it is and I don't have any idea how this can be stopped. Attached to this is the idea of Marcia Bates' "Principle of Least Effort" which I discussed on a list somewhere and I placed a copy on my blog at: http://catalogingmatters.blogspot.com/2009/06/re-in-praise-of-lazy-catalogers-was.html.
"Probably the single most frequently discovered finding on information seeking behavior is that people use the principle of least effort in their information seeking. This may seem reasonable and obvious, but the full significance of this finding must be understood. People do not just use information that is easy to find; they even use information they know to be of poor quality and less reliable--so long as it requires little effort to find--rather than using information they know to be of high quality and reliable, though harder to find." 

This is why I keep harping on the FRBR user tasks, which necessarily are very closely related to user expectations: people want and expect something substantially different today from before. The FRBR user tasks are simply obsolete and the sooner we accept this, the better for our entire field. In fact, it is my experience that the rise of full-text searching has brought a consequent loss of the very concept of authority control (which was poorly understood to begin with), and as a result, even the *idea* of being able to find, for example "all of the works" of Mark Twain (within the traditional parameters of the rule of three etc.) no matter the form of the name on the item, is becoming less and less known among patrons and perhaps less and less appreciated. Once they understand the purpose and power of authority control, which is definitely not something that can be explained in sixty seconds, (for example, see the BBC article "Turning into digital
 goldfish" http://news.bb!
c.co.uk/2/hi/science/nature/1834682.stm) This goes equally for all the European, US and UK students I have worked with.

It’s Sunday morning and I’m listening to CNN’s State of the Union while working on a chapter of my book.  I’m hearing mostly about the thwarted December 25th terrorist attack on the plane from Amsterdam to Detroit and the breakdown in the intelligence community as it concerns making the connections between information they had concerning the individual terrorist, his connection to Yemen, how and why things were missed that may have prevented him from being able to get on the plane in the first place, etc.  At the same time I’m trying to write a chapter on our library information systems, what they are, what are library catalogs today, objectives, FRBR, etc.  All of this brings to mind the complexity of an information system and the effect of that complexity on making those connections, the reliance and over-reliance on the technology (i.e., on commentator asked why the computer technology didn’t make the connection), and on human ability
 to make the connections, and so on.  !
If we shift that complexity to the kinds of information systems we in LIS create, populate, manipulate, maintain, and cross-connect to other systems---it begs the question of how much complexity can we expect to be able to maintain or work within?

As the organizers of the information (the raw data), our tools are description, authority control of names and headings, inclusion and exclusion of shared vocabulary, both natural language and controlled, our interpretation of the intentions of the resource creator from both ourselves and outside resources (i.e., agents on the ground, snitches, etc.), our judgment based on the experience, or inexperience, we have accumulated during our life, and the ability of the system to make these same types of judgment (based on how it’s been programmed).  On top of that we as the organizers also have to have a strong understanding of the system or variety of systems that we work within, as well as information needs and information seeking abilities (human information behavior) of the users of those systems.  Furthermore, we realize that we have no control over how that information is used, misused, or not used by the user---which logically would push us to make
 even richer representati!
ons as a way of attracting the user so they might use the information correctly and make those connections.

Shawne D. Miksa, Ph.D.
Associate Professor